杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=2
1.2.5
#include<stdio.h>
/*
题意:找闰年。
 if((i%4==0 && i%100!=0) || i%400==0)count++;
 3
2005 25
1855 12
2004 10000
2108
1904
43236
*/
int main()
{
	int t,y,n;
	int i,count=0;
	while(scanf("%d",&t)==1)
	{
		while(t--)
		{
			count = 0;
			scanf("%d%d",&y,&n);
			for (i=y;count<n;i++)
			{
				if((i%4==0 && i%100!=0) || i%400==0)
					count++;
			}
			printf("%d\n",i-1);
		}
	}
	return 0;
}
1.2.6
#include "stdafx.h"
/*
题意:计算每行1的个数
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0

2
5
*/
#include <cstdio>
#include <cstdlib>
#include <stdio.h>
int main(){
	int n, m, z;
	scanf("%d", &z);
	int c=0;
	//int r=0,g=0;
	int *r;
	while (z-- != 0)
	{
		scanf("%d%d", &n,&m);
		while(n-- != 0)
		{
			r = (int*)malloc(sizeof(int)*m);
			for (int i = 0; i < m;++i)
			{
				scanf("%d",r+i);
				if (r[i] == 1)
					c++;
			}
		}
		printf("%d\n", c);
		c = 0;
	}
	return 0;
}  
1.2.7
#include<stdio.h>
/*
题意:转10进制做加法
3
1(2)
2(3)
3(4)

4
11(10)
11(2)
11(3)
11(4)

6
23
*/
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int sum;

int pow(int x, int i)
{
    if(i == 0)
        return 1;
    else if(i == 1)
        return x;
    else
        return x * pow(x, i - 1);
}

void fun(int x, int n)
{
    int i = 0, p;
    while(x) {
        p = x % 10;
        sum += p * pow(n, i);
        x = x / 10;
        i++;
    }
}
int main( )
{
    int N, a,b, i;
    while(scanf("%d", &N)!=EOF)
	{
		sum = 0;
		for(i = 1; i <= N; i++)
		{
			scanf("%d(%d)",&a, &b);
			if (b == 10)
			{
				sum += a;
				continue;
			}
			fun(a, b);
		}
		printf("%d\n",sum);
    }
    return 0;
}
1.2.8
/*
题意:元音词,数组映射,aAeEiIoOuU
4
XYz
application
qwcvb
aeioOa

xyz
ApplIcAtIOn
qwcvb
AEIOOA
*/
#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
using namespace std;
int alpha[256];
int main(){
    int n;
    char text[55];
    alpha['a']=alpha['A']=alpha['e']=alpha['E']=alpha['i']=alpha['I']=alpha['o']=alpha['O']=alpha['u']=alpha['U']=1;
    while(scanf("%d",&n)!=EOF){
        while(n--){
            scanf("%s",text);
            int len=strlen(text);
            for(int i=0;i<len;++i){
                if(alpha[text[i]]){
                    putchar(toupper(text[i]));
                }else{
                    putchar(tolower(text[i]));
                }
            }
            puts("");
        }
    }
    return 0;
}

杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》,布布扣,bubuko.com

时间: 2024-10-07 00:53:18

杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》的相关文章

杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse&amp;#39; Trade》《今年暑假不AC》《排名》《开门人和关门人》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=3 1.3.1 FatMouse' Trade #include <algorithm> /* 题意:价值/代价的比值来排序,买比值大的. Sample Input 5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1 Sample Output 13.333 31.500 */ #include<stdio.h>

杭电OJ(HDU)-ACM Steps-Chapter Two-《Biker&#39;s Trip Odometer》《Climbing Worm》《hide handkerchief》《Nasty Hac》

1.2.1 Biker's Trip Odometer #include<stdio.h> #include<math.h> const double PI=acos(-1.0); /* 计算题,根据公式做就行,PI*d*r/(12*5280);res1/t*3600; Sample Input 26 1000 5 27.25 873234 3000 26 0 1000 Sample Output Trip #1: 1.29 928.20 Trip #2: 1179.86 1415

杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse&#39; Trade》《今年暑假不AC》《排名》《开门人和关门人》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=3 1.3.1 FatMouse' Trade #include <algorithm> /* 题意:价值/代价的比值来排序,买比值大的. Sample Input 5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1 Sample Output 13.333 31.500 */ #include<stdio.h>

『ACM C++』HDU杭电OJ | 1415 - Jugs (灌水定理引申)

今天总算开学了,当了班长就是麻烦,明明自己没买书却要带着一波人去领书,那能怎么办呢,只能说我善人心肠哈哈哈,不过我脑子里突然浮起一个念头,大二还要不要继续当这个班委呢,既然已经体验过就可以适当放下了吧,用心在自己的研究上.晚上级会开完也就八点多了,开始打打题,今天在HDU杭电的ACM集训题看到一个奇葩的题,前来献上. 今日推荐: <全球风暴> 一部宇宙航空和地球气候片的良心佳作,后期特效建模都是特别杠杠的大片,不会让你失望的哟,我已经三刷了哈哈哈.这部片在爱奇艺有上线,有兴趣的朋友可以看看鸭.

杭电oj 1009 FatMouse&#39; Trade

Tips:本题采用贪心算法,类似于背包问题,关键在于读入数据之后,将数据按 J[i]/F[i] 从大到小排列即可. 1 /**本程序主要采用贪心算法思想,类似于背包问题*/ 2 #include<stdio.h> 3 #include<string.h> 4 int main() 5 { 6 int M,N; 7 while(scanf("%d %d",&M,&N)) 8 { 9 if(M == -1 && N == -1) 10

异或^符号在C/C++中的使用 &amp; 杭电oj 2095

异或^符号,在平时的学习时可能遇到的不多,不过有时使用得当可以发挥意想不到的结果. 值得注意的是,异或运算是建立在二进制基础上的,所有运算过程都是按位异或(即相同为0,不同为1,也称模二加),得到最终结果. 特点:任何数和0异或都等于它本身;两个相同的数异或后的结果是0: 举例如下: int a = 4 =100(二进制) int b = 3 =011(二进制) int c = a^b = 111 = 7: 下面就^常用应用做个介绍: 1. 在一排数中找到独一无二的一个数 本例启发来自于杭电oj

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

杭电oj 1069 Monkey and Banana

Monkey and Banana Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6866 Accepted Submission(s): 3516 Problem Description A group of researchers are designing an experiment to test the IQ of a monkey

杭电oj 1002

1 #include <iostream> 2 #include <algorithm> 3 using namespace std; 4 int nCases; 5 int m[1001], n[1001]; 6 char a[1001], b[1001]; 7 int main() 8 { 9 scanf("%d", &nCases); 10 for(int i = 1; i <= nCases; ++i) 11 { 12 memset(m,