1032. Sharing (25)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of
a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9

67890 i 00002

00010 a 12345

00003 g -1

12345 D 67890

00002 n 00003

22222 B 23456

11111 L 00001

23456 e 67890

00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4

00001 a 10001

10001 s -1

00002 a 10002

10002 t -1

Sample Output 2:

-1

#include <iostream>
using namespace std;

int counts[100001];
int linkList[100001];
int target = -1;

int main() {
    int start1, start2;
    int n;

    for(int i=0; i<100001; i++) {
        counts[i] = 0;
        linkList[i] = -1;
    }
    cin>>start1>>start2>>n;
    if(start1 == start2) {
        printf("%05d\n", start1);
        return 0;
    }

    while(n--) {
        int value1, value2;
        char s2;
        cin>>value1>>s2>>value2;
        linkList[value1] = value2;
    }
    int i;
    for(i = start1; i!=-1; i = linkList[i]) {
        counts[i] = 1;
    }
    for(i = start2; i!=-1 && !counts[i]; i = linkList[i]) {
        counts[i] = 1;
    }
    if(i != -1) {
        printf("%05d\n", i);
    } else {
        printf("-1\n");
    }
    return 0;
}
时间: 2024-11-06 15:29:50

1032. Sharing (25)的相关文章

1032. Sharing (25)【链表】——PAT (Advanced Level) Practise

题目信息 1032. Sharing (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix.

PAT 1032. Sharing (25)

1032. Sharing (25) To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being

【PAT甲级】1032 Sharing (25分)

1032 Sharing (25分) To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored a

1032 Sharing (25分)(数组链表)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure

PAT:1032. Sharing (25) AC

#include<stdio.h> #include<stdlib.h> #include<string.h> struct node { char data; int next; bool tag; }Node[100066]; int main() { int add1,add2,n; //连表1首地址, scanf("%d%d%d",&add1,&add2,&n); memset(Node,0,sizeof(Node))

PAT (Advanced Level) 1032. Sharing (25)

简单题,不过数据中好像存在有环的链表...... #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<vector> using namespace std; const int maxn=100000+10

1032. Sharing (25) -set运用

题目如下: To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are st

PAT Advanced 1032 Sharing(25) [链表]

题目 To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same sufix. For example, "loading" and "being" are stored

pat1032. Sharing (25)

1032. Sharing (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if the