杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse' Trade》《今年暑假不AC》《排名》《开门人和关门人》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=3
1.3.1 FatMouse' Trade
#include <algorithm>
/*
题意:价值/代价的比值来排序,买比值大的。
Sample Input
5 3
7 2
4 3
5 2
20 3 25 18 24 15 15 10 -1 -1

Sample Output
13.333 31.500
*/
#include<stdio.h>
#include<stdlib.h>

const int MAXN = 1010;
struct node
{
    double j,f;
    double r;
}a[MAXN];
int cmp(const void *a,const void *b)
{
    struct node *c=(node *)a;
    struct node *d=(node *)b;
    if(c->r > d->r) return -1;
    else return 1;
}
int main()
{
    int N;
    double M;
    double ans;
    while(scanf("%lf%d",&M,&N))
    {
        if(M==-1&&N==-1) break;
        for(int i=0;i<N;i++)
        {
           scanf("%lf%lf",&a[i].j,&a[i].f);
           a[i].r=(double)a[i].j/a[i].f;
        }
        qsort(a,N,sizeof(a[0]),cmp);
        ans=0;
        for(int i=0;i<N;i++)
        {
            if(M>=a[i].f)
            {
                ans+=a[i].j;
                M-=a[i].f;
            }
            else
            {
                ans+=(a[i].j/a[i].f)*M;
                break;
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}    
1.3.2	今年暑假不AC
*
Sample Input
12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

Sample Output
5
*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>  

struct ti
{
    int s, e;
};  

int compare(const void *a, const void *b);  

int main()
{
    int i, n, k;
    struct ti tis[101], temp[101];  

    while(scanf("%d", &n) != EOF)
    {
        if(n == 0)
            break;  

        for(i = 0; i < n; i ++)
        {
            scanf("%d %d", &tis[i].s, &tis[i].e);
        }  

        qsort(tis, n, sizeof(tis[0]), compare);  

        k = 0;
        temp[k] = tis[0];  

        for(i = 1; i < n; i ++)
        {
            if(tis[i].s >= temp[k].e)
                temp[++ k] = tis[i];
        }
        printf("%d\n", k + 1);
    }
    return 0;
}  

int compare(const void *a, const void *b)
{
    const struct ti *p = (ti*)a;
    const struct ti *q = (ti*)b;  

    return p->e - q->e;
}  
1.3.3	排名

#include <string>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define N 1000
int que[10];
struct node
{
	char name[20];
	int num;
	int score;
}stu[N];

bool cmp(const node& a, const node& b)
{
	if (a.score == b.score)
	{
		return strcmp(a.name, b.name) < 0 ? 1:0;
	}
	else
	{
		return a.score > b.score;
	}
}

/* 联系字典序:第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;
第2行排序给出第1题至第M题的正整数分值;
以下N行,每行给出一名考生准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
*/
int main()
{
	int student, question, judge, x, count;
	while(scanf("%d", &student),student)
	{
		count = 0;
		for (int i = 1; i <= student;++i)
		{
			stu[i].score = 0;
			stu[i].num = 0;
		}
		scanf("%d%d",&question, &judge);
		for (int i = 1;i <= question;++i)
		{
			scanf("%d",&que[i]);
		}
		for (int i = 1;i <= student;++i)
		{
			scanf("%s%d",&stu[i].name,&stu[i].num);
			while(stu[i].num--)
			{
				scanf("%d",&x);
				stu[i].score += que[x];
			}
			if (stu[i].score >= judge)
				count ++;
		}
		sort(stu+1,stu+1+student,cmp);
		printf("%d\n",count);
		for (int i = 1;i <= student;++i)
		{
			if (stu[i].score >= judge)
				printf("%s %d\n",stu[i].name, stu[i].score);
			else
				break;
		}
	}
	return 0;
}

1.3.4 开门人和关门人
#include "stdafx.h"

#include <iostream>
#include <string>
using namespace std ;  

struct node
{
    string name, timee;
}maxt, mint;//记录最大和最小的结构体  

int main()
{
    int t, n;
    string s,mis, mas;
    cin>>t;  

    while (t--)
    {
        cin>>n;
        n--;
        cin>>s>>mint.timee>>maxt.timee;
        mint.name = maxt.name = s;  

        while (n--)
        {
            cin>>s>>mis>>mas;
            if (mis < mint.timee)
            {
                mint.name = s;
                mint.timee = mis;
            }
            if (mas > maxt.timee)
            {
                maxt.name = s;
                maxt.timee = mas;
            }
        }  

        cout<<mint.name<<" "<<maxt.name<<endl;
    }  

    return 0;
}

杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse' Trade》《今年暑假不AC》《排名》《开门人和关门人》

时间: 2024-10-03 13:45:24

杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse' Trade》《今年暑假不AC》《排名》《开门人和关门人》的相关文章

杭电OJ(HDU)-ACMSteps-Chapter Three-《FatMouse&amp;#39; Trade》《今年暑假不AC》《排名》《开门人和关门人》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=3 1.3.1 FatMouse' Trade #include <algorithm> /* 题意:价值/代价的比值来排序,买比值大的. Sample Input 5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1 Sample Output 13.333 31.500 */ #include<stdio.h>

杭电OJ(HDU)-ACMSteps-Chapter Two-《An Easy Task》《Buildings》《decimal system》《Vowel Counting》

http://acm.hdu.edu.cn/game/entry/problem/list.php?chapterid=1§ionid=2 1.2.5 #include<stdio.h> /* 题意:找闰年. if((i%4==0 && i%100!=0) || i%400==0)count++; 3 2005 25 1855 12 2004 10000 2108 1904 43236 */ int main() { int t,y,n; int i,count=0; whil

杭电OJ(HDU)-ACM Steps-Chapter Two-《Biker&#39;s Trip Odometer》《Climbing Worm》《hide handkerchief》《Nasty Hac》

1.2.1 Biker's Trip Odometer #include<stdio.h> #include<math.h> const double PI=acos(-1.0); /* 计算题,根据公式做就行,PI*d*r/(12*5280);res1/t*3600; Sample Input 26 1000 5 27.25 873234 3000 26 0 1000 Sample Output Trip #1: 1.29 928.20 Trip #2: 1179.86 1415

I题 hdu 1234 开门人和关门人

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1234 开门人和关门人 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12183    Accepted Submission(s): 6157 Problem Description 每天第一个到机房的人要把门打开,最后一个离开的人要把门关

HDU 1234 开门人和关门人

开门人和关门人 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10622    Accepted Submission(s): 5419 Problem Description 每天第一个到机房的人要把门打开,最后一个离开的人要把门关好.现有一堆杂乱的机房签 到.签离记录,请根据记录找出当天开门和关门的人. Input 测试输入的第一

hdu 开门人和关门人

/* * hdu OpenDoorManAndCloseDoorMan * date 2014/5/13 * state AC */ #include <iostream> #include <fstream> #include <algorithm> #include <vector> using namespace std; struct DoorMan { char name[20]; int startH,startM,startS; int end

杭电 HDU 1234 开门人和关门人

开门人和关门人 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11717    Accepted Submission(s): 5949 Problem Description 每天第一个到机房的人要把门打开,最后一个离开的人要把门关好.现有一堆杂乱的机房签 到.签离记录,请根据记录找出当天开门和关门的人. Input 测试输入的第一

九度OJ刷题——1013:开门人和关门人

题目描述:     每天第一个到机房的人要把门打开,最后一个离开的人要把门关好.现有一堆杂乱的机房签到.签离记录,请根据记录找出当天开门和关门的人. 输入: 测试输入的第一行给出记录的总天数N ( N> 0 ),下面列出了N天的记录.     每天的记录在第一行给出记录的条目数M (M > 0 ),下面是M行,每行的格式为 证件号码 签到时间 签离时间 其中时间按"小时:分钟:秒钟"(各占2位)给出,证件号码是长度不超过15的字符串. 输出: 对每一天的记录输出1行,即当天

HDU 1234开门人和关门人。

开门人和关门人 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11372    Accepted Submission(s): 5786 Problem Description 每天第一个到机房的人要把门打开,最后一个离开的人要把门关好.现有一堆杂乱的机房签 到.签离记录,请根据记录找出当天开门和关门的人. Input 测试输入的第一