poj 2253 最短路 or 最小生成树

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.
    Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
    To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence.
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone.
Input
    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
    0 0
    3 4

3
    17 4
    19 4
    18 5

0

Sample Output

Scenario #1
    Frog Distance = 5.000

Scenario #2
    Frog Distance = 1.414

题意 : 要求青蛙从第一个点跳到第二个点,其他的点作为跳板,可以选择跳或者不跳。问最小权值中的最大值是多少。

注意 : 这题wA 了好久,因为精度的问题,c++交可以过,g++就wa了

   还有 sqrt(x), 里面的 x得是浮点型的数,不然交的时候给你提示编译错误

代码:

const int inf = 1<<29;
struct qnode
{
    double x, y;
}arr[205];
int n;
double fun(int i, int j){
    double ff = sqrt((arr[i].x - arr[j].x)*(arr[i].x - arr[j].x) + (arr[i].y - arr[j].y)*(arr[i].y - arr[j].y));
    return ff;
}
double edge[205][205];
double ans;

struct node
{
    int v;
    double c;
    node(int _v, double _c):v(_v), c(_c){}
    friend bool operator< (node n1, node n2){
        return n1.c > n2.c;
    }
};
double d[205];
bool vis[205];

void prim(){
    ans = 0;
    priority_queue<node>que;
    while(!que.empty()) que.pop();
    for(int i = 1; i <= n; i++){
        d[i] = edge[1][i];
        que.push(node(i, d[i]));
    }
    memset(vis, false, sizeof(vis));
    while(!que.empty()){
        node tem = que.top();
        que.pop();
        int v = tem.v;
        double c = tem.c;

        ans = max(ans, c);
        if (v == 2) return;
        if (vis[v]) continue;
        vis[v] = true;;
        for(int i = 1; i <= n; i++){
            if (!vis[i] && edge[v][i] < d[i]){
                d[i] = edge[v][i];
                que.push(node(i, d[i]));
            }
        }
    }
}

int main() {

    int k = 1;
    while(~scanf("%d", &n) && n){
        for(int i = 1; i <= n; i++){
            scanf("%lf%lf", &arr[i].x, &arr[i].y);
        }
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++)
                edge[i][j] = inf;
        }
        for(int i = 1; i <= n; i++){
            for(int j = i+1; j <= n; j++){
                double len = fun(i, j);
                edge[i][j] = edge[j][i] = len;
            }
        }
        prim();
        printf("Scenario #%d\n", k++);
        printf("Frog Distance = %.3f\n\n", ans);
    }
    return 0;
}
时间: 2024-10-31 20:21:32

poj 2253 最短路 or 最小生成树的相关文章

poj 2253 最短路floyd **

题意:有两只青蛙和若干块石头,现在已知这些东西的坐标,两只青蛙A坐标和青蛙B坐标是第一个和第二个坐标,现在A青蛙想要到B青蛙那里去,并且A青蛙可以借助任意石头的跳跃,而从A到B有若干通路,问从A到B的所有通路上的最大边 链接:点我 floyd变形即可 1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm> 4 #include<cstring> 5 #include<cmath>

Floyd-Warshall算法(求解任意两点间的最短路) 详解 + 变形 之 poj 2253 Frogger

/* 好久没有做有关图论的题了,复习一下. --------------------------------------------------------- 任意两点间的最短路(Floyd-Warshall算法) 动态规划: dp[k][i][j] := 节点i可以通过编号1,2...k的节点到达j节点的最短路径. 使用1,2...k的节点,可以分为以下两种情况来讨论: (1)i到j的最短路正好经过节点k一次 dp[k-1][i][k] + dp[k-1][k][j] (2)i到j的最短路完全

poj 2253 Frogger (最长路中的最短路)

链接:poj 2253 题意:给出青蛙A,B和若干石头的坐标,现青蛙A想到青蛙B那,A可通过任意石头到达B, 问从A到B多条路径中的最长边中的最短距离 分析:这题是最短路的变形,以前求的是路径总长的最小值,而此题是通路中最长边的最小值,每条边的权值可以通过坐标算出,因为是单源起点,直接用SPFA算法或dijkstra算法就可以了 SPFA 16MS #include<cstdio> #include<queue> #include<cmath> #include<

poj 2253 Frogger (dijkstra最短路)

题目链接:http://poj.org/problem?id=2253 Frogger Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 25773   Accepted: 8374 Description Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on an

poj 2253(3种最短路搞法)

T - Frogger Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2253 Appoint description:  System Crawler  (2014-08-24) Description Freddy Frog is sitting on a stone in the middle of a lake. Suddenl

poj 2253 Frogger [dijkstra]

传送门:http://poj.org/problem?id=2253 Frogger Description Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists

[2016-04-02][POJ][2253][Frogger]

时间:2016-04-02 17:55:33 星期六 题目编号:[2016-04-02][POJ][2253][Frogger] 题目大意:给定n个点的坐标,问从起点到终点的所有路径中,最大边的最小值是多少,即每一步至少是多少才能走到终点 分析: 方法1: 枚举出完全图,然后从起点跑一次Dijkstra算法,不过选点不再是选择起点到终点路径的点,而是起点到终点的路径中,边最大边最小的点,即d数组保存起点到当前点的路径中最大边的最小值, 最大边的最小值:u->v d[v] = min(d[i],m

poj 2253 Frogger 解题报告

题目链接:http://poj.org/problem?id=2253 题目意思:找出从Freddy's stone  到  Fiona's stone  最短路中的最长路. 很拗口是吧,举个例子.对于 i 到 j 的一条路径,如果有一个点k, i 到 k 的距离 && k 到 j 的距离都小于 i 到 j 的距离,那么就用这两条中较大的一条来更新 i 到 j 的距离 .每两点之间都这样求出路径.最后输出 1 到 2 的距离(1:Freddy's stone   2:Fiona's sto

【POJ 2253】Frogger

[POJ 2253]Frogger 求起点到终点的通路中每天路的最大权中的最小值 最短路保证最大权联通求最小值(最短) Floyd 524K 79MS 1170B #include using namespace std; typedef struct Point { int x,y; }Point; Point p[233]; double dis[233][233]; int n; int dcmp(double x) { return x < -esp? -1: x > esp; } d