杭电 1698 Just a Hook(线段树区间修改)

http://acm.hdu.edu.cn/showproblem.php?pid=1698

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17322    Accepted Submission(s): 8640

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

看这个题的时候接触线段树不久,线段树对我来说比较难理解,学长讲了好久才觉得好像懂了那么一点,现在也还是不太能灵活运用(T_T)

题意是给定n根筷子,初始时筷子的价值都是1,后面改变筷子的价值,x,y,z,意思是把第x到第y根筷子的值变为z,最后输出所有筷子价值的总和。

感觉还是有点模糊,不怎么好讲。。。

AC代码:

#include<stdio.h>
#include<iostream>
#define L(u) (u<<1)    //u*2
#define R(u) (u<<1|1)  //u*2+1

const int M=100010;

struct Node
{
    int l,r;
    int add,sum;  //
}node[M*4];
//int a[M];

void pushdown(int u)    //下分
{
    node[L(u)].add=node[u].add;
    node[L(u)].sum=(node[L(u)].r-node[L(u)].l+1)*node[u].add;
    node[R(u)].add=node[u].add;
    node[R(u)].sum=(node[R(u)].r-node[R(u)].l+1)*node[u].add;
    node[u].add=0;    //分完之后归0,以防出错
}
void build(int i,int left,int right)
{
    node[i].l=left;
    node[i].r=right;
    node[i].add=0;
    if(node[i].l==node[i].r)
    {
        node[i].sum=1;
        return;
    }
    int mid=(node[i].l+node[i].r)/2;
    build(L(i),left,mid);
    build(R(i),mid+1,right);
    node[i].sum=node[L(i)].sum+node[R(i)].sum;
}

void update(int u,int left,int right,int val)
{
    if(left<=node[u].l&&node[u].r<=right)  //建树中的区间在给出的区间内
    {
        node[u].add=val;
        node[u].sum=(node[u].r-node[u].l+1)*val;  //注意之处,这个区间的值是这么计算的
        return ;
    }
    //node[u].sum=(right-left+1)*val;
    if(node[u].add) pushdown(u);       //节点的单位值不为0,下分
    int mid=(node[u].l+node[u].r)/2;    //建树节点(区间)的中间值
    if(right<=mid) update(L(u),left,right,val);  //给出的右端点(较大值)小于
    else if(left>mid) update(R(u),left,right,val);//
    else
    {
        update(L(u),left,mid,val);   //跨越了两个子区间的,但是又没有完全包括的
        update(R(u),mid+1,right,val);
    }
    node[u].sum=node[L(u)].sum+node[R(u)].sum;
}

int query(int u,int left,int right)
{
     if(left<=node[u].l&&node[u].r<=right)
    {
        return node[u].sum;
    }
    if(node[u].add) pushdown(u);
    int mid=(node[u].l+node[u].r)/2;
     if(right<=mid) return query(L(u),left,right);
    else if(left>mid) return query(R(u),left,right);
    else return (query(L(u),left,mid)+query(R(u),mid+1,right));
}

int main()
{
    int T,n,m,i,x,y,z;
    int k=0;
    scanf("%d",&T);
    while(T--)
    {
        k++;
         scanf("%d%d",&n,&m);
         build(1,1,n);
         for(i=0;i<m;i++)
         {
             scanf("%d%d%d",&x,&y,&z);
             update(1,x,y,z);
         }
         printf("Case %d: The total value of the hook is %d.\n",k,query(1,1,n));
    }
    return 0;
}

杭电 1698 Just a Hook(线段树区间修改)

时间: 2024-10-11 20:50:44

杭电 1698 Just a Hook(线段树区间修改)的相关文章

HDU 1698 Just a Hook (线段树,区间更新)

Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 17214    Accepted Submission(s): 8600 Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing f

HDU 1698 Just a Hook(线段树区间替换)

题目地址:HDU 1698 区间替换裸题.同样利用lazy延迟标记数组,这里只是当lazy下放的时候把下面的lazy也全部改成lazy就好了. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h> #in

hdu 1698 Just a Hook 线段树区间更新

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698 Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks

HDU 1698 Just a Hook (线段树 区间更新基础)

Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 21856    Accepted Submission(s): 10963 Problem Description In the game of DotA, Pudge's meat hook is actually the most horrible thing

(简单) HDU 1698 Just a Hook , 线段树+区间更新。

Description: In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on the hook

[HDU] 1698 Just a Hook [线段树区间替换]

Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 18378    Accepted Submission(s): 9213 Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing f

HDU 1698 Just a Hook 线段树区间更新、

来谈谈自己对延迟标记(lazy标记)的理解吧. lazy标记的主要作用是尽可能的降低时间复杂度. 这样说吧. 如果你不用lazy标记,那么你对于一个区间更新的话是要对其所有的子区间都更新一次,但如果用lazy标记的话. 就只需要更新这一个区间然后加一个标记,那么如果要访问这个区间的子区间,因为有lazy标记,所以下次访问会将区间的lazy标记传递给子区间,让后去更新子区间,这样我们不必在每次区间更新操作的时候更新该区间的全部子区间,等下次查询到这个区间的时候只需要传递lazy标记就可以了 但从时

HDU 1698 Just a Hook (线段树区间更新)

Problem Description In the game of DotA, Pudge's meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on t

HDU - 1698 Just a Hook(线段树区间整体修改值,查询区间和)

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on the hook. Let us numb