PAT 1067. 试密码
当你试图登录某个系统却忘了密码时,系统一般只会允许你尝试有限多次,当超出允许次数时,账号就会被锁死。本题就请你实现这个小功能。
入格式:
输入在第一行给出一个密码(长度不超过20的、不包含空格、Tab、回车的非空字符串)和一个正整数N(<= 10),分别是正确的密码和系统允许尝试的次数。随后每行给出一个以回车结束的非空字符串,是用户尝试输入的密码。输入保证至少有一次尝试。当读到一行只有单个#字符时,输入结束,并且这一行不是用户的输入。
输出格式:
对用户的每个输入,如果是正确的密码且尝试次数不超过N,则在一行中输出“Welcome in”,并结束程序;如果是错误的,则在一行中按格式输出“Wrong password: 用户输入的错误密码”;当错误尝试达到N次时,再输出一行“Account locked”,并结束程序。
输入样例1:
Correct%pw 3
correct%pw
[email protected]
whatisthepassword!
Correct%pw
#
输出样例1:
Wrong password: correct%pw
Wrong password: [email protected]
Wrong password: whatisthepassword!
Account locked
输入样例2:
[email protected] 3
[email protected]
[email protected]
[email protected]
try again
#
输出样例2:
Wrong password: [email protected]
Wrong password: [email protected]
Welcome in
分析
一开始老是A不掉,因为是代码逻辑问题,老是改动代码,结果是必须用getline,不清楚为什么
代码如下
#include<iostream>
using namespace std;
int main(){
string password,input="";
int try_times,cnt=0;
cin>>password>>try_times;
getchar();
while(1){
getline(cin,input);
if(input=="#") break;
cnt++;
if(input==password&&cnt<=try_times){
cout<<"Welcome in"<<endl;
break;
}else if(input!=password&&cnt<=try_times){
cout<<"Wrong password: "<<input<<endl;
if(cnt==try_times){
cout<<"Account locked"<<endl;
break;
}
}
}
return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8142951.html
时间: 2024-10-14 06:22:05