Description
Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.
When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.
Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
Input
The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.
Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output
The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.
Sample Input
3 2 1
2 2 3
2 3 1
2 1 2
Sample Output
0
一开始想复杂了,以为会有可能把方向扳回去的情况。其实只要把扳过去的次数当成边的权值就行,然后直接最短路
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1010
#define Mod 10001
using namespace std;
int map[1005][1005],cost[1005][1005],vis[1005],dis[1005],n,m;
int p[MAXN],level[MAXN];
void dijkstra(int s)
{
int i,j,min,v;
for(i=1; i<=n; ++i)
{
dis[i]=map[s][i];
}
vis[s]=1;
for(i=1; i<=n; ++i)
{
min=INF;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&dis[j]<min)
{
min=dis[j];
v=j;
}
}
vis[v]=1;
for(j=1; j<=n; ++j)
{
if(!vis[j]&&map[v][j]<INF)
{
if(dis[j]>dis[v]+map[v][j])
{
dis[j]=dis[v]+map[v][j];
}
}
}
}
}
int main()
{
int a,b,k,ki;
while(~scanf("%d%d%d",&n,&a,&b))
{
for(int i=1;i<=n;++i)
for(int j=1;j<=n;++j)
map[i][j]=INF;
for(int i=1;i<=n;++i)
{
scanf("%d",&k);
for(int j=0;j<k;++j)
{
scanf("%d",&ki);
if(j==0)
map[i][ki]=0;
else
map[i][ki]=1;
}
}
dijkstra(a);
if(dis[b]<INF)
printf("%d\n",dis[b]);
else
printf("-1\n");
}
return 0;
}