HDU 5437 Alisha’s Party

题目链接:

http://acm.split.hdu.edu.cn/showproblem.php?pid=5437

Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Biis the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1

5 2 3

Sorey 3

Rose 3

Maltran 3

Lailah 5

Mikleo 6

1 1

4 2

1 2 3

Sample Output

Sorey Lailah Rose

 Hint:

题意:

给出k,m,q。k表示参加聚会的人数,m表示会开门的次数,q表示询问的次数。

m中有t,p。表示当到达会场的人数达到t的时候,就有p个人可以进入。

题解:

优先队列加模拟。

代码:

#include <cmath>
#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 150000+10;
#define met(a,b) memset(a,b,sizeof(a))
char ans[maxn][200+10];
struct node
{
    char name[200+10];
    int time;
    int val;
    friend bool operator < (node a,node b)
    {
        if(a.val==b.val)
            return a.time>b.time;
        return a.val<b.val;
    }
}s[maxn];
struct node1
{
    int t,p;
}d[maxn];
int cmp(node1 a,node1 b)
{
    return a.t<b.t;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int k,m,q;
        scanf("%d%d%d",&k,&m,&q);
        for(int i=1;i<=k;i++)
        {
            scanf("%s %d",s[i].name,&s[i].val);
            s[i].time=i;
        }
        for(int i=1;i<=m;i++)
            scanf("%d%d",&d[i].t,&d[i].p);
        sort(d+1,d+1+m,cmp);
        priority_queue<node>que;
        while(!que.empty())
            que.pop();
        int j=1,l=1;
        for(int i=1;i<=m;i++)
        {
            while(j<=k&&j<=d[i].t)
            {
                que.push(s[j]);
                j++;
            }
            int num=d[i].p;
            while(!que.empty()&&num--)
            {
                node a=que.top();
                que.pop();
                strcpy(ans[l++],a.name);
            }
        }
        while(j<=k)
        {
            que.push(s[j]);
            j++;
        }
        while(!que.empty())
        {
            node a=que.top();
            que.pop();
            strcpy(ans[l++],a.name);
        }
        for(int i=1;i<=q;i++)
        {
            int x;
            scanf("%d",&x);
            if(i!=q)
                printf("%s ",ans[x]);
            else
                printf("%s\n",ans[x]);
        }
    }
}
时间: 2024-10-27 09:49:34

HDU 5437 Alisha’s Party的相关文章

hdu 5437 Alisha’s Party (优先队列)

http://acm.hdu.edu.cn/showproblem.php?pid=5437 题目意思比较好理解,如果暴力的话或超时,可以考虑到用优先队列就可以很简单的解决问题 1 #include<queue> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 using namespace std; 6 struct point { 7 int x,id; 8 char na[2

Hdu 5437 Alisha’s Party(模拟)

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=5437 思路:优先队列模拟,注意最后一次门外人全部进入. #include<cstdio> #include<queue> #include<cstring> #include<iostream> #include<algorithm> #define debu using namespace std; const int maxn=150000+50

hdu 5437 Alisha’s Party 模拟 优先队列

Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a

hdu 5437 Alisha’s Party (线段树)

Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a

HDU 5437 &amp; ICPC 2015 Changchun Alisha&#39;s Party(优先队列)

Alisha’s Party Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 7971    Accepted Submission(s): 1833 Description Princess Alisha invites her friends to come to her birthday party. Each of her f

HDU OJ 5437 Alisha’s Party 2015online A

题目:click here 题意: 邀请k个朋友,每个朋友带有礼物价值不一,m次开门,每次开门让一定人数p(如果门外人数少于p,全都进去)进来,当最后所有人都到了还会再开一次门,让还没进来的人进来,每次都是礼物价值高的人先进.最后给出q个数,表示要输出第ni个进来的人的名字. 分析: 优先队列问题.注意优先队列的比较函数即出队顺序, 1 #include <iostream> 2 #include <cstdio> 3 #include <queue> 4 #inclu

2015长春现场赛

1.Alisha’s Party(hdu 5437) 优先队列模拟,共k个人,每个人有一个价值,m次进入,每次价值最大的进去,价值相同id小的先进去,a b前a个没进去的人进去b个,不够b个,都进去,m次操作后,剩下的都进去,最后输出查询的第i个进去的人的名字 需要注意的是,m是乱序给的,需要按照a进行排序 #include<bits/stdc++.h> using namespace std; const int maxn=150005; char name[maxn][205]; type

15年-ICPC长春-网络赛

ID name status one word    POJ 5437 Alisha’s Party 赛后AC. 优先队列,模拟.对时间t排序 #include <stdio.h> #include <string.h> #include <iostream> #include <algorithm> #include <queue> using namespace std; struct Node { char name[210]; int v

Alisha&#39;s Party

Alisha's Party Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5437 Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of