POJ 2431 Expedition (贪心 + 优先级队列)

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7696   Accepted: 2260

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold

题意:以汽车要行驶距离L的路程,路上有n个加油站,车从起点出发,在起点时,车上有汽油容量为p,已知单位距离1,就会消耗汽油1,已知n个加油站距离终点的距离和各个加油站可以加的油量,然后问最少需要加多少次油可以到达终点,若不能到达终点,输出“-1”。

解析:按照贪心的思想,我们肯定是尽可能的把油用完了再加,但是每个加油站的加油量有区别,这样就不能简单的贪心了。我们可以这样看,由于不知道什么时候加最合适,所以我们可以先把那些途经的加油站的油量全部放到优先级队列里,到后来需要的时候再加上,就相当于是经过那个站的时候把油给加上了,效果是一样的。这样就可以了,每次加的都是油量最大的,所以最后的加油次数就是最少的。

AC代码:

#include <cstdio>
#include <queue>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 10002

int a[maxn], b[maxn];
struct node{ int a; int b; };        //加油站结构体,位置a,油量b
node m[maxn];

bool cmp(node x, node y){            //自己定义排序函数,先按位置升序排,相等时再按油量降序
    if(x.a == y.a) return x.b > y.b;
    return x.a < y.a;
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk

    int n, l, p;
    while(scanf("%d", &n)!=EOF){
        for(int i=0; i<n; i++) scanf("%d%d", &m[i].a, &m[i].b);
        scanf("%d%d", &l, &p);
        for(int i=0; i<n; i++) m[i].a = l - m[i].a;          //处理读入的数据,将位置转化为据起点的位置
        m[n].a = l;               //方便起见,把终点也看作一个加油站
        m[n].b = 0;
        n ++;

        sort(m, m+n, cmp);                  //加油站按位置排序
        priority_queue<int> q;
        int flag = 1;
        int ans = 0, pos = 0, tank = p;     //加油次数ans,车的位置pos,车上剩余油量tank
        for(int i=0; i<n; i++){
            int d = m[i].a - pos;           //接下来要行进的距离
            while(tank < d){                //不断加油,直到油量足够行驶到下一个加油站
                if(q.empty()){              //未到加油站就没油了,代表不能完成任务了
                    flag = 0;
                    break;
                }
                tank += q.top();
                q.pop();
                ans ++;
            }
            if(!flag) break;
            tank -= d;
            pos = m[i].a;
            q.push(m[i].b);                 //将途经加油站的油量放入优先级队列
        }
        printf("%d\n", flag ? ans : -1);
    }
    return 0;
}

PS:优先级队列(priority_queue)很神奇,很好用,内部用堆实现的,所以时间复杂度还是很优的~~~

时间: 2024-10-12 15:55:17

POJ 2431 Expedition (贪心 + 优先级队列)的相关文章

POJ 2431 Expedition 贪心 优先级队列

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 30702   Accepted: 8457 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed t

poj 2431 Expedition 贪心+最大堆

当油量不够时从走过的油站中选最大加油量的 #include<iostream> #include<queue> #include<stdlib.h> #include<algorithm> using namespace std; #define MAX_N 10005 struct node{ int dist,fuel; }t[MAX_N]; bool cmp(const node &a,const node &b) { return a

POJ 2431 Expedition (STL 优先权队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8053   Accepted: 2359 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

poj 2431 Expedition 贪心+优先队列

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7707   Accepted: 2263 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

POJ 2431 Expedition 贪心

题意:一辆汽车由起点开往小镇,总路程为L,路上有N个加油站,第i个加油站距离小镇a[i],最多可为提供b[i]的汽油,汽车开始时有P单位汽油,问汽车内否到达小镇,若能到达输出最小的加油次数. 思路:每经过一个加油站i,汽车就获得了一次在任何时候加油b[i]的权利,当汽车不足以到达下一站时,就加入过往的最大的b值. #include<stdio.h> #include<queue> #include<iostream> #include<algorithm>

poj 2431 Expedition (贪心+优先队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6890   Accepted: 2065 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

POJ 3253 Fence Repair 贪心 优先级队列

Fence Repair Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 77001   Accepted: 25185 Description Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000)

poj 2431 Expedition(优先队列)

题目链接 http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9243   Accepted: 2700 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

BNUOJ 44662 水题 (贪心+优先级队列)

水题 Time Limit: 500ms Memory Limit: 32768KB This problem will be judged on HRBUST. Original ID: 2223 64-bit integer IO format: %lld      Java class name: Main Prev Submit Status Statistics Discuss Next 因为是有关于接水的问题,便简称为水题了(. N个人排队在M个出水口前接水,第i个人接水需时为t[i