POJ 2528——Mayor's posters——————【线段树区间替换、找存在的不同区间】

Mayor‘s posters

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit Status Practice POJ 2528

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题目大意:在一块儿宣传栏中贴宣传单,规定宽度相同,长度不同。按一定顺序贴,给出宣传单的起始和结束位置,这里位置不能忽略成点(而是一段长度),问最后会看到几个宣传单。

解题思路:由于给出的数据范围多大,所以要先进行离散化减少复杂度,因为这里给出的不是”点“是带长度的,所以一般的离散化会出现离散失真,这里可以在离散的时候增加技巧,即在不相邻的数据里增加分隔点,凸显不连续。然后进行线段树成段替换,最后求出整个区间的不同宣传单个数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mid (L+R)/2
#define lson rt*2,L,mid
#define rson rt*2+1,mid+1,R
const int maxn=50000;
int lm[maxn/2],rm[maxn/2];
int col[maxn*4];
int Hash[maxn];
int A[maxn];
int num=0;
int discretization(int l,int r,int key){    //离散化

    while(l<=r){

        int m=(l+r)/2;
        if(key==A[m]){

            return m;
        }else if(key<A[m]){

            r=m-1;
        }else{

            l=m+1;
        }
    }
}
void PushDown(int rt){

    if(col[rt]!=-1){

        col[rt*2]=col[rt];
        col[rt*2+1]=col[rt];
        col[rt]=-1;
    }
}
void update(int rt,int L,int R,int l_ran,int r_ran,int _col){

    if(l_ran<=L&&R<=r_ran){

        col[rt]=_col;
        return ;
    }
    PushDown(rt);
    if(l_ran<=mid)
        update(lson,l_ran,r_ran,_col);
    if(r_ran>mid)
    update(rson,l_ran,r_ran,_col);
}
void query(int rt,int L,int R){

    if(col[rt]!=-1){

        if(!Hash[col[rt]]){

            num++;
            Hash[col[rt]]=1;
        }
        return ;
    }
    if(L==R)
        return ;
    query(lson);
    query(rson);
}
void debug(){

    for(int i=1;i<32;i++){

        printf("%d %d\n",i,col[i]);
    }
}
int main(){

    int t;
    scanf("%d",&t);
    while(t--){

        int n,nn=0,m;
        scanf("%d",&n);
        for(int i=0;i<n;i++){

            scanf("%d%d",&lm[i],&rm[i]);
            A[nn++]=lm[i];
            A[nn++]=rm[i];
        }
        sort(A,A+nn);
        m=1;
        for(int i=0;i<nn-1;i++){    //去重

            if(A[i]!=A[i+1]){

                A[m++]=A[i+1];
            }
        }
        for(int i=m-1;i>0;i--){     //添加分隔点

            if(A[i]!=A[i-1]+1){

                A[m++]=A[i-1]+1;
            }
        }
        sort(A,A+m);
        int tml,tmr;
        memset(col,-1,sizeof(col));
        for(int i=0;i<n;i++){

           tml= discretization(0,m-1,lm[i]);    //离散化
           tmr= discretization(0,m-1,rm[i]);    //离散化
           update(1,0,m-1,tml,tmr,i);
        }
      //  debug();
        memset(Hash,0,sizeof(Hash));
        num=0;
        query(1,0,m-1);
        printf("%d\n",num);
    }
    return 0;
}

  

POJ 2528——Mayor's posters——————【线段树区间替换、找存在的不同区间】

时间: 2024-08-10 23:20:46

POJ 2528——Mayor's posters——————【线段树区间替换、找存在的不同区间】的相关文章

POJ 2528 Mayor&#39;s posters (线段树区间更新+离散化)

题目链接:http://poj.org/problem?id=2528 给你n块木板,每块木板有起始和终点,按顺序放置,问最终能看到几块木板. 很明显的线段树区间更新问题,每次放置木板就更新区间里的值.由于l和r范围比较大,内存就不够了,所以就用离散化的技巧 比如将1 4化为1 2,范围缩小,但是不影响答案. 写了这题之后对区间更新的理解有点加深了,重点在覆盖的理解(更新左右两个孩子节点,然后值清空),还是要多做做题目. 1 #include <iostream> 2 #include <

poj 2528 Mayor&#39;s posters 线段树区间更新

Mayor's posters Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 http://poj.org/problem?id=2528 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at al

POJ 2528 Mayor&#39;s posters(线段树,区间覆盖,单点查询)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 45703   Accepted: 13239 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

Poj 2528 Mayor&#39;s posters (线段树+离散化)

题目连接: http://poj.org/problem?id=2528 题目大意: 有10000000块瓷砖,n张海报需要贴在墙上,每张海报所占的宽度和瓷砖宽度一样,长度是瓷砖长度的整数倍,问按照所给海报顺序向瓷砖上贴海报,最后有几张海报是可见的? 解题思路: 因为瓷砖块数和海报张数多,首选线段树,如果按照常规的建树方式,把瓷砖当做数的节点,肯定会MTL......... 所以我们可以用海报的起点和终点当做树的节点,这样树的节点才有20000个,但是这样建树的话,求海报覆盖了那些节点会很复杂,

poj 2528 Mayor&#39;s posters(线段树)

题目链接:http://poj.org/problem?id=2528 思路分析:线段树处理区间覆盖问题,也可以看做每次给一段区间染不同的颜色,最后求在整段区间上含有的所有颜色种类数: 注意由于区间太大,所以需要离散化: 区间更新:对于线段树的每个结点,标记颜色,初始时没有颜色,标记为0:当更新时,使用延迟标记,需要标记传递到子节点: 区间查询:使用深度优先查询线段树,当某个子节点的颜色不为0时,即停止深度优先搜索,并在map中查询是否已经记录该段区间的颜色: 代码如下: #include <i

POJ 2528 Mayor&#39;s posters 线段树成段更新+离散化

题目来源:POJ 2528 Mayor's posters 题意:很多张海报贴在墙上 求可以看到几张海报 看那两张图就行了 第一张俯视图 思路:最多2W个不同的数 离散化一下 然后成段更新 a[rt] = i代表这个区间是第i张报纸 更新玩之后一次query cover[i]=1代表可以看到第i张报纸 #include <cstdio> #include <algorithm> #include <cstring> using namespace std; const

POJ 2528 Mayor&#39;s posters(线段树区间染色+离散化或倒序更新)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 59239   Accepted: 17157 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post

POJ 2528 Mayor&#39;s posters 区间离散化线段树

点击打开链接 Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 45894   Accepted: 13290 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their elector

poj 2528 Mayor&#39;s posters (线段树+区间离散)

Mayor's posters Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 45031   Accepted: 13080 Description The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral post