hdu 4004 The Frog's Games 【二分】

The Frog‘s Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 4565    Accepted Submission(s): 2225

Problem Description

The annual Games in frogs‘ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000).
There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog‘s longest jump distance).

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m.

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output

For each case, output a integer standing for the frog‘s ability at least they should have.

Sample Input

6 1 2
2
25 3 3
11
2
18

Sample Output

4
11

根据题意很容易知道解的单调性,我们只需要对最远跳跃距离在 [0,L]范围内进行二分即可。

#include <queue>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 500000+5;
const int INF = 1000000000+5;
int L,n,m;
int stone[maxn];
bool judge(const int& x) {
    if(x*m < L) return false;
    if(x >= L) return true;
    for(int i = 0;i <= n+1;i++)
        if(i!=n+1&&stone[i+1]-stone[i] > x) return false;
    int step = 0;
    for(int i = 0,j;i < n+1;)
    {
        for(j = i+1;j <= n+1 && stone[j]-stone[i] <= x;)   //求当前解下需要最少的步数
            if(j+1 <= n+1 && stone[j+1]-stone[i] <= x) j++;
            else break;
        i = j;
        step++;
    }
    return step <= m;
}
int main() {
    //freopen("input.in","r",stdin);
    while(~scanf("%d %d %d",&L,&n,&m))
    {
        stone[0] = 0;
        for(int i = 1;i <= n;i++) scanf("%d",&stone[i]);
        sort(stone+1,stone+n+1);
        stone[n+1] = L;
        int l = 0,r = L+1,mid;
        while(r-l>=1)
        {
            mid = l+((r-l)>>1);
            if(judge(mid))  r = mid;
            else l = mid+1;
        }
        printf("%d\n",l);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 4004 The Frog's Games 【二分】

时间: 2024-10-06 00:16:19

hdu 4004 The Frog's Games 【二分】的相关文章

HDU 4004 The Frog&#39;s Games 二分 贪心

戳这里:HDU 4004 //思路:二分经典入门题...贪心判方案是否可行 1 #include "bits/stdc++.h" 2 using namespace std; 3 int L, n, m; 4 int pos[500010], dis[500010]; 5 6 bool Cant(int Dis_Jump) 7 { 8 int i, Dis_Sum = 0, Count = 0; 9 for(i = 1; i <= n + 1; ++i) { 10 if(dis[

HDU 4004 The Frog&#39;s Games 二分

1.题意:一条河长为L,河上有N块石头,一只青蛙可以利用这些石头从河的一端跳到对岸,可以跳不超过M次,求各种跳法中,找到最小化的最大步长.输入第一行依次给出L.N.M,第二行依次给出N块石头距离起点的距离. 2.分析:这类最小化最大值的问题用二分来求解最高效.先预先处理,连同起点,终点,共N+2个点排序,两两相减得到N+1段距离C[i],即跨一步的最小距离.二分维护mid值,上界为河长L,下界为两两距离之中的最大值maxC[i](反证易知),以mid值分割C[i]数组,分割的段数<=M则mid偏

HDU 4004 The Frog&#39;s Games(二分+小思维+用到了lower_bound)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 9678    Accepted Submission(s): 4428 The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triat

HDU 4004 The Frog&#39;s Games(二分答案)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 10307    Accepted Submission(s): 4686 Problem Description The annual Games in frogs' kingdom started again. The most famous game

HDU 4004 The Frog&#39;s Games(基本算法-贪心,搜索-二分)

The Frog's Games Problem Description The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The

hdu 4004 The Frog&#39;s Games【二分】

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 3980    Accepted Submission(s): 1931 Problem Description The annual Games in frogs' kingdom started again. The most famous game

hdu 4004 The Frog&#39;s Games

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4004 The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over

hdoj 4004 The Frog&#39;s Games(二分)

The Frog's Games Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 5676    Accepted Submission(s): 2732 Problem Description The annual Games in frogs' kingdom started again. The most famous game i

hdu4004The Frog&#39;s Games 二分

河的长度为L, 有n个石头,最多跳m次,求青蛙最少至少能够跳多远的最小值. 二分,去年学过,好像也写过,今年还是不会,惭愧. 在两个石头的最大值和河的宽度L之间二分,每一次判断在当前mid下,可不可以到达对岸 #include<cmath> #include<iostream> #include<cstdio> #include<cstdlib> #include<algorithm> #include<cstring> using