hdu1814Peaceful Commission(2-SAT)

Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3556    Accepted Submission(s):
1173

Problem Description

The Public Peace Commission should be legislated in
Parliament of The Democratic Republic of Byteland according to The Very
Important Law. Unfortunately one of the obstacles is the fact that some deputies
do not get on with some others.

The Commission has to fulfill the
following conditions:
1.Each party has exactly one representative in the
Commission,
2.If two deputies do not like each other, they cannot both
belong to the Commission.

Each party has exactly two deputies in the
Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1
and 2i belong to the i-th party .

Task
Write a program, which:

1.reads from the text file SPO.IN the number of parties and the pairs of
deputies that are not on friendly terms,
2.decides whether it is possible to
establish the Commission, and if so, proposes the list of members,
3.writes
the result in the text file SPO.OUT.

Input

In the first line of the text file SPO.IN there are two
non-negative integers n and m. They denote respectively: the number of parties,
1 <= n <= 8000, and the number of pairs of deputies, who do not like each
other, 0 <= m <=2 0000. In each of the following m lines there is written
one pair of integers a and b, 1 <= a < b <= 2n, separated by a single
space. It means that the deputies a and b do not like each other.
There are
multiple test cases. Process to end of file.

Output

The text file SPO.OUT should contain one word NIE
(means NO in Polish), if the setting up of the Commission is impossible. In case
when setting up of the Commission is possible the file SPO.OUT should contain n
integers from the interval from 1 to 2n, written in the ascending order,
indicating numbers of deputies who can form the Commission. Each of these
numbers should be written in a separate line. If the Commission can be formed in
various ways, your program may write mininum number sequence.

Sample Input

3 2
1 3
2 4

Sample Output

1
4
5

Source

POI
2001

/*
最小字典序
直接暴力枚举DFS,首先将所有的点都置为未染色,然后从第一个点开始DFS染色,我们先尝试将i染
成1(答案中的颜色),将~i染成2,然后dfs i的所有后继并染色,如果对于后继j没有染色,那么将j然
后为1,~j染成2。如果后继j已经被染成2,则说明不能选则i,如果j已经染成1,则说明可以。
那么这些后继就可以被选择。如果选择i的时候失败了,那么必定要选择~i,如果也失败,则说明无解。否则
按次序选取下一个未被染色的点。时间复杂度O(nm)。
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 16001

using namespace std;
int col[maxn],head[maxn],ans[maxn];
int a,b,n,m,num,tot,cnt;
struct node
{
    int u,v,next;
}e[maxn<<2];

inline void add(int u,int v)
{
    e[++num].u=u;
    e[num].v=v;
    e[num].next=head[u];
    head[u]=num;
}

bool dfs(int u)
{
    if(col[u]==1) return true;
    if(col[u]==2) return false;
    col[u]=1;col[u^1]=2;ans[cnt++]=u;
    for(int i=head[u];i;i=e[i].next)
    {
        int v=e[i].v;
        if(!dfs(v)) return false;
    }
    return true;
}

bool solve()
{
    memset(col,0,sizeof col);
    for(int i=0;i<n;i++)
    {
        if(col[i]) continue;
        cnt=0;
        if(!dfs(i))
        {
            for(int j=0;j<cnt;j++)
            {
                col[ans[j]]=0;
                col[ans[j]^1]=0;
            }
            if(!dfs(i^1))return false;
        }
    }
    return true;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        n<<=1;num=1;
        memset(head,0,sizeof head);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            a--;b--;
            add(a,b^1);add(b,a^1);
        }
        if(solve())
        {
            for (int i=0;i<n;i++)
              if(col[i]==1)
                printf("%d\n",i+1);
        }
        else printf("NIE\n");
    }
    return 0;
}
时间: 2024-10-01 13:07:50

hdu1814Peaceful Commission(2-SAT)的相关文章

HIT_1917_Peaceful Commission(2-SAT)

Peaceful Commission Source : POI 2001 Time limit : 10 sec Memory limit : 32 M The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacle

LA 3211 飞机调度(2—SAT)

https://vjudge.net/problem/UVALive-3211 题意: 有n架飞机需要着陆,每架飞机都可以选择“早着陆”和“晚着陆”两种方式之一,且必须选择一种,第i架飞机的早着陆时间为E,晚着陆时间为L,不得在其他时间着陆.你的任务是为这些飞机安排着陆方式,使得整个着陆计划尽量安全.换句话说,如果把所有飞机的实际着陆时间按照从早到晚的顺序排列,相邻两个着陆时间间隔的最小值. 思路: 二分查找最大值P,每次都用2—SAT判断是否可行. 1 #include<iostream>

HDU 1814 Peaceful Commission

Peaceful Commission Time Limit: 5000ms Memory Limit: 32768KB This problem will be judged on HDU. Original ID: 181464-bit integer IO format: %I64d      Java class name: Main The Public Peace Commission should be legislated in Parliament of The Democra

hdu 1814 Peaceful Commission (2-sat 输出字典序最小路径)

Peaceful Commission Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1948    Accepted Submission(s): 560 Problem Description The Public Peace Commission should be legislated in Parliament of Th

HDOJ 1814 Peaceful Commission

经典2sat裸题,dfs的2sat能够方便输出字典序最小的解... Peaceful Commission Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1578    Accepted Submission(s): 406 Problem Description The Public Peace Commission should

8.3吝啬SAT问题

吝啬SAT问题是这样的:给定一组子句(每个子句都是其中文字的析取)和整数k,求一个最多有k个变量为true的满足赋值--如果该赋值存在.证明吝啬SAT是NP-完全问题. 1.易知吝啬SAT的解可以在多项式时间内验证,因此属于NP问题. 2.如果我们把吝啬SAT问题中的k设置为输入的数目,那么SAT问题就可以规约到吝啬SAT问题,所以吝啬SAT问题是np-完全问题.

POJ 3207 Ikki&#39;s Story IV - Panda&#39;s Trick(2 - sat啊)

题目链接:http://poj.org/problem?id=3207 Description liympanda, one of Ikki's friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki. liy

多边形碰撞 -- SAT方法

检测凸多边形碰撞的一种简单的方法是SAT(Separating Axis Theorem),即分离轴定理. 原理:将多边形投影到一条向量上,看这两个多边形的投影是否重叠.如果不重叠,则认为这两个多边形是分离的,否则找下一条向量来继续投影.我们不需要比较很多条向量,因为已经在数学上证明,多边形每条边的垂直向量就是我们需要的向量. 1.AABB 让我们首先以AABB开始(AABB是一种两边分别平行于X-Y轴的矩形) 判断两个AABB是否碰撞,我们只需要投影两次,分别是投影在平行于X轴和Y轴的向量上

HIT1917Peaceful Commission(2-SAT)

Peaceful Commission   Source : POI 2001   Time limit : 10 sec   Memory limit : 32 M Submitted : 2112, Accepted : 641 The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important