poj2566 Bound Found

Bound Found

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1651   Accepted: 544   Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We‘ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

思路:sum[i][j]=sum[0][j]-sum[0][i-1],所以可以把部分和问题转换成求两个和之间的差最接近T的问题但是差可能有负也有正,那就把和排序一遍,这样就只能得到非负数差,可以用尺取,记录下编号小的在前就行了
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100005;
int n,k,T;
typedef pair<long long ,int> P;
P  sum[maxn];int nsts,nste;
long long nstt;
long long calc(int s,int e){
    return sum[e].first-sum[s].first;
}
int main(){
    while(scanf("%d%d",&n,&k)==2&&n&&k){
        long long s=0;
        sum[0].first=0;
        sum[0].second=0;//这个不能在结果中出现,为了使得0存在而加入,是不含元素的和
        for(int i=1;i<=n;i++){
            int tmp;
            scanf("%d",&tmp);
            s+=tmp;
            sum[i].first=s;
            sum[i].second=i;
        }
        nsts=nste=1;nstt=sum[1].first;
        sort(sum,sum+n+1);
        for(int i=0;i<k;i++){
                int l=0,r=1;
                scanf("%d",&T);
                while(l<r&&r<=n){
                        long long tmp=calc(l,r);
                        if(abs(tmp-T)<abs(nstt-T)){
                                nstt=tmp;
                                nsts=min(sum[l].second,sum[r].second)+1;
                                nste=max(sum[l].second,sum[r].second);
                    }
                    if(tmp>T&&l<r-1){
                        l++;
                    }
                    else {
                        r++;
                    }
                }
                printf("%I64d %d %d\n",nstt,nsts,nste);
        }
    }
    return 0;
}
时间: 2024-11-02 14:36:19

poj2566 Bound Found的相关文章

Bound Found [POJ2566] [尺取法]

题意 给出一个整数列,求一段子序列之和最接近所给出的t.输出该段子序列之和及左右端点. Input The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <

通过maven test 报org.apache.ibatis.binding.BindingException: Invalid bound statement

背景 直接使用eclipse工具去执行,没有问题,通过testng.xml去执行,没有问题,但通过mvn clean test执行,就报错,提示org.apache.ibatis.binding.BindingException: Invalid bound statement 解决方法 首先先肯定的是:mybatis的配置是没有问题,因为eclipse可以正常执行: 在eclipse中把mapper的xml文件放到src代码目录下是可以一起打包进classes的,而maven去编译的时候不会,

解读Android之Service(2)Bound Service

翻译自android官方文档,并根据自己测试形成下面的内容. 这是service的第二部分bound service.若第一部分没看的,请参考:上一篇. bound service 相当于客户-服务器接口中的服务器.bound service 允许其它组件(除了broadcast receiver)绑定该service,然后进一步操作:发送请求,接收响应,甚至IPC.bound service 只有在其他组件绑定它时才处于存活状态,且会受到绑定它的组件影响. 下面将具体介绍如何创建bound s

org.hibernate.HibernateException: No Hibernate Session bound to thread, and configuration does not

遇到这个问题之前,我去百度和谷歌去搜索了一下,发现各种说法,但是针对我的项目而言,也就是公司的项目而言,这个问题的根源并非是网上所说的那样. 最后是通过自己的想法做测试得到了解决. 1.首先说说我的配置吧!我的配置是通过spring自带的注解来实现 声明式事物管理的.如果我们没去了解spring的声明式事物管理的话,或许我们是得不出什么结论的. 如果你配置过声明式事物管理,你就知道spring是怎么帮你管理的. 2.spring声明式事物管理是在service层管理的,关于到sessionFac

Exception:HTTP Status 500 - org.apache.ibatis.binding.BindingException: Invalid bound statement (not found)

主要错误信息如下: HTTP Status 500 - org.apache.ibatis.binding.BindingException: Invalid bound statement (not found) description The server encountered an internal error that prevented it from fulfilling this request. exception java.lang.RuntimeException: org

二分查找里的upper bound与lower bound的实现与分析

1. 问题引入 最近参选了学堂在线的课程数据结构(2015秋).课程由清华大学的邓俊辉老师主讲,在完成课后作业时,遇到了这样一个题目范围查询.在这个题目中,我需要解决这样一个子问题:给定了一组已经排好序的整数集合A[0...n]和一组闭区间[L,R],求这个整数集合中落在这个区间中的点的个数.解决这个问题,我们很容易想到查找效率很高的二分查找,但是这又不是一般求key是否在一个数组里面的二分查找问题.对于区间左端点L,要找到数组里面大于或等于它的最小的元素的下标indexL.对于区间右端点R,要

spring 管理事务配置时,结果 报错: No Hibernate Session bound to thread, and configuration does not allow creation of non-transactional one here这个异常

java.lang.IllegalStateException: No Hibernate Session bound to thread, and configuration does not allow creation of non-transactional one here这个异常 这个错误,网上说的原因一大推,反正我这个出的问题 是因为 虽然我在 spring 里把事务都配置好了,结果运行就出现这个错误,看看配置都没什么问题,都是网上 案例 照 写编码的,还是错的,结果发现是因为 我

The prefix &quot;mvc&quot; for element &quot;mvc:annotation-driven&quot; is not bound 异常

使用STS或者eclipse 开发SpringMVC应用 时,我靠..有个小小的东西没注意搞了半天, STS在创建SpringMVC工程时,自动生成了Dispatcher的配置文件,然后看教程时,使用了<mvc:annotation-driven> 注解配置 但是自动生成的xml里呢有一个<annotation-driven>, 挺疑惑的,以为mvc约束文件版本不对,所以配置了很久的本地约束,仍然没有用 后来决定仔细看看什么问题,通过代码排版对齐,发现了.....靠,前缀也是需要配

MyBatis-Invalid bound statement (not found)-问题处理

最近把工程改为Hibernate和MyBatis并存,并存只要注意两点即可: 1.使用同一个dataSource 2.事物交给Hibernate进行管理(Hibernate4+)  Hibernate做CUD操作 MyBatis负责R 在整合完成之后发现一个问题.使用MyBatis进行查询报错: Invalid bound statement (not found) 网上有很多同样的错误,但是出现这个错误的原因有很多种,解法都是不一样的.这里说一下我出现这个错误的原因. 这里主要是因为我使用ge