HDU 1075 What Are You Talking About (Trie)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 16042    Accepted Submission(s): 5198

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn‘t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book
into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines
follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian‘s language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book
part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian‘s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate
it and write the new word into your translation, if you can‘t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(‘ ‘), tab(‘\t‘), enter(‘\n‘) and all the punctuation should not be translated.
A line with a single string "END" indicates the end of the book part, and that‘s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i‘m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i‘m from mars.
i like earth!

解析:将词典中的原始单词组织成Trie,相应的相应单词作为原始单词的附加信息放到Trie树中原始单词的最后一个字符结点中。

AC代码:

//#include <bits/stdc++.h>       //hdu的C++,不支持此头文件。G++支持
#include <cstdio>
#include <cstring>
#include <cctype>

using namespace std;

const int maxw = 12;
const int maxnode = 100000 * maxw + 10;
const int sigma_size = 26;

struct Trie{
    int ch[maxnode][sigma_size];
    char val[maxnode][maxw];
    int sz;

    void clear(){ sz = 1; memset(ch[0], 0, sizeof(ch[0])); }
    int idx(char c){ return c - ‘a‘; }

    void insert(const char *s, const char *v){
        int u = 0, n = strlen(s);
        for(int i=0; i<n; i++){
            int c = idx(s[i]);
            if(!ch[u][c]){
                memset(ch[sz], 0, sizeof(ch[sz]));
                ch[u][c] = sz++;
            }
            u = ch[u][c];
        }
        strcpy(val[u], v);
    }

    char* find(const char *s){
        int u = 0, n = strlen(s);
        int i;
        char ans[maxw];
        for(i=0; i<n; i++){
            int c = idx(s[i]);
            if(!ch[u][c]) return "";
            u = ch[u][c];
        }
        return val[u];
    }
};

Trie trie;

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    trie.clear();
    char s[maxw], ss[maxw], text[3002];
    scanf("%s", s);
    while(scanf("%s", s)){
        if(s[0] == ‘E‘ && s[1] == ‘N‘ && s[2] == ‘D‘) break;
        scanf("%s", ss);
        trie.insert(ss, s);
    }
    scanf("%s", s);
    getchar();
    while(gets(text)){
        if(text[0] == ‘E‘ && text[1] == ‘N‘ && text[2] == ‘D‘) break;
        int n = strlen(text);
        for(int i=0; i<n; ){
            char foo[maxw];
            int cnt = 0;
            while(i < n && isalpha(text[i])){ foo[cnt ++] = text[i ++]; }
            foo[cnt] = ‘\0‘;
            if(!cnt){ putchar(text[i ++]); continue; }
            if(strcmp(trie.find(foo), "")) printf("%s", trie.find(foo));
            else printf("%s", foo);
        }
        puts("");
    }
    return 0;
}
时间: 2024-08-09 08:13:17

HDU 1075 What Are You Talking About (Trie)的相关文章

HDU 1075 What Are You Talking About(Trie的应用)

What Are You Talking About Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others) Total Submission(s): 20680    Accepted Submission(s): 6852 Problem Description Ignatius is so lucky that he met a Martian yesterday. But

HDU 1075 What Are You Talking About (Trie树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1075 map可以过...我上的字典树,小bug有点尴尬,题目没有明确给出数据范围也是无奈. 贡献了几次RE 一次WA.尴尬.discuss里面有个说注意前缀的到是给了点tip.总体来说不错 代码: 1 #define _CRT_SECURE_NO_WARNINGS 2 #include <functional> 3 #include <algorithm> 4 #include <

HDU 1075 What Are You Talking About (strings)

What Are You Talking About Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others) Total Submission(s): 15966    Accepted Submission(s): 5177 Problem Description Ignatius is so lucky that he met a Martian yesterday. But

HDU ACM 1247-Hat’s Words-字典树(Trie)

分析:字典树解决,注意节点里面只需要保存该点是否构成一个单词,和匹配类型的题有所区别:另外要注意重读打印.字典树效率高. #include<iostream> using namespace std; struct Tri { bool v; Tri* child[26]; }; Tri* root; void Init() { root->v=false; for(int i=0;i<26;i++) { root->child[i]=NULL; } } void Creat

HDU 1075 What Are You Talking About (map解法+Trie解法)

HDU 1075 What Are You Talking About (map解法+Trie解法) ACM 题目地址: HDU 1075 What Are You Talking About 题意: 给出一个"翻译-原文"的对应表,然后给出句子,要把句子中的原文都翻译出来. 分析: 可以用map赤裸裸地做,但是比较花费时间,虽然这题时间给了5s,map解法是能过的. 不过Trie解法500+ms,果然Trie字典树才是正解啊. Trie入门题. 另外发现ios_base::sync_

hdu 1507 Uncle Tom&#39;s Inherited Land*(二分)

Uncle Tom's Inherited Land* Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1853    Accepted Submission(s): 769 Special Judge Problem Description Your old uncle Tom inherited a piece of land fr

HDU 5024 Wang Xifeng&#39;s Little Plot (搜索)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 157    Accepted Submission(s): 105 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

hdu 4956 Poor Hanamichi BestCoder Round #5(数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4956 Poor Hanamichi Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 7    Accepted Submission(s): 4 Problem Description Hanamichi is taking part in

HDU 4001 To Miss Our Children Time (动态规划)

To Miss Our Children Time Problem Description Do you remember our children time? When we are children, we are interesting in almost everything around ourselves. A little thing or a simple game will brings us lots of happy time! LLL is a nostalgic boy