HDU-1033-Edge(C++ && 简单模拟 && 题意恶心)

Edge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2314    Accepted Submission(s): 1477

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its
initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated
by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in
a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming
90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately
after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto".
Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge
and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

Source

University of Ulm Local Contest 2003

Recommend

We have carefully selected several similar problems for you:  1035 1036 1039 1032 1062

三天没写,脑袋果然有点小生锈,祝贺我的朋友老赵成为东北赛区ACM正式队员!博主当然是替他高兴啊!无奈水平太差,不能与其共同战斗,所以我呢有时间做做题就好,有句话不是常说,自己选择的路!跪着也要走完,即使我是一次正式比赛也参加过渣渣,但是这份AC之心,永不放弃!

接下来,今天的题目,出题人简直恶心,(明明是个水题非得弄得这么高大上?)我想即使英语很好的人,看这道题都会很费劲吧,更不要说,英语不好的人了(比如说我),说了一圈,题意解释的模模糊糊的,什么叫言简意赅,我也是醉了!里面什么A是顺时针,V是逆时针的,我是看了30分钟都没看懂!

所以这题的题意是:

它给了你一个起点和第一次画线的方向,

第一个起点是(300,420),第一次画线方向往右画的,

所以每次都得输出:

300 420 moveto

310 420 lineto

然后后面便根据你输入的A,V来重新进行方向画线,

记住A是往右V是往左

然后唯一的难点就是用dir控制东西南北方向的判定了,dir的周期为4

//A往右边,V往左边

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define LEN 300
int main()
{
    char cmd[LEN];
    while(scanf("%s",cmd)!=EOF)
    {
        int i, j, len;
        int x, y, dir;
        dir = 0;
        x = 310;
        y = 420;
        len = strlen(cmd);
        printf("300 420 moveto\n");
        printf("310 420 lineto\n");
        for(i=0;i<len;i++)
        {
            if('V'==cmd[i])
            {
                switch(dir)
                {
                case 0:
                    y+=10;
                    break;
                case 1:
                    x+=10;
                    break;
                case 2:
                    y-=10;
                    break;
                case 3:
                    x-=10;
                    break;
                }
                dir=(dir+3)%4;
                printf("%d %d lineto\n",x,y);
            }
            else if('A'==cmd[i])
            {
                switch(dir)
                {
                case 0:
                    y-=10;
                    break;
                case 1:
                    x-=10;
                    break;
                case 2:
                    y+=10;
                    break;
                case 3:
                    x+=10;
                    break;
                }
                dir = (dir+1)%4;
                printf("%d %d lineto\n",x,y);
            }
        }

        printf("stroke\n");
        printf("showpage\n");
    }
}
时间: 2024-08-30 14:12:20

HDU-1033-Edge(C++ && 简单模拟 && 题意恶心)的相关文章

hdu 5038 Grade(简单模拟求解)2014 ACM/ICPC Asia Regional 北京 Online

Grade                                                                     Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others) Problem Description Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives h

杭电 HDU 1033 Edge

Edge Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2251    Accepted Submission(s): 1439 Problem Description For products that are wrapped in small packings it is necessary that the sheet of p

HDU 1033 Edge

题目不难,逆时针的时候注意,wa了好多次 wa的代码,错误 1 #include <cstdio> 2 #include <cstring> 3 using namespace std; 4 struct Point{ 5 int x;int y; 6 }p[3]; 7 int main() 8 { 9 char c[205]; 10 while(~scanf("%s",c)){ 11 printf("300 420 moveto\n310 420 l

HDU 1048 What Is Your Grade? (简单模拟)

 What Is Your Grade? Problem Description "Point, point, life of student!" This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in

HDU 4891 简单模拟

The Great Pan Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1035    Accepted Submission(s): 355 Problem Description As a programming contest addict, Waybl is always happy to take part in vario

HDU ACM 1057 A New Growth Industry 简单模拟

题意:给一个天数N,求20*20方阵内细菌的变化情况.每次变化加上一个d[k],d数组有给定的16个数.k是某个格子它本身加上它上下左右的四个数. 简单模拟题. 分析: #include<iostream> using namespace std; int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}}; char den[]=".!X#"; int D[16]; int map[20][20],tmp[20][20]; void Fun() {

HDU 4772 Zhuge Liang&#39;s Password (简单模拟题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4772 题面: Zhuge Liang's Password Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1404    Accepted Submission(s): 926 Problem Description In the anc

HDU-1008-Elevator(Java版本+简单模拟+恶心水果)

Elevator Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 50645    Accepted Submission(s): 27932 Problem Description The highest building in our city has only one elevator. A request list is mad

hdu 1800 Flying to the Mars(简单模拟,string,字符串)

题目 又来了string的基本用法 //less than 30 digits //等级长度甚至是超过了int64,所以要用字符串来模拟,然后注意去掉前导零 //最多重复的个数就是答案 //关于string的修改增加的用法 #include <cstdio> #include<iostream> #include <cstring> #include <algorithm> #include<string> using namespace std