poj 2253(kruskal)

Frogger

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34968   Accepted: 11235

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona‘s stone is out of his jump range. Therefore
Freddy considers to use other stones as intermediate stops and reach her
by a sequence of several small jumps.

To execute a given sequence of jumps, a frog‘s jump range obviously
must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two
stones therefore is defined as the minimum necessary jump range over
all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and
all other stones in the lake. Your job is to compute the frog distance
between Freddy‘s and Fiona‘s stone.

Input

The
input will contain one or more test cases. The first line of each test
case will contain the number of stones n (2<=n<=200). The next n
lines each contain two integers xi,yi (0 <= xi,yi <= 1000)
representing the coordinates of stone #i. Stone #1 is Freddy‘s stone,
stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a
blank line following each test case. Input is terminated by a value of
zero (0) for n.

Output

For
each test case, print a line saying "Scenario #x" and a line saying
"Frog Distance = y" where x is replaced by the test case number (they
are numbered from 1) and y is replaced by the appropriate real number,
printed to three decimals. Put a blank line after each test case, even
after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
题意:一只青蛙要从1走到2,求所有1-2的路径中最长的子段中最短的那条(minimax)。。有点难懂啊,,打个比方。1 2 21 3 1.52 3 1那么我们有 1 2 可以选择 ,路径长度为 2还有 1 3 2 可以选择 路径长度 为 1.5+1 = 2.5所以我们选择 1 3 2 答案为 1.5这里可以用贪心的思想,利用kruskal进行添边,如果1 2 联通了就必定是这一条。。开始想复杂了,用二分+网络流去解。。结果果断TLE
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iostream>
using namespace std;
const int N = 205;
struct Point{
    double x,y;
}p[N];
struct Edge{
    int s,t;
    double v;
}edge[N*N];
int father[N];
int n;
void init(){
    for(int i=1;i<=n;i++) father[i] = i;
}
double dis(Point a,Point b){
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
int _find(int x){
    if(x==father[x]){
        return father[x];
    }
    return father[x] = _find(father[x]);
}
int cmp(Edge a,Edge b){
    return a.v<b.v;
}
double kruskal(int m){
    double MAX = -1;
    sort(edge+1,edge+1+m,cmp);
    for(int i=1;i<=m;i++){
        int a = _find(edge[i].s);
        int b = _find(edge[i].t);
        if(a!=b) {
            father[a] = b;
        }
        if(_find(1)==_find(2)){
            MAX = edge[i].v;
            return MAX;
        }
    }
}
int main()
{
    int t = 1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
        }
        int m=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                double d = dis(p[i],p[j]);
                edge[m].s = i;
                edge[m].t = j;
                edge[m++].v = d;
            }
        }
        m--;
        double res = kruskal(m);
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,sqrt(res));
    }
    return 0;
}
时间: 2024-07-31 09:10:33

poj 2253(kruskal)的相关文章

POJ 2253 kruskal变形

Frogger Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 26226   Accepted: 8538 Description Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her,

POJ 2253 Frogger

题意:一只青蛙找到另外一只青蛙,不过可以通过其它的石头跳到目标青蛙的位置去,其中,输入数据的时候第一组数据是第一只青蛙的位置,第二组是目标青蛙的位置,其它的为石头的位置 思路:dijkstra算法的一种小小的变形,做法还是一样的 Tips:POJ上的双精度浮点型输出竟然是%f输出害的我一直错,或者是编译错误,恼啊! AC代码: #include<cstdio> #include<cmath> #include<algorithm> using namespace std

[2016-04-02][POJ][2253][Frogger]

时间:2016-04-02 17:55:33 星期六 题目编号:[2016-04-02][POJ][2253][Frogger] 题目大意:给定n个点的坐标,问从起点到终点的所有路径中,最大边的最小值是多少,即每一步至少是多少才能走到终点 分析: 方法1: 枚举出完全图,然后从起点跑一次Dijkstra算法,不过选点不再是选择起点到终点路径的点,而是起点到终点的路径中,边最大边最小的点,即d数组保存起点到当前点的路径中最大边的最小值, 最大边的最小值:u->v d[v] = min(d[i],m

poj 2253

群 #include <stdio.h>#include <math.h> int a[220][220];int x[220],y[220],n;int init(){ int i,j; for(i=0;i<n;i++) scanf("%d%d",&x[i],&y[i]); for(i=0;i<n;i++) for(j=0;j<n;j++) a[i][j]=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])

Floyd-Warshall算法(求解任意两点间的最短路) 详解 + 变形 之 poj 2253 Frogger

/* 好久没有做有关图论的题了,复习一下. --------------------------------------------------------- 任意两点间的最短路(Floyd-Warshall算法) 动态规划: dp[k][i][j] := 节点i可以通过编号1,2...k的节点到达j节点的最短路径. 使用1,2...k的节点,可以分为以下两种情况来讨论: (1)i到j的最短路正好经过节点k一次 dp[k-1][i][k] + dp[k-1][k][j] (2)i到j的最短路完全

POJ 2253 - Frogger (floyd)

A - Frogger Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to

poj 2253 Frogger 解题报告

题目链接:http://poj.org/problem?id=2253 题目意思:找出从Freddy's stone  到  Fiona's stone  最短路中的最长路. 很拗口是吧,举个例子.对于 i 到 j 的一条路径,如果有一个点k, i 到 k 的距离 && k 到 j 的距离都小于 i 到 j 的距离,那么就用这两条中较大的一条来更新 i 到 j 的距离 .每两点之间都这样求出路径.最后输出 1 到 2 的距离(1:Freddy's stone   2:Fiona's sto

POJ 1258-Agri-Net (Kruskal)

题目链接:Agri-Net 最小生成树水题,数组开的和题目描述一样,但是就是RE,有填了个0,还好这个题用 库鲁斯卡尔 敲了一遍,发现了点问题,以前写的库鲁卡尔模板有点问题,多写了步无用的操作,已修正. 题意:就是一个农夫想选镇长....建一条路,使之能到达所有点,距离最短. scanf输入 796K 32MS cin输入 832K 125MS #include <iostream> #include <cstdio> #include <cstring> #inclu

【POJ 2253】Frogger

[POJ 2253]Frogger 求起点到终点的通路中每天路的最大权中的最小值 最短路保证最大权联通求最小值(最短) Floyd 524K 79MS 1170B #include using namespace std; typedef struct Point { int x,y; }Point; Point p[233]; double dis[233][233]; int n; int dcmp(double x) { return x < -esp? -1: x > esp; } d