PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

题目链接:http://www.patest.cn/contests/pat-a-practise/1090

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题意:

给出初始价格和增长率!

求最高价格,和不同的路径数!

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
vector<int >a[100017];
int maxdep;
int cont;
int n;
void dfs(int tem, int dep)
{
	if(a[tem].size() == 0)//走到底,不能再供应给其他人
	{
		if(dep > maxdep)
		{
			cont = 1;
			maxdep = dep;
		}
		else if(dep == maxdep)
		{
			cont++;
		}
	}
	for(int i = 0; i < a[tem].size(); i++)
	{
		dfs(a[tem][i], dep+1);
	}
}

int main()
{
	double p, r;
	while(~scanf("%d%lf%lf",&n,&p,&r))
	{
		cont = 0;
		maxdep = 0;
		int t, i;
		int root;
		for(i = 0; i < n; i++)
		{
			scanf("%d",&t);
			if(t == -1)
			{
				root = i;
				continue;
			}
			a[t].push_back(i);
		}
		dfs(root, 0);
		double ans = p;
		for(i = 0; i < maxdep; i++)
		{
			ans = ans*(100+r)/100.0;
		}
		printf("%.2lf %d\n",ans,cont);
	}
	return 0;
}
时间: 2024-10-26 04:18:00

PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )的相关文章

1090. Highest Price in Supply Chain (25)【树】——PAT (Advanced Level) Practise

题目信息 1090. Highest Price in Supply Chain (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from o

PAT 1090 Highest Price in Supply Chain[较简单]

1090 Highest Price in Supply Chain(25 分) A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain bu

1090. Highest Price in Supply Chain (25)

时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplie

PAT 1090. Highest Price in Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

PAT (Advanced Level) 1090. Highest Price in Supply Chain (25)

简单dfs. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<map> #include<queue> #include<stack> #include<vector> using namespace std; const int maxn=100000+10; vector<int>g[

PAT:1090. Highest Price in Supply Chain (25) AC

#include<stdio.h> #include<vector> using namespace std; const int MAX=100010; int DEPest=0,times=0; vector<int> child[MAX]; //child[父亲][孩子] 二维数组表示树形结构 void DFS(int root,int depth) { if(child[root].size()==0) //叶子节点开始判断深度 { if(depth>DE

pat1090. Highest Price in Supply Chain (25)

1090. Highest Price in Supply Chain (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric