hdu1325is it a tree?&&poj1308 is it a tree?(并查集)

题目链接:

huangjing||huangjing

建议做hdu上的这个题,因为poj上面的数据很弱,就是因为只做了poj上面的导致我在一次比赛中一直wa到比赛结束,因为比赛的那次挂的是hdu上的题。。。

题意:

判断由给出的数据得到的是否是一棵树。。。

思路:

这个题有几个要注意的地方。

【1】首先一棵树只能有一个入度为0的点即根节点。。所以根节点唯一。。

【2】除根节点外其他点的入度均为1。

题目:


Language:
Default

Is It A Tree?

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22135   Accepted: 7555

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int cnt;
const int maxn=100000+10;
int root[maxn],in[maxn];

struct edge
{
    int u,v;
}e[maxn];

void init()
{
    for(int i=1;i<maxn;i++)
    {
        root[i]=i;
        in[i]=0;
    }
}

int findroot(int x)
{
    if(root[x]!=x)
        root[x]=findroot(root[x]);
    return root[x];
}

int judge()
{
    int boss=findroot(e[1].u);//是否存在几棵树
    for(int i=1;i<cnt;i++)
    {
        int fx=findroot(e[i].u);
        int fy=findroot(e[i].v);
        if(fx==fy&&boss==fx)
            continue;
        else
            return 0;
    }
    return 1;
}

int main()
{
    int a,b,cas=1;
    int ans1,ans2;
    while(1)
    {
        ans2=1;
        cnt=1;
        init();
        while(scanf("%d%d",&a,&b)!=EOF)
        {
           if(a<0&&b<0)
               return 0;
           if(a==0&&b==0)
           {
               ans1=judge();
               if(ans1&&ans2)
                   printf("Case %d is a tree.\n",cas);
               else
                   printf("Case %d is not a tree.\n",cas);
               cas++;
               break;
           }
           e[cnt].u=a;
           e[cnt].v=b;
           in[b]++;
           int fx=findroot(a);
           int fy=findroot(b);
           if(fx==fy||in[b]>=2)//判断是否有入度为大于2的点 if(fx==fy||b!=fy)这样判断也可以
              ans2=0;
           else
           {
               root[fy]=fx;
               cnt++;
           }
        }
    }
    return 0;
}
时间: 2024-10-12 14:51:44

hdu1325is it a tree?&&poj1308 is it a tree?(并查集)的相关文章

POJ 1308 Is It A Tree? &amp;&amp; NYOJ 129 (树的判定+并查集)

[题目链接]click here~~ [题目大意]给定多对节点,判断所有节点能否组成一棵树 [解题思路]并查集的基本操作,定义node,edge,统计node和edge的数目,如果(edge==node-1||node==0)则可以成树 树的判定:n个节点,最多n-1条环,只有一个入度为边,不成0 的点,其他入度不大于1,不过要注意poj数据里如果1 1 0 0也会不符合要求,也就是不能自己指向自己 代码: /* Author:HRW 树的判定: n个节点,最多n-1条边 不成环 只有一个入度为

hdu-1325 &amp; poj-1308 Is It A Tree?

http://acm.hdu.edu.cn/showproblem.php?pid=1325 题意: 判断一个图是不是说树 只有树的根入度为 0 ,其余结点入度均为 1; Is It A Tree? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15503    Accepted Submission(s): 3443 Problem

POJ1308——Is It A Tree?

Is It A Tree? Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 22631   Accepted: 7756 Description A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edge

POJ1308 Is It A Tree?

题目大意:和HDU1272-小希的迷宫题目一样, 如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路).小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路.比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8.  Input 输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号.房间的编号至少为1,

HDU-1325&amp;&amp;POJ-1308 Is It A Tree?(基础并查集)

Is It A Tree? Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26976    Accepted Submission(s): 6213 Problem Description A tree is a well-known data structure that is either empty (null, void, no

POJ-1308 Is It A Tree?(并查集判断是否是树)

http://poj.org/problem?id=1308 Description A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.There is exactl

HDU1325 &amp;&amp;poj1308 基础并查集

和上一道小希的迷宫差不多,但是在HDU上提交一直WA,POJ过了 HDU的数据太强了吧,强的我感觉数据有问题 题意:输入若干对点,判断是否是一颗树,转化过来也就是是否存在环 点数-边数=1,还要判断每个点的入度都<=1 POJ AC代码 #include <iostream> #include <cstdlib> #include <cstdio> #include <cstring> #include <algorithm> const

HDU 5606 tree 并查集

tree 把每条边权是1的边断开,发现每个点离他最近的点个数就是他所在的连通块大小. 开一个并查集,每次读到边权是0的边就合并.最后Ans?i??=size[findset(i)],size表示每个并查集根的size Ans_i=size[findset(i)],sizeAns?i??=size[findset(i)],size表示每个并查集根的sizesize. #include<cstdio> #include<cstring> #include<algorithm>

HDU 1325 POJ 1308 Is It A Tree? (并查集)

这道题就是裸并查集,关键在于对不是树几种的判断 1. 空树是树 2. 森林不是树 3. 无环 或者从入度来看:1,无环:2,除了根,所有的入度为1,根入度为0:3,这个结构只有一个根,不然是森林了. 这道题本来暑假做的POJ 1308 但是HDU没有过.在于空树没有考虑. 用并查集判断有多少个森林注意编号是随机的,不是次序.... /* input: 0 0 1 1 0 0 1 2 1 2 0 0 1 2 2 3 4 5 0 0 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9