HDU 搜索练习 A strange lift

A strange lift

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 122 Accepted Submission(s) : 22

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you‘ll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2 th floor isn‘t exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>

Input

The input consists of several test cases.,Each test
case contains two lines.<br>The first line contains three integers N ,A,B(
1 <= N,A,B <= 200) which describe above,The second line consist N integers
k1,k2,....kn.<br>A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least
times you have to press the button when you on floor A,and you want to go to
floor B.If you can‘t reach floor B,printf "-1".

Sample Input

5 1 5

3 3 1 2 5

0

Sample Output

3

简单题意:

  给出N个楼梯up or down的参数, 和所在的楼层,和目标楼层,比如 在1楼按up那么会上升1楼的参数层,求到达目的楼层的最小次数

思路分析:

  有目标层数,明显BFS。

# include <iostream>
# include <fstream>
# include <cstring>
# include <queue>
using namespace std;
int n, a, b;
int floor[1000];
int is[1000];
struct Info
{
    int k;
    int jishu;
};

int bfs();
int main()
{
    //fstream cin("aaa.txt");
    while(cin >> n)
    {
        if(n == 0)
        break;
        cin >> a >> b;
        memset(is, 0, sizeof(is));
        for(int i = 1; i <= n; i++)
            cin >> floor[i];
        int jishu = bfs();
        cout << jishu << endl;
    }

    return 0;
}
int bfs()
{
    is[a] = 1;
    queue <Info> Q;
    Info info;

    info.k = a;
    info.jishu = 0;

    Q.push(info);
    Info t, tep;
    while(!Q.empty())
    {
        t = Q.front();
        Q.pop();
        if(t.k == b)
        {
            return t.jishu;
        }
        for(int i = -1; i <= 1; i++)
        {
            tep.k = t.k + i * floor[t.k];
            if(tep.k >= 1 && tep.k <= n && !is[tep.k])
            {
                is[tep.k] = 1;
                tep.jishu = t.jishu + 1;
                Q.push(tep);
            }
        }

    }
    return -1;
}
时间: 2024-10-13 17:17:42

HDU 搜索练习 A strange lift的相关文章

HDU 1548 A strange lift 搜索

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11341    Accepted Submission(s): 4289 Problem Description There is a strange lift.The lift can stop can at every floor as you want

HDU 1548 A strange lift【不错的最短路,spfa】

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21281    Accepted Submission(s): 7786 Problem Description There is a strange lift.The lift can stop can at every floor as you want

(hdu step 4.2.4)A strange lift(求从起点到终点的最小步数,限制条件是:在一维的情况下)

题目: A strange lift Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 709 Accepted Submission(s): 348   Problem Description There is a strange lift.The lift can stop can at every floor as you want, a

HDU 1548 A strange lift(Dijkstra,简单BFS)

题目大意: 电梯有两个选项向上或向下,每层楼有一个参数ki,代表电梯可以再该楼层的基础上向上或向下移动ki层,限制条件是向上不能超过楼层总数n,向下不能少于一.输入总层数n和当前所在层数以及目标层数,然后是n个数分别代表第i层的移动范围.输出最少移动次数,若不可达,输出-1. 解题思路: 1.用Dijkstra算法,首先构建邻接矩阵,注意在构造时,要考虑i-k[i]<1和i+k[i]>n,i代表当前所在层. 1 #include<string.h> 2 #include<st

HDU 1548 (最基础的BFS了) A strange lift

这是一维的BFS,而且没有什么变形,应该是最基础的BFS了吧 题意: 有这样一个奇葩的电梯,你在第i层的时候你只能选择上或者下Ki层,也就是你只能从第i层到达i+Ki或者i-Ki层.当然电梯最低只能在1层最高只能在n层. 给出起点和终点问最少需要多少次才能到达终点,如果不能到达输出-1 没有什么好解释的了,如此单纯的一道题,只要不是太粗心就能A过去 1 //#define LOCAL 2 #include <iostream> 3 #include <cstdio> 4 #incl

hdu 1548 A strange lift (dijkstra算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1548 题目大意:升降电梯,先给出n层楼,然后给出起始的位置,即使输出从A楼道B楼的最短时间. 注意的几点 (1)每次按一下,只能表示上或者是下,然后根据输入的看是上几层或者是下几层. (2)注意不能到底不存在的楼层. 详见代码. 1 #include <iostream> 2 #include <cstdio> 3 using namespace std; 4 const int IN

HDU1548A strange lift(搜索)

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11649    Accepted Submission(s): 4419 Problem Description There is a strange lift.The lift can stop can at every floor as you want

HDU 1548.A strange lift

A strange lift Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u SubmitStatusPracticeHDU 1548 Description There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N)

HDU 1548 A strange lift(最短路&amp;&amp;bfs)

A strange lift Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26943    Accepted Submission(s): 9699 Problem Description There is a strange lift.The lift can stop can at every floor as you want,