PAT Advanced 1050 String Subtraction (20) [Hash散列]

题目

Given two strings S1 and S2, S = S1 – S2 is defined to be the remaining string afer taking all the characters in S2 from S1. Your task is simply to calculate S1 – S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively.The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1 – S2 in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

题意

  1. 输入s1,s2,打印s=s1-s2(即:打印s1中未出现在s2中的字符)
  2. s1,s2长度均<=10^4,所有字符都是ASCII码表中的字符,换行符表示输入结束

题目分析

  1. 定义int asc[256],记录s2中字符出现次数。
  2. 遍历s1,若asc[s1[i]]>0,说明在s2中出现,不打印

知识点

  1. 标记全部ASCII码的数组长度设置为256即可
  2. strlen(),如果直接在for条件中写strlen()容易引起超时
  3. 使用字符数组接收整行
char ca[10001];
cin.getline(ca,10001);//不可以修改为strlen(ca),因为strlen是获取已填充字符长度

Code

Code 01(string)

#include <iostream>
using namespace std;
int main(int argc, char * argv[]) {
    string s1,s2;
    getline(cin,s1);
    getline(cin,s2);
    int asc[256]= {0};
    for(int i=0; i<s2.length(); i++) {
        asc[s2[i]]++;
    }
    for(int i=0; i<s1.length(); i++) {
        if(asc[s1[i]]>0)continue;
        printf("%c",s1[i]);
    }
    return 0;
}

Code 02(char array)

#include <iostream>
#include <cstring>
using namespace std;
int main(int argc, char * argv[]) {
    char s1[10001],s2[10001];
    cin.getline(s1,10001);
    cin.getline(s2,10001);
    int asc[256]= {0};
    int len1=strlen(s1),len2=strlen(s2);//如果直接在for条件中写strlen()容易引起超时
    for(int i=0; i<len2; i++) asc[s2[i]]++;
    for(int i=0; i<len1; i++) {
        if(asc[s1[i]]>0)continue;
        printf("%c",s1[i]);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/houzm/p/12238628.html

时间: 2024-08-29 18:12:19

PAT Advanced 1050 String Subtraction (20) [Hash散列]的相关文章

PAT Advanced 1050 Broken Keyboard (20) [Hash散列]

题目 On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.Now given a string that you are supposed to type, and the string that you actually type out,

PAT Advanced 1050 String Subtraction (20 分)

Given two strings S?1?? and S?2??, S=S?1??−S?2?? is defined to be the remaining string after taking all the characters in S?2?? from S?1??. Your task is simply to calculate S?1??−S?2?? for any given strings. However, it might not be that simple to do

PAT Advanced 1041 Be Unique (20) [Hash散列]

题目 Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4]. The first one who bets on a unique number wins. For example, if there ar

PAT:1050. String Subtraction (20) AC

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; bool HARSH[260]; //实际上申请来之后初试都是false int main() { fill(HARSH,HARSH+260,true); char str1[10066]; char str2[10066]; gets(str1); gets(str2); int len1=strlen(str1)

1050. String Subtraction (20)【字符串处理】——PAT (Advanced Level) Practise

题目信息 1050. String Subtraction (20) 时间限制10 ms 内存限制65536 kB 代码长度限制16000 B Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any giv

PAT (Advanced Level) 1050. String Subtraction (20)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<string> #include<vector> using namespace std; const int maxn=100000

PAT甲题题解-1050. String Subtraction (20)-水题

#include <iostream> #include <cstdio> #include <string.h> #include <algorithm> using namespace std; /* 水题,注意字符范围是整个ASCII编码即可. */ const int maxn=130; int vis[maxn]; char s1[10000+5]; char s2[10000+5]; int main() { gets(s1); //getcha

PAT Advanced 1092 To Buy or Not to Buy (20) [Hash散列]

题目 Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must c

【PAT甲级】1050 String Subtraction (20 分)

题意: 输入两个串,长度小于10000,输出第一个串去掉第二个串含有的字符的余串. trick: ascii码为0的是NULL,减去'0','a','A',均会导致可能减成负数. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;char s1[10007],s2[10007];int vis[507];int main(){ ios::sync_with_stdio(false); cin.t