poj 1469 COURSES 【二分匹配】

COURSES

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18438   Accepted: 7262

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

...

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意:每一门课可能有多个学生喜欢,定义一位学生可以代表他所喜欢的一门课(同时,这门课也就代表了这个学生),问能不能每一门课都有一个不同于其他的学生来作为代表。 其实就是一门课匹配一个学生,问能不能将所有的课都匹配。

。。。二分;

注意:用cin会超时。。。

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>

const int M =310;

using namespace std;

bool map[110][M], vis[M], flag;
int p, n, match[M];

bool dfs(int u){
	for(int i = 1; i <= n; ++ i){
		if(!vis[i] && map[u][i]){
			vis[i] = 1;
			if(match[i] == -1||dfs(match[i])){
				match[i] = u; return true;
			}
		}
	}
	return false;
}

int main(){
	int t;

	//cin >> t;
	scanf("%d", &t);
	while(t --){
		//cin >> p >> n;
		scanf("%d%d", &p, &n);
		memset(map, 0, sizeof(map));
		memset(match, -1, sizeof(match));
		int m, temp;
		flag = 1;
		for(int i = 1; i <= p; ++ i){
			//cin >> m;
			scanf("%d", &m);
			if(m == 0) flag = 0;
			while(m --){
				//cin >> temp;
				scanf("%d", &temp);
				map[i][temp] = 1;
			}
		}
		if(flag == 0) {
			cout << "NO\n"; return 0;
		}
		else {
			int res = 0;
			for(int i = 1; i <= p; ++ i){
				memset(vis, 0, sizeof(vis));
				if(dfs(i)) res++;
			}
			if(res == p) cout << "YES\n";
			else cout << "NO\n";
		}
	}
	return 0;
}
时间: 2024-10-07 11:30:26

poj 1469 COURSES 【二分匹配】的相关文章

poj 1469 COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16877   Accepted: 6627 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

POJ 1469 COURSES(二部图匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 21527   Accepted: 8460 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

POJ 1469 COURSES 二分图最大匹配

就是判断一下是不是每一个课程都能找到自己的代表人,做一遍最大匹配看看匹配数是否等于p即可 #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cs

POJ 1469 COURSES //简单二分图

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17211   Accepted: 6769 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES 解题报告

题目链接:http://poj.org/problem?id=1469 题目意思:略 for 循环中遍历的对象要特别注意,究竟是遍历课程数P 还是 学生数N,不要搞混! 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 6 const int maxn = 300 + 5; 7 int match[maxn], map[maxn][maxn];

POJ 1469 COURSES【二分图最大匹配】

分析:二分图最大匹配 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <vector> 5 using namespace std; 6 7 const int maxn = 305; 8 9 int n; 10 11 vector<int> G[maxn]; 12 int vis[maxn]; 13 int Link[maxn]; 14

POJ 1469 -- COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 23535   Accepted: 9221 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES(二分匹配模板)

题目链接:http://poj.org/problem?id=1469 COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17135   Accepted: 6730 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your tas

poj 1469 COURSES(匈牙利算法模板)

http://poj.org/problem?id=1469 COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19419   Accepted: 7642 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is

POJ 3041 - 最大二分匹配

这道题实现起来还是比较简单的,但是理解起来可能有点困难. 我最开始想到的是贪心法,每次消灭当前小行星最多的一行或一列.然而WA了.Discuss区里已经有高人给出反例. 下面给出正确的解法 我们把行和列抽象成点,把小行星抽象成边,每出现一个小行星,就把其行列所对应的点连起来.这样就形成了一个无向图$G=\left(V, E\right)$.问题就转化为了求这个图G中的最小点覆盖,即求一个元素数量尽可能小的点集$V' \subset V$,$E$中的所有边均与其内的一点相连. 最小点覆盖问题是一个