杭电1010---Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 83349    Accepted Submission(s): 22707

Problem Description

The doggie found a bone in an ancient maze,which fascinated him a lot. However, when he picked it up, the maze began toshake, and the doggie could feel the ground sinking. He realized that the bonewas a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M.There was a door in the maze. At the beginning, the door was closed and itwould open at the T-th second for a short period of time (less than 1 second).Therefore the doggie had to arrive at the door on exactly
the T-th second. Inevery second, he could move one block to one of the upper, lower, left andright neighboring blocks. Once he entered a block, the ground of this blockwould start to sink and disappear in the next second. He could not stay at oneblock for
more than one second, nor could he move into a visited block. Can thepoor doggie survive? Please help him.

Input

The input consists of multiple test cases.The first line of each test case contains three integers N, M, and T (1 < N,M < 7; 0 < T < 50), which denote the sizes of the maze and the time atwhich the door will open, respectively. The next N lines give the
maze layout,with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggiecannot enter;

‘S‘: the start point of the doggie;

‘D‘: the Door; or

‘.‘: an empty block.

The input is terminated with three 0‘s.This test case is not to be processed.

Output

For each test case, print in one line"YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0

Sample Output

NO

YES

分析:刚开始以为这是一道简单的BFS,就快写出来的代码,后来发现提交一直wrong。后来就跟学长讨论,发现这是一道规定路径,即规定的时间到达某一地。后来就写DFS的代码,写出来之后就是超时。一直超时,上网看了别人的代码,需要剪枝。如果开始的点为(0,0),需要到达的点为(2,2)。则从(0,0),到达(2,2).的距离为4;如果给的T是偶数就能到达,如果给的T是奇数,就不能达到。如果开始点为(0,0),需要到达的点为(1,2),则从(0.0)到达点(1,2)的步数为3,如果给的T是偶数,那么就不能到达,如果是奇数就能到达。所以奇偶剪枝就是始点到达终点的距离加上时间T,如果他们的和是奇数就直接输出NO

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
int n,m,t;
int zx,zy,sx,sy;
int flag;
char mp[10][10];
int vis[10][10];
struct dot
{
    int x,y;
};
inline bool in(dot gx)
{
    if(gx.x>=0&&gx.x<n&&gx.y>=0&&gx.y<m)
    return true;
   return false;
}
void dfs(int x,int y,int time)
{
    dot next;
    if(flag)                               //找到后剪枝
        return ;
    if(time==t)
    {
       if(x==zx&&y==zy)
        {
            flag=1;
            return ;
        }
    }
    if(t<=time)
        return ;
    int tmp=fabs(zx-x)+fabs(zy-y);           //奇偶性剪枝
    if(tmp>t-time||(tmp+t-time)%2==1)
        return ;

     for(int i=0;i<4;i++)
     {
         int x1=x+dx[i];
         int y1=y+dy[i];
         next.x=x1;
         next.y=y1;
         if(in(next)&&mp[x1][y1]!='X'&&!vis[x1][y1])
         {
             vis[x1][y1]=1;
             dfs(x1,y1,time+1);
             vis[x1][y1]=0;
         }

     }
}
int main()
{
  while(cin>>n>>m>>t)
  {
      int count1=1;
      if(m==0&&n==0&&t==0)
        break;
      memset(vis,0,sizeof(vis));
      for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
           cin>>mp[i][j];
      for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
         {
             if(mp[i][j]=='S')
             {
                 sx=i;
                 sy=j;
             }
             if(mp[i][j]=='D')
             {
                 zx=i;
                 zy=j;
             }
             if(mp[i][j]=='.')                //记录可以走的路
             {
                 count1++;
             }
             if(mp[i][j]=='X')              //把墙标记为1
             {
                 vis[i][j]=1;
             }
         }
         flag=0;
         vis[sx][sy]=1;                  //它的位置很重要,一个细节把它放在dfs后面,错了很多次
         dfs(sx,sy,0);

         int dis=fabs(zx-sx)+fabs(zy-sy);
         if((dis+t)%2)                     //奇偶性剪枝
         {
             printf("NO\n");
             continue;
         }
         if(count1<t)               //如果可以走的路比规定的时间少,就输出NO
         {
              printf("NO\n");
             continue;
         }
         if(flag)
         {
             printf("YES\n");
         }
         else
         {
             printf("NO\n");
         }

  }
  return 0;
}
时间: 2024-08-01 10:45:41

杭电1010---Tempter of the Bone的相关文章

【深搜加剪枝五】HDU 1010 Tempter of the Bone

Tempter of the BoneTime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 64326    Accepted Submission(s): 17567 Problem Description The doggie found a bone in an ancient maze, which fascinated him a l

HDU 1010 Tempter of the Bone heuristic 剪枝法

本题就是考剪枝法了. 应该说是比较高级的应用了.因为要使用heuristic(经验)剪枝法.要总结出这个经验规律来,不容易.我说这是高级的应用也因为网上太多解题报告都没有分析好这题,给出的程序也很慢,仅仅能过掉,由此看来很多人没有做好这道题. 这里我需要更正一下网上流行的说法:奇偶剪枝法. 其实本题使用奇偶剪枝法并不能太大提高速度,只能说仅仅让使用奇偶剪枝过掉.所以网上说本题使用奇偶剪枝的,其实并不能提高速度. 原因: 奇偶剪枝只能剪枝一次,不能在递归的时候剪枝,因为只要初始化位置符合奇偶性,那

HDU 1010 Tempter of the Bone dfs+剪枝

给你一个迷宫一个起点和一个终点,问你能否走T步刚好到达终点,不能重复走,并且只有4个方向 显然这是一个dfs,虽然N最大只有7,但是裸的dfs复杂度还是太高了,因此要进行一些剪枝 1.如果T比图上所有的可走点还要大,肯定是不可行的.这个可以避免dfs整张图. 2.奇偶剪枝,有性质当前点(x,y)到目标点(tx,ty)的所有路径的长度的奇偶性一定和|x-tx|+|y-ty|一样. #include <cstdio> #include <iostream> #include <c

hdu 1010 Tempter of the Bone (DFS+剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 68206    Accepted Submission(s): 18719 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU 1010 Tempter of the Bone(DFS+奇偶性剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 70665    Accepted Submission(s): 19487 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

Tempter of the Bone(杭电1010)(DFS+奇偶剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 74916    Accepted Submission(s): 20481 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU 1010 Tempter of the Bone【DFS经典题+奇偶剪枝详解】

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 125945    Accepted Submission(s): 33969 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU - 1010 Tempter of the Bone 深搜模板题(DPS)解题报告

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 88587    Accepted Submission(s): 24116 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU 1010 Tempter of the Bone(bfs)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 97219    Accepted Submission(s): 26383 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU 1010 Tempter of the Bone (DFS 奇偶剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 75141    Accepted Submission(s): 20531 Problem Description The doggie found a bone in an ancient maze, which fascinated him a