G - Rescue 【BFS+优先队列】

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel‘s friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there‘s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

InputFirst line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel‘s friend.

Process to the end of the file. 
OutputFor each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

/*救人,
你在a,要救的人在r,
‘.‘是路可以走,‘#‘是墙,‘x‘是警卫,走路花费一秒,遇见警卫花费两秒。
问最小多少秒能救人,
能的话输出步数,不能的话输出"Poor ANGEL has to stay in the prison all his life."*/
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long
#define inf 0x3fffffff
using namespace std;

const int maxn = 205;

int n,m,xxx,yyy;
char a[maxn][maxn];
int vis[maxn][maxn];
int dir[][2]={ {1,0},{0,1},{-1,0},{0,-1} };

struct Node
{
    int xx,yy,time;  //横纵坐标+时间
   friend bool operator < (Node a,Node b)
    {
        return a.time > b.time;
    }
};

int check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m||a[x][y]==‘#‘||vis[x][y])
        return 0;
    return 1;
}
/*int check(int x,int y)
{
    if(x<0 || y<0 || x>=n || y>=m || !vis[x][y] || a[x][y] == ‘#‘)
        return 1;
    return 0;
}*/

int bfs(int x,int y)
{
    memset(vis,0,sizeof(vis));//清空标记数组放到bfs里面!!!!!
    priority_queue<Node> q;
    while(!q.empty()) q.pop();
    q.push(Node{x,y,0});
    vis[x][y]=1;

    while(!q.empty())
    {
        Node u=q.top();
        q.pop();
        Node tmp;
        if(a[u.xx][u.yy]==‘r‘)
            return u.time;
        for(int i=0;i<4;i++)
        {
            tmp.xx=u.xx+dir[i][0];
            tmp.yy=u.yy+dir[i][1];

            if( check(tmp.xx,tmp.yy) )
            {
                vis[tmp.xx][tmp.yy]=1;
                if(a[tmp.xx][tmp.yy]==‘x‘)
                tmp.time=u.time+2;
                else
                tmp.time=u.time+1;
                q.push(tmp);
            }
        }
    }
    return -1;
}

int main()
{
    memset(vis,0,sizeof(vis));
    while(~scanf("%d%d",&n,&m))
{
    for(int i=0;i<n;i++)
    {
        scanf("%s",&a[i]);
    }

    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(a[i][j]==‘a‘)
            {
                xxx=i;
                yyy=j;
                break;
            }
        }
    }

    int ans=bfs(xxx,yyy);
    if(ans==-1)
         printf("Poor ANGEL has to stay in the prison all his life.\n");
    else
         printf("%d\n",ans);
}

}

时间: 2024-08-14 12:05:25

G - Rescue 【BFS+优先队列】的相关文章

[ACM] hdu 1242 Rescue (BFS+优先队列)

Rescue Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want to save Angel. Their task is:

hdu 1242 Rescue(bfs+优先队列)

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want to save Angel. Their task is: approach Angel. We assume

poj1649 Rescue(BFS+优先队列)

Rescue Time Limit: 2 Seconds      Memory Limit: 65536 KB Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want

杭电ACM1242——Rescue~~BFS+优先队列

这题,简单的BFS就可以搞定.题目的大概意思是最短时间从地图的r到达a. 一开始,用普通的队列来做,结果内存超了,原因是N和M最大200:普通的队列会浪费一大堆内存,所以应该改用优先队列来做. 下面是AC的代码: #include <iostream> #include <queue> #include <cstdio> using namespace std; class data { public: int x, y, cost; friend bool opera

HDU 1242 -Rescue (双向BFS)&amp;&amp;( BFS+优先队列)

题目链接:Rescue 进度落下的太多了,哎╮(╯▽╰)╭,渣渣我总是埋怨进度比别人慢...为什么不试着改变一下捏.... 开始以为是水题,想敲一下练手的,后来发现并不是一个简单的搜索题,BFS做肯定出事...后来发现题目里面也有坑 题意是从r到a的最短距离,"."相当时间单位1,"x"相当时间单位2,求最短时间 HDU 搜索课件上说,这题和HDU1010相似,刚开始并没有觉得像剪枝,就改用  双向BFS   0ms  一Y,爽! 网上查了一下,神牛们竟然用BFS+

HDU 1242 -Rescue (双向BFS)&amp;amp;&amp;amp;( BFS+优先队列)

题目链接:Rescue 进度落下的太多了,哎╮(╯▽╰)╭,渣渣我总是埋怨进度比别人慢...为什么不试着改变一下捏.... 開始以为是水题,想敲一下练手的,后来发现并非一个简单的搜索题,BFS做肯定出事...后来发现题目里面也有坑 题意是从r到a的最短距离,"."相当时间单位1,"x"相当时间单位2,求最短时间 HDU 搜索课件上说,这题和HDU1010相似,刚開始并没有认为像剪枝,就改用  双向BFS   0ms  一Y,爽! 网上查了一下,神牛们居然用BFS+优

hdu 1242 Rescue (BFS+优先队列)

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1242 这道题目我是用BFS+优先队列做的.听说只用bfs会超时. 因为这道题有多个营救者,所以我们从被营救者开始bfs,找到最近的营救者就是最短时间. 先定义一个结构体,存放坐标x和y,还有到达当前点(x,y)消耗的时间. struct node { int x,y; int time; friend bool operator < (const node &a,const node &

hdu 1242 rescue (优先队列 bfs)

题意: 公主被关在 a位置 她的朋友在r位置 路上x位置有恶魔 遇上恶魔花费2 时间 否在时间花费 1 时间 问 最短多少时间 找到公主 思路: bfs+ 优先队列(时间短的先出列) #include<cstdio> #include<cstring> #include<cmath> #include<queue> #include<iostream> #include<algorithm> using namespace std;

zoj 1649 Rescue (bfs+队列)

Rescue Time Limit: 2 Seconds      Memory Limit: 65536 KB Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want

Battle City BFS+优先队列

Battle City Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers,