华中农业大学校赛--c The Same Color

Problem C: The Same Color

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 993  Solved: 595
[Submit][Status][Web Board]

Description

Diao Yang has many balls with different colors. Today he wants to divide his balls into two groups. But he does not know how to divide. Then Diao Ze gives him a suggestion: first you choose a ball and put it into the first group. Then from the second ball, if the color of the ball is same to the last ball you has chosen, then you put the ball into the other group. Otherwise you put the ball into the same group with the last ball. Diao Yang thinks it is OK.

Then the problem is, Diao Yang wants to know the product of the number of two groups’ balls. Can you help him?

Input

The first line contains an integer T, indicating the number of test cases.

In each test case, there are several lines, each line contains only one string with lowercas, indicating the color of the ball Diao Yang has chosen currently. Diao Yang will stop choosing when the string is equal to “END”. Note that the string “END” does not mean a color.

You can assume that there are at most 100 lines in each test case and each string has at most 10 letters.

Output

For each test case, output the answer in a line.

Sample Input

3
yellow
yellow
pink
red
red
green
END
blue
black
purple
purple
END
rose
orange
brown
white
END

Sample Output

9
3
0

HINT

In the first test case, the color of the first group’s balls are yellow, red, green, 3 balls in total. The color of the second group’s balls are yellow, pink, red, 3 balls in total too. So the product is 3×3=9.

In the second test case, the answer is 3×1=3 and in the third test case the answer is 4×0=0.

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<map>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int g[2];
        g[0]=1;
        g[1]=0;
        char a[12];
        char b[12];
        scanf("%s",b);
        int t=0;
        if(strcmp(b,"END")==0)
        {
            printf("0\n");
            continue;
        }
        scanf("%s",a);
        while(strcmp(a,"END")!=0)
        {
            if(strcmp(a,b)==0)
            {
                t=1-t;
                g[t]++;
            }
            else
            {

                g[t]++;
            }
            strcpy(b,a);
            scanf("%s",a);
        }
        printf("%d\n",g[0]*g[1]);
    }
    return 0;
}

水题,只是考虑第一个颜色就是END就可以了。wa惨了

时间: 2024-10-01 01:35:14

华中农业大学校赛--c The Same Color的相关文章

湖南多校对抗赛(2015.05.10)(国防科大学校赛决赛-Semilive)CSU1609-1618

简单地写个题解,毕竟总个结很重要.但是由于题目水 + 不会写题解,路过的大牛莫喷... 题A 题意:给你两个序列a和b,有一种操作,对于一个数(非头尾)v,左边加上v,右边加上v,自己变成-v,然后问a操作无数次可不可以变成b? 题解:这题我学会了一个分析题目的方法:从目标逆着推.对于两个一样的序列,如下 操作前:……(i - 1) (i) (i + 1) …… 操作后:……(i - 1) + (i) (i) - (i) - (i) (i + 1) + (i)…… 定义si为前i项的和,假设原序

2016广东工业大学校赛 E题 GDUT-oj1173

Problem E: 积木积水 Description 现有一堆边长为1的已经放置好的积木,小明(对的,你没看错,的确是陪伴我们成长的那个小明)想知道当下雨天来时会有多少积水.小明又是如此地喜欢二次元,于是他把这个三维的现实问题简化成二维的问题.设雨量无穷.积木不透水.积木间无缝连接,问在这个二次元的世界里,已放置好的积木会有多少单位的积水量? Input 第一行包含一个整数T(T≤100),表示接下来的测试样例个数. 每个测试样例有两行组成: 第一行包含一个整数N(N≤1e6),表示积木的列数

2016广东工业大学校赛 D题 GDUT-oj1172

Problem D: 二叉树的中序遍历 Description 对于学过数据结构的人来说,二叉树和二叉树上的中序遍历都是再简单不过的东西了.这道题就搞搞二叉树好了,当然,不是一般的二叉树:) 我们定义一种a二叉树,它的节点内容可以是任一个数字或者#,#只能作为叶子节点的内容. 如下就是一棵合法定义的a二叉树1: 再来一棵不合法的a二叉树2: (根节点的左儿子的内容是#,因此不应该有一个左儿子3) 对于a二叉树1,我们可以进行对他进行中序遍历,得到序列(1)#4112#37:对于a二叉树2,可以得

第三届沈阳航空航天大学校赛(大连海事大学赛)---I: Spoors (预处理)

Spoors Time Limit: 1 Sec  Memory Limit: 128 MB Description Some of you may know when a snail crawls; he will leave a spoor after his tour. Then all of you will know that when many snail crawls, they will leave many spoors. In this problem, you will b

2016年 河南工业大学校赛 C题.魔法宝石

魔法宝石 时间限制: 2 秒  内存限制: 64 MB  |  提交: 582  解决: 187 题目描述 小s想要创造n种魔法宝石.小s可以用ai的魔力值创造一棵第i种魔法宝石,或是使用两个宝石合成另一种宝石(不消耗魔力值).请你帮小s算出合成某种宝石的所需的最小花费. 输入 第一行为数据组数T(1≤T≤3). 对于每组数据,首先一行为n,m(1≤n,m≤10^5).分别表示魔法宝石种类数和合成魔法的数量. 之后一行n个数表示a1到an.(1≤ai≤10^9).a_i表示合成第i种宝石所需的魔

2016年 河南工业大学校赛 D题.rqy的键盘

rqy的键盘 时间限制: 1 秒  内存限制: 128 MB  |  提交: 233  解决: 136 题目描述 rqy在和妹子约会,突然女票打来电话.rqy骗女票他在写代码.女票为了证实,问他键盘上F键左边是哪个键. 你能否帮助rqy回应女票的质问?不然他可就要写思想汇报了... 输入 输入数据第一行是一个整数 T(1≤T≤10000),表示测试数据的组数. 之后每一行先是一个大写字母X ,之后为一个字符串Left或Right,分别表示询问X键的左边或右边是哪个键. 输出 如果结果为一个字母键

2016年 河南工业大学校赛 H题.ch追妹

ch追妹 时间限制: 2 秒  内存限制: 128 MB  |  提交: 241  解决: 119 题目描述 n个点的一张无向图,ch站在a点,ch要追的妹子站在b点.r_clover为了让ch安心训练,要阻止ch追妹.ch每走一步,r_clover就会挖断一条路.ch和r_clover均采用最优策略,问ch能不能追到妹子 输入 第一行为数据组数T(T≤10). 每组数据的第一行为四个数 n,m,a,b(1≤a,b≤n≤20; 1≤m≤80),分别表示点数,边数,ch的位置,妹子的位置. 之后m

2016年 河南工业大学校赛 A题.饶学妹的比赛

饶学妹的比赛 时间限制: 1 秒  内存限制: 64 MB  |  提交: 385  解决: 120 题目描述 饶学妹组织了一场ACM赛制的比赛,大家纷纷慕名来参加.比赛中大家交题只会有两种结果:AC,WA.比赛结束了,饶学妹制作榜单啦.首先按AC题目的数目(重复AC一道题只算一次)从多到少排名:AC题目数目相同的同学按罚时(罚时计算方式为:单题罚时 = (首次AC该题目时间 + 首次AC之前WA的次数 * 20) min,总罚时 = 各题罚时之和:即某题目AC之后,对这道题目后续的提交均不计入

川大/电子科大校赛

第一次出校比赛 比赛时间: 电子科技大学校赛:2015.4.4 周六 四川大学校赛:2015.4.6 周一 之前本以为可以愉快地正大光明地不上课出去玩玩,不过后来才发现正值清明节,好像亏了,并不能好好滴玩耍,不过少上了4节课也是不错的,哈哈. 4.3 上午11点从学校出发,坐27路公交到圣水寺转车,然而发现时间并不多了,于是打车赶到火车站,无奈排队取票和进站的人都多得不行,看来之前小框框建议早点走是极为明智的,毕竟假期,无形甩锅....好不容易取到票出来但是进站的队伍又好长好长,只有10分钟点车