1036. Boys vs Girls (25)

1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student‘s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
using namespace  std;

struct student
{
    string name;
    string id;
    int score;
};
bool cmp_girl(student a,student b)
{
    return a.score>b.score;
}
bool cmp_boy(student a,student b)
{
    return a.score<b.score;
}

int main()
{
    vector<student>boy;
    vector<student>girl;
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        student temp;
        char sex;
        cin>>temp.name>>sex>>temp.id>>temp.score;
        if(sex==‘M‘)
        {
            boy.push_back(temp);
        }
        else
        {
            girl.push_back(temp);
        }
    }
    sort(boy.begin(),boy.end(),cmp_boy);
    sort(girl.begin(),girl.end(),cmp_girl);
    if(girl.size()==0)
        cout<<"Absent"<<endl;
    else
        cout<<girl[0].name<<" "<<girl[0].id<<endl;
    if(boy.size()==0)
        cout<<"Absent"<<endl;
    else
        cout<<boy[0].name<<" "<<boy[0].id<<endl;

    if(boy.size()==0||girl.size()==0)
        cout<<"NA"<<endl;
    else
        cout<<girl[0].score-boy[0].score<<endl;

    return 0;
}
时间: 2024-08-19 06:54:08

1036. Boys vs Girls (25)的相关文章

PAT 1036. Boys vs Girls (25)

1036. Boys vs Girls (25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contain

PAT 甲级 1036 Boys vs Girls (25 分)(简单题)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT 1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT甲题题解-1036. Boys vs Girls (25)-找最大最小,大水题

题意:给出n个人的姓名.性别.ID.分数,让你找出其中哪个妹纸分数最高.哪个汉子分数最低.以及他们的差如果没有妹纸或者汉子,则对应输出Absent,差用NA代替. 就是for一遍找最大最小值,水题 #include <iostream> #include <cstdio> #include <algorithm> #include <string.h> #include <cmath> #include <vector> #defin

PAT (Advanced Level) 1036. Boys vs Girls (25)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<vector> using namespace std; const int maxn=100000; struct X { string nam

1036 Boys vs Girls (25分)

1. 题目 2. 思路 用vector<node> m, vector<node> f 分别存放女性和男性,后排序比较 3. 注意点 无 4. 代码 #include<cstdio> #include<algorithm> #include<set> #include<map> #include<vector> #include<string> using namespace std; struct stu{

pat1036. Boys vs Girls (25)

1036. Boys vs Girls (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Spec

1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT 1036 Boys vs Girls[简单]

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai