POJ1789 Truck History 【最小生成树Prim】

Truck History

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18981   Accepted: 7321

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company‘s history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

field=source&key=CTU+Open+2003" style="text-decoration:none">CTU Open 2003

读了两遍题,愣是没读懂,看了讨论区的解释才明确。

题意:给定n个点的编号,用7位长度的字符串表示,随意两个点的距离为它们字符串相应位中不同的字符个数,求MST。

#include <stdio.h>
#include <string.h>

#define maxn 2010
#define maxm maxn * maxn
#define inf 0x3f3f3f3f

int head[maxn], n, id;
struct Node {
	int v, w, next;
} E[maxm];
char map[maxn][8];
int dis[maxn];
bool vis[maxn];

int calDis(int x, int y) {
	int sum = 0;
	for(int i = 0; i < 7; ++i)
		if(map[x][i] != map[y][i]) ++sum;
	return sum;
}

void addEdge(int u, int v, int w) {
	E[id].v = v; E[id].w = w;
	E[id].next = head[u]; head[u] = id++;
}

void getMap() {
	memset(head, -1, sizeof(int) * n);
	int i, j, w; id = 0;
	for(i = 0; i < n; ++i) {
		scanf("%s", map[i]);
		for(j = 0; j < i; ++j) {
			w = calDis(i, j);
			addEdge(i, j, w);
			addEdge(j, i, w);
		}
	}
}

int getNext() {
	int i, pos = -1, w = inf;
	for(i = 0; i < n; ++i)
		if(!vis[i] && w > dis[i]) {
			w = dis[i]; pos = i;
		}
	return pos;
}

int Prim() {
	int i, u, v, sum = 0;
	for(i = 0; i < n; ++i) {
		vis[i] = 0; dis[i] = inf;
	}
	dis[u = 0] = 0;
	while(u != -1) {
		vis[u] = 1; sum += dis[u];
		for(i = head[u]; i != -1; i = E[i].next)
			if(!vis[v = E[i].v] && dis[v] > E[i].w)
				dis[v] = E[i].w;
		u = getNext();
	}
	return sum;
}

void solve() {
	printf("The highest possible quality is 1/%d.\n", Prim());
}

int main() {
	while(scanf("%d", &n), n) {
		getMap();
		solve();
	}
	return 0;
}

版权声明:本文博客原创文章,博客,未经同意,不得转载。

时间: 2024-10-23 18:31:32

POJ1789 Truck History 【最小生成树Prim】的相关文章

POJ1789 Truck History【Prim】

Truck History Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 19456 Accepted: 7498 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. T

poj 1789 Truck History 最小生成树 prim

Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 19122   Accepted: 7366 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for brick

POJ1789:Truck History(Prim算法)

http://poj.org/problem?id=1789 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. Th

POJ 1789 -- Truck History(Prim)

 POJ 1789 -- Truck History Prim求分母的最小.即求最小生成树 1 #include<iostream> 2 #include<cstring> 3 #include<algorithm> 4 using namespace std; 5 const int maxn = 2000 + 10; 6 const int INF = 1000000; 7 int n;//有几个卡车 8 char str[maxn][10]; 9 int d[ma

POJ 1789:Truck History 【Prim】

Truck History Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other) Total Submission(s) : 123   Accepted Submission(s) : 36 Problem Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are

POJ #1789 Truck History 最小生成树(MST) prim 稠密图 链式向前星

Description 题目:链接 这道题的数据集网上比较少,提供一组自己手写的数据: INPUT: 3 aaaaaaa baaaaaa abaaaaa OUTPUT: The highest possible quality is 1/2. 思路 题意比较不好理解,简而言之就是有 n 个字符串,设两个字符串之间的差异为 dis,dis 由两个字符串对应位置上不同字母的数量决定.比如串A"aaaaaaa" .串B"baaaaaa" 和串C"abaaaaa&

poj 1789 Truck History 最小生成树

Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of ex

POJ1789&amp;ZOJ2158--Truck History【最小生成树变形】

链接:http://poj.org/problem?id=1789 题意:卡车公司有悠久的历史,它的每一种卡车都有一个唯一的字符串来表示,长度为7,它的所有卡车(除了第一辆)都是由以前的卡车派生出来的.现在一些砖家想研究这些卡车的历史,他们定义了卡车类型编码的距离:卡车编码字符串(长度7)相同位置字符不同的个数.比如一个卡车编码是aaaaaaa,另一个是bbaaaaa,则他们的距离是2,.他们又定义了派生方案的优劣值:1/Σ(to,td)d(to,td). 其中t0为基类型,td为派生类型,d(

poj1789Truck History(最小生成树prim算法)

题目链接: 啊哈哈,点我点我 思路:根据字符串中不同的长度建图,然后求图的最小生成树.. 题目: Truck History Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18272   Accepted: 7070 Description Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vege