POJ 3080 Blue Jeans(KMP 最长公共子串)

Blue Jeans

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string
"no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题意   给你n个DNA串   求它们的长度最大的公共子串   如果有多个  输出字典序最小的   长度小于3的不算

每个DNA串的长度都是60  可以从子串长度为60依次递减   并枚举所有该长度子串  当某个长度的子串也为其它n-1个串的子串时   就是我们要的答案了

判断是否为其它DNA串的子串直接kmp就行了

#include<cstdio>
#include<cstring>
using namespace std;
const int N = 15, M = 65, L = 60;

bool kmp (char s[], char p[])
{
    int next[M];
    next[0] = -1, next[1] = 0;
    int plen = strlen (p), i = 0, j,slen = strlen (s);
    while (++i < plen - 1)
    {
        j = next[i];
        while (j != -1 && p[i] != p[j])
            j = next[j];
        next[i + 1] = j + 1;
    }

    i = j = 0;
    while (i < slen && j < plen)
    {
        if (j == -1 || s[i] == p[j]) ++i, ++j;
        else j = next[j];
    }
    return j == plen;
}

int main()
{
    int cas, n, flag;
    char s[N][M], tans[M],ans[M];
    scanf ("%d", &cas);
    while (cas--)
    {
        scanf ("%d", &n);
        for (int i = flag = 0; i < n; ++i)
            scanf ("%s", s[i]);
        for (int lans = L; lans > 2 && flag == 0; --lans)
        {
            strcpy(ans,"ZZ");
            for (int i = 0, j, k; i + lans <= L; ++i)
            {
                for (j = 0; j < lans; ++j)
                    tans[j] = s[0][i + j];
                tans[j] = '\0';

                for (k = 1; k < n; ++k)
                    if (!kmp (s[k], tans)) break;

                if (k == n)
                {
                    if(strcmp(ans,tans)>0) strcpy(ans,tans);
                    flag = 1;
                }
            }
        }

        if (flag == 1) printf ("%s\n", ans);
        else printf ("no significant commonalities\n");
    }
    return 0;
}

POJ 3080 Blue Jeans(KMP 最长公共子串)

时间: 2024-10-11 22:58:31

POJ 3080 Blue Jeans(KMP 最长公共子串)的相关文章

poj 3080 Blue Jeans (kmp暴力)

# include <stdio.h> # include <algorithm> # include <cstring> using namespace std; int next[100]; char pat[100]; char a[100][100]; int ma; int lenp; int n; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=lenp) { if(j==-1||pat[j]==

POJ 3080 Blue Jeans KMP解法

使用KMP寻找最长的前缀的方法,比一般的暴力法有快了很多. 本题一般的暴力法需要的是O(m*n*n*n),其中m是有多少字符串,而n是字符串长度,而使用KMP就可以把时间效率提高到O(m*n*n),减少了一个n,提高了一个档次啦. 速度快很多. 准确来说应该是利用KMP寻找一个字符串A,在另一个字符串B任意位置出现的A的最长的前缀字符串. 理解好KMP的next table就好办了.每次查找到相等字符的时候,保存好最长的前缀. 注意本题的条件:选取最前的字典顺序输出.老害我错的条件. #incl

POJ 3080 Blue Jeans KMP

题意:找出所有字符串中最长相同字串 解题思路:枚举KMP 解题代码: 1 // File Name: getnext.cpp 2 // Author: darkdream 3 // Created Time: 2014年09月09日 星期二 22时35分02秒 4 5 #include<vector> 6 #include<list> 7 #include<map> 8 #include<set> 9 #include<deque> 10 #in

POJ 3080 Blue Jeans Trie后缀树解法

题目是牛仔裤的意思,不过看不出题意和Blue Jeans有什么关系. 本题的数据是很水的,数据量小,故此可以使用非常暴力的方法过,也可以使用不那么暴力的KMP过. 这里使用更加不暴力的Trie后缀树过,这种解法就一点都不水了,呵呵. 思路: 1 建立所有字符串的后缀Trie树 2 增加额外信息,看每过路径是否是所有的字符串都经过了,如果是,那么就是合法的字符串了,查找最长的这样的字符串 3 优化一下:如果不是所有字符串的经过的路径,那么就可以直接返回,不往下搜索了 最后,我发现删除Trie都是很

POJ 3080 Blue Jeans 三种暴力法

本题可以使用暴力法直接求解,思路也挺简单的,不过实现起来也挺麻烦的. 本题最暴力直接使用strstr过. 这里使用hash表的方法过,这种方法好像有个学名的,主要思路就是把一个需要查找的字符串赋予一个数值,那么就可以把一串字符串的比较转换为一个值的比较了,那么就可以加速字符串的查找了. #include <stdio.h> #include <string.h> #include <stdlib.h> const long long MOD = (int)(1E9+7)

poj 3080 Blue Jeans (KMP)

http://poj.org/problem?id=3080 Blue Jeans Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populate

poj 3080 Blue Jeans(kmp)

Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM researcher, you have been tas

POJ 3080 Blue Jeans(后缀数组+二分答案)

[题目链接] http://poj.org/problem?id=3080 [题目大意] 求k个串的最长公共子串,如果存在多个则输出字典序最小,如果长度小于3则判断查找失败. [题解] 将所有字符串通过拼接符拼成一个串,做一遍后缀数组,二分答案,对于二分所得值,将h数组大于这个值的相邻元素分为一组,判断组内元素是否覆盖全字典,是则答案成立,对于答案扫描sa,输出第一个扫描到的子串即可. [代码] #include <cstdio> #include <cstring> #inclu

POJ 2774 Long Long Message (最长公共子串)

Long Long Message Time Limit: 4000MS   Memory Limit: 131072K Total Submissions: 27062   Accepted: 11010 Case Time Limit: 1000MS Description The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days