Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory
Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15730 Accepted Submission(s): 11092
链接: hdu 1028
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627题意
题意:赤裸裸的整数划分,求N的划分成1~N中的数的和的形式的个数。分析
整数划分的题目有很多种解决的方法,有DP的解法,有也完全背包的解法。这里仅给出一个递归的解法,用dp[n][m]表示整数N的划分中最大的为m的方法数,那么有dp[n][m] = Dp[n, m]= 1; (n=1 or m=1) Dp[n, n]; (n<m) 1+ dp[n, m-1]; (n=m) Dp[n-m,m]+dp[n,m-1]; (n>m) 这里链接大牛们的其他做法: 母函数 、 递归 完全 背包参考代码
#include <cmath> #include <queue> #include <vector> #include <cstdio> #include <string> #include <cstring> #include <iomanip> #include <iostream> #include <algorithm> using namespace std; //#pragma comment(linker, "/STACK:1024000000,1024000000") #define FIN freopen("input.txt","r",stdin) #define FOUT freopen("output.txt","w",stdout) #define CASE(T) for(scanf("%d",&T);T--;) const int maxn = 120 + 5; int dp[maxn][maxn]; int dfs(int n, int m) { if(dp[n][m] != -1) return dp[n][m]; if(n < 1 || m < 1) return dp[n][m] = 0; if(n == 1 || m == 1) return dp[n][m] = 1; if(n < m) return dp[n][m] = dfs(n, n); if(n == m) return dp[n][m] = dfs(n, m - 1) + 1; return dp[n][m] = dfs(n, m - 1) + dfs(n - m, m); } int main() { // FIN; int N; while(~scanf("%d", &N)) { printf("%d\n", dfs(N, N)); } return 0; }
版权声明:本文为博主原创文章,未经博主允许不得转载。