poj1459 Power Network

Power Network

Time Limit: 2000MS   Memory Limit: 32768K
Total Submissions: 25843   Accepted: 13488

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.

Source

Southeastern Europe 2003

最大流模板。

题目要求多源多汇最大流。方法为添加两个点,分别为超级源点S和超级汇点T,再将所有源点与S连边,所有汇点与T连边,求S到T的最大流。

注意:BFS用到的STL队列模板要写到子函数里,具体为什么我也不太清楚,写在外面会出错。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<queue>
#define F(i,j,n) for(int i=j;i<=n;i++)
#define D(i,j,n) for(int i=j;i>=n;i--)
#define LL long long
#define pa pair<int,int>
#define MAXN 105
#define MAXM 30000
#define INF 1000000000
using namespace std;
struct edge_type
{
	int next,to,v;
}e[MAXM];
int n,m,np,nc,x,y,z,s,t,ans,cnt,dis[MAXN],head[MAXN],cur[MAXN];
inline void add_edge(int x,int y,int v)
{
	e[++cnt]=(edge_type){head[x],y,v};head[x]=cnt;
	e[++cnt]=(edge_type){head[y],x,0};head[y]=cnt;
}
inline bool bfs()
{
	queue<int>q;
	memset(dis,-1,sizeof(dis));
	dis[s]=0;q.push(s);
	while (!q.empty())
	{
		int tmp=q.front();q.pop();
		if (tmp==t) return true;
		for(int i=head[tmp];i;i=e[i].next) if (e[i].v&&dis[e[i].to]==-1)
		{
			dis[e[i].to]=dis[tmp]+1;
			q.push(e[i].to);
		}
	}
	return false;
}
inline int dfs(int x,int f)
{
	int tmp,sum=0;
	if (x==t) return f;
	for(int &i=cur[x];i;i=e[i].next)
	{
		int y=e[i].to;
		if (e[i].v&&dis[y]==dis[x]+1)
		{
			tmp=dfs(y,min(f-sum,e[i].v));
			e[i].v-=tmp;e[i^1].v+=tmp;sum+=tmp;
			if (sum==f) return sum;
		}
	}
	if (!sum) dis[x]=-1;
	return sum;
}
inline void dinic()
{
	ans=0;
	while (bfs())
	{
		if (!dis[t]) return;
		F(i,1,n+2) cur[i]=head[i];
		ans+=dfs(s,INF);
	}
}
int main()
{
	while (scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
	{
		char ch;
		s=n+1;t=n+2;cnt=1;
		memset(head,0,sizeof(head));
		F(i,1,m)
		{
			ch=getchar();
			while (ch!='(') ch=getchar();
			scanf("%d,%d)%d",&x,&y,&z);x++;y++;
			if (x!=y) add_edge(x,y,z);
		}
		F(i,1,np)
		{
			ch=getchar();
			while (ch!='(') ch=getchar();
			scanf("%d)%d",&x,&z);x++;
			add_edge(s,x,z);
		}
		F(i,1,nc)
		{
			ch=getchar();
			while (ch!='(') ch=getchar();
			scanf("%d)%d",&x,&z);x++;
			add_edge(x,t,z);
		}
		dinic();
		printf("%d\n",ans);
	}
}
时间: 2024-10-11 05:48:05

poj1459 Power Network的相关文章

poj1459 Power Network --- 最大流 EK/dinic

求从电站->调度站->消费者的最大流,给出一些边上的容量,和电站和消费者可以输入和输出的最大量. 添加一个超级源点和汇点,建边跑模板就可以了.两个模板逗可以. #include <iostream> #include <cstring> #include <string> #include <cstdio> #include <cmath> #include <algorithm> #include <vector&

Poj1459 Power Network 预流推进

Poj1459 Power Network 预流推进 问题描述: A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p ma

POJ-1459 Power Network(最大流模板)

题目链接:POJ-1459 Power Network 题意 有$np$个发电站,$nc$个消费者,$m$条有向边,给出每个发电站的产能上限,每个消费者的需求上限,每条边的容量上限,问最大流量. 思路 很裸的最大流问题,源点向发电站连边,边权是产能上限,消费者向汇点连边,边权是需求上限,其余的连边按给出的$m$条边加上去即可. 代码实现 #include <iostream> #include <cstdio> #include <cstring> #include &

POJ1459 Power Network(网络最大流)

Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 27229   Accepted: 14151 Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied

POJ1459 Power Network【最大流】【Edmond-Karp】

第一道网络流题,纪念下~~~ 题目链接: http://poj.org/problem?id=1459 题目大意: 一个电力网络包含很多节点(发电站.消费者以及中转站)和电力传输线.所有发电站不消耗电力, 所有消费者不产生电力,所有中转站不产生也不消耗电力.在网络中,任意两点u和v之间最多只 有一条传输线的存在,且能够从u望v传输最多w单位容量.计算整个网络的最大电力消耗. 思路: 一道非常基础.非常典型的网络流题目.每个发电站当做一个源点,每个消费者当做一个汇点.但 是这样子并不适合任何一种求

《网络流学习笔记03&amp;&amp;POJ1459 Power Network》

题目链接:click here 题意:一个电力网络有n个点,有np个发电站,nc个消耗点,其余的为中转站.m条电缆,中转站既不发电也不耗电.每条电缆都有一个最大容量. 思路:设置一个超级源点和一个超级汇点,将所有的源点和汇点分别放进去,Dinic 算法实现. 注意括号的处理. 代码: #include <math.h> #include <queue> #include <deque> #include <vector> #include <stack

POJ1459:Power Network(dinic)

题目链接:http://poj.org/problem?id=1459 题意:有n个结点,np个发电站,nc个消费者,m个电力运输线.接下去是m条边的信息(u,v)cost,cost表示边(u,v)的最大流量:a个发电站的信息(u)cost,cost表示发电站u能提供的最大流量:b个用户的信息(v)cost,cost表示每个用户v能接受的最大流量. 思路:在图中添加1个源点S和汇点T,将S和每个发电站相连,边的权值是发电站能提供的最大流量:将每个用户和T相连,边的权值是每个用户能接受的最大流量.

poj1459(Power Network)

题目地址:Power Network 题目大意: 输入分别为m个点,a个发电站,b个用户,n条边:接下去是n条边的信息(u,v)cost,cost表示边(u,v)的最大流量:a个发电站的信息(u)cost,cost表示发电站u能提供的最大流量:b个用户的信息(v)cost,cost表示每个用户v能接受的最大流量. 求发电站流向用户的最大流量. 解题思路: 最大流问题 ,首先建图,我让m+1这个节点为源点S,让m这个点为汇点T.求流入T的最大流即可. 代码: 1 #include <algorit

Power Network (poj 1459 网络流)

Language: Default Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 23407   Accepted: 12267 Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node