HDU5137 How Many Maos Does the Guanxi Worth(枚举+dijkstra)

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 760    Accepted Submission(s): 290

Problem Description

"Guanxi" is a very important word in Chinese. It kind of means
"relationship" or "contact". Guanxi can be based on friendship, but also
can be built on money. So Chinese often say "I don‘t have one mao (0.1
RMB) guanxi with you." or "The guanxi between them is naked money
guanxi." It is said that the Chinese society is a guanxi society, so you
can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the
middle school entrance examinations in order to relief studying burden
of primary school students. Because there is no clear and strict
standard of entrance, someone may make their children enter good middle
schools through guanxis. Boss Liu wants to send his kid to a middle
school by guanxi this year. So he find out his guanxi net. Boss Liu‘s
guanxi net consists of N people including Boss Liu and the schoolmaster.
In this net, two persons who has a guanxi between them can help each
other. Because Boss Liu is a big money(In Chinese English, A "big money"
means one who has a lot of money) and has little friends, his guanxi
net is a naked money guanxi net -- it means that if there is a guanxi
between A and B and A helps B, A must get paid. Through his guanxi net,
Boss Liu may ask A to help him, then A may ask B for help, and then B
may ask C for help ...... If the request finally reaches the
schoolmaster, Boss Liu‘s kid will be accepted by the middle school. Of
course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu‘s plan. All you
can do is to persuade ONE person in Boss Liu‘s guanxi net to reject any
request. This person can be any one, but can‘t be Boss Liu or the
schoolmaster. If you can‘t make Boss Liu fail, you want Boss Liu to
spend as much money as possible. You should figure out that after you
have done your best, how much at least must Boss Liu spend to get what
he wants. Please note that if you do nothing, Boss Liu will definitely
succeed.

Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N
people in Boss Liu‘s guanxi net. They are numbered from 1 to N. Boss
Liu is No. 1 and the schoolmaster is No. N. M means that there are M
guanxis in Boss Liu‘s guanxi net. (3 <=N <= 30, 3 <= M <=
1000)

Then M lines follow. Each line contains three integers
A, B and C, meaning that there is a guanxi between A and B, and if A
asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It‘s guaranteed that Boss Liu‘s request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend
after you have done your best. If Boss Liu will fail to send his kid to
the middle school, print "Inf" instead.

Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

Sample Output

50

Inf

题意:1到n个人,在删除一个人(除第1个人和第n个人外)情况下,求打通关系从第一个1到第n人所花费最多的钱。

思路:枚举+dijkstra

收获:dijkstra应用。dijkstra:求单源最短路径,边权要为正。

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);

const int maxn=5000;
int w[maxn][maxn];
int n, m;
int v[maxn];
int d[maxn];
int num[maxn];
int dijkstra(int k)
{
    memset(v, 0, sizeof(v));
    v[k] = 1;
    for(int i = 1; i <= n; i++) d[i] = (i==1 ? 0 : INF);
    for(int i = 1; i <= n; i++)
    {
        int x, m = INF;
        for(int j = 1; j <= n; j++) if(!v[j] && d[j]<=m) m = d[x=j];
        v[x]=1;
        for(int j = 1; j <= n; j++) d[j] = min(d[j], d[x] + w[x][j]);
    }
    return d[n];
}
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        if(n==0 && m==0)
            break;
        memset(w, INF, sizeof(w));
        int a, b, t;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &a, &b, &t);
            w[a][b] = w[b][a] = min(t, w[a][b]);
        }
        //int ans = INF;
        int cnt = 0;
        memset(num, INF, sizeof(num));
        for(int i = 2; i < n; i++) cnt = max(cnt, dijkstra(i));
        if(cnt == INF)
            printf("Inf\n");
        else
            printf("%d\n", cnt);
    }
    return 0;
}
时间: 2024-10-05 14:12:19

HDU5137 How Many Maos Does the Guanxi Worth(枚举+dijkstra)的相关文章

HDOJ 5137 How Many Maos Does the Guanxi Worth 枚举+Dijkstra

枚举点暴力Dijkstra.... How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 96    Accepted Submission(s): 34 Problem Description "Guanxi" is a very important wo

hdu 5137 How Many Maos Does the Guanxi Worth(dijkstra &amp;&amp; floyd)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 853    Accepted Submission(s): 326 Problem Description "Guanxi" is a very important word in Chinese. I

ACM学习历程——HDU5137 How Many Maos Does the Guanxi Worth(14广州10题)(单源最短路)

Problem Description "Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one ma

hdu5137 How Many Maos Does the Guanxi Worth(单源最短路径)

题目链接:点击打开链接 题目描述:现在有一张关系网,网中有n个结点标号为1-n,有m个关系,每个关系之间有一个权值.问从2-n-1中任意去掉一个结点之后,从1-n的距离中所有最小值的最大值为多少? 解题思路:多次调用Dijkstra即可,每次标记那个结点不通即可 代码: #include <cstdio> #include <queue> #include <cstring> #define MAXN 31 #define MAXE 1010 #define INF 1

HDU5137 How Many Maos Does the Guanxi Worth (13广州现场赛K题 )--最短路问题

链接:click here 题意:从2~n-1这几个点中任意去掉一个点,使得从1到n的最短路径最大,如果任意去掉一个点1~n无通路输出Inf. 去年这道题现场是队友1A过的,感觉好NB,当时还不会最短路问题,只是脑子里大概有这么个印象,做了之发现数据比较水,今天看了一下Dijkstra 和Floyd,用两种算法实现了一下: 题目描述有点长,但是搞清楚了,就很容易了,因为数据实在很水,算是最短路入门训练的一道题了 Dijkstra 算法 (1)令S={源点s + 已经确定了最短路径的顶点vi} (

How Many Maos Does the Guanxi Worth

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 864    Accepted Submission(s): 329 Problem Description "Guanxi" is a very important word in Chinese. It

HDU 5137 How Many Maos Does the Guanxi Worth(暴力+spfa)

题目大意:给你一个关系图,让你再删除一个点之后(除了1,和n).让你求出来从1到n的最短路的最大值,如果不可达输出Inf. 解题思路:题意也说了,就是暴力枚举点,然后跑n-2次spfa求出来一个最大值就可以了. How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 4

hdoj 5137 How Many Maos Does the Guanxi Worth 【枚举删点 + 最短路】

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 847    Accepted Submission(s): 322 Problem Description "Guanxi" is a very important word in Chinese. I

HDU 5137 How Many Maos Does the Guanxi Worth (14广州 Floyd 最短路)

How Many Maos Does the Guanxi Worth Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 468    Accepted Submission(s): 164 Problem Description "Guanxi" is a very important word in Chinese. I