[POJ] String Matching

String Matching

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4074   Accepted: 2077

Description

It‘s easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY 
MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY
     MARSUPIAL

with two common letters (A and R), but the best is:

   CAPILLARY
MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by: 
common letters * 2 
----------------------------- 
length(word1) + length(word2)
Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.

Input

The input for your program will be a series of words, two per line, until the end-of-file flag of -1. 
Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. 
The words will all be uppercase.

Output

Print the value for appx() for each pair as a reduced fraction,Fractions reducing to zero or one should have no denominator.

Sample Input

CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1

Sample Output

appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1

字符匹配问题:按着题目要求写就好了记住要相反方向进行两次求值
#include<iostream>
#include<string>
using namespace std;

int appx(string& word1,string&word2)
{
	int count = 0;
	int max = 0;

	int length1 = word1.length();
	int length2 = word2.length();

	for (int i = 0; i<length1; i++)
	{
		count = 0;
		for (int j = 0; j<length2&&i + j<length1; j++)
		{
			if (word1[i + j] == word2[j])
				count++;
		}
		if (max<count)
			max=count;
	}

	return max;
}

int main()
{
	string word1;
	string word2;

	while (cin >> word1&&word1 != "-1")
	{
		cin >> word2;
		int len1 = word1.length();
		int len2 = word2.length();

		int app1 = appx(word1,word2);
		int app2 = appx(word2,word1);

		if (app1<app2)app1 = app2;

		cout << "appx(";
		for (int i = 0; i<len1; i++)
			cout << word1[i];
		cout << ",";
		for (int i = 0; i<len2; i++)
			cout << word2[i];
		cout << ") = ";

		if (app1 == 0)cout << 0 << endl;
		else
		{
			len1 += len2;
			app1 *= 2;
			for (int i = 2; i <= ((len1<app1) ? len1 : app1); i++)
				while (app1%i == 0 && len1%i == 0)
				{
					app1 /= i;
					len1 /= i;
				}

			if (app1%len1 != 0)
				cout << app1 << ‘/‘ << len1 << endl;
			else
				cout << app1 / len1 << endl;
		}
	}

	return 0;
}

  

时间: 2024-10-08 10:11:34

[POJ] String Matching的相关文章

poj 1580 String Matching(比较字符串的相似程度,四个for循环即可)

String Matching Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 3717   Accepted: 1913 Description It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close

KMP String Matching Algorithm

This is a program based on Knuth-Morris-Pratt String Matching Algorithm (a.k.a KMP algorithm), which can solve the problem POJ 3461. 1 import java.io.*; 2 import java.util.*; 3 4 class Input { 5 private Scanner in; 6 private StringTokenizer tok; 7 8

String Matching -- Brute Force + Rabin-Karp + KMP

String Matching 这个问题已经被做烂了... 下面是C语言实现集合. http://www-igm.univ-mlv.fr/~lecroq/string/ 留个爪- 暴力解法: 暴力美啊- """ Programmer : EOF Date : 2015.02.28 Code file : nsm.py """ def naive_string_matcher(T, P) : if (T or P) is None : return

HDU1306 String Matching 【暴力】

String Matching Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 847    Accepted Submission(s): 434 Problem Description It's easy to tell if two words are identical - just check the letters. But

九度OJ 1094 String Matching

题目1094:String Matching 时间限制:1 秒 内存限制:32 兆 特殊判题:否 提交:1098 解决:587 题目描述: Finding all occurrences of a pattern in a text is a problem that arises frequently in text-editing programs. Typically,the text is a document being edited,and the pattern searched

NYOJ 5 Binary String Matching【string find的运用】

Binary String Matching 时间限制:3000 ms  |  内存限制:65535 KB 难度:3 描述 Given two strings A and B, whose alphabet consist only '0' and '1'. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is '100111011

NYOJ5 Binary String Matching

Binary String Matching 时间限制:3000 ms  |  内存限制:65535 KB 难度:3 描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘100111011

NYOJ 5 Binary String Matching (kmp 字符串匹配)

Binary String Matching 时间限制:3000 ms  |  内存限制:65535 KB 难度:3 描述 Given two strings A and B, whose alphabet consist only '0' and '1'. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is '100111011

NYOJ题目5---Binary String Matching

Binary String Matching 时间限制:3000 ms  |  内存限制:65535 KB 难度:3 描述 Given two strings A and B, whose alphabet consist only '0' and '1'. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is '100111011