1074 Reversing Linked List (25分) 链表反转

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤) which is the total number of nodes, and a positive K (≤) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解题思路:

这道题目,用一个vector,按照顺序把 节点依次存起来,输入是4 - > 1 - > 6 -> 3 ->5 -> 2  按照 1->2->3->4->5->6存放,再反转vector

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<vector>
#include<algorithm>

using namespace std;

typedef struct Node{
	int data;
	int order;
	int next;
}Node;
Node nodes[100010];
int main(){
//	freopen("C:\\Users\\zzloyxt\\Desktop\\1.txt","r",stdin);

	int first,n,k;
	scanf("%d %d %d",&first,&n,&k);

	for(int i=0;i<n;i++){
		int data,order,next;
		scanf("%d %d %d",&data,&order,&next);
		nodes[data].data = data;
		nodes[data].order = order;
		nodes[data].next = next;
	}
	vector<Node> V;

	for(int i=first;i!=-1;i = nodes[i].next){
		V.push_back(nodes[i]);
	}

	for(int i=0;i<=V.size()-k;i=i+k){
		reverse(V.begin()+i,V.begin()+i+k);
	}

	for(int i=0;i<V.size()-1;i++){
		printf("%05d %d %05d\n",V[i].data,V[i].order,V[i+1].data);
	}

	printf("%05d %d %d\n",V[V.size()-1].data, V[V.size()-1].order,-1);

	return 0;
}

注意这里的reverse()函数,传的是iterator,reverse(V.begin(), V.begin() + k),最后一个单独输出

原文地址:https://www.cnblogs.com/zzlback/p/12419612.html

时间: 2024-10-07 12:20:29

1074 Reversing Linked List (25分) 链表反转的相关文章

【PAT甲级】1074 Reversing Linked List (25 分)

题意: 输入链表头结点的地址(五位的字符串)和两个正整数N和K(N<=100000,K<=N),接着输入N行数据,每行包括结点的地址,结点的数据和下一个结点的地址.输出每K个结点局部反转的链表. trick: 测试点6包含一些不在起点这条链表上的结点. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;map<string,pair<int,string> >

PAT 1074. Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L.  For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6. Input Specifica

1074. Reversing Linked List (25)

reverse 方法很好用 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then yo

浙大数据结构课后习题 练习二 7-2 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6. Input Specification:

PAT (Advanced Level) 1074. Reversing Linked List (25)

简单题. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; const int maxn=100000+10

A1074 Reversing Linked List (25分)未解决看懂

二.参考代码 #include<cstdio> #include<iostream> using namespace std; int main(){ int first, k, n, sum = 0; cin >> first >> n >> k; int temp, data[100010], next[100010], list[100010], result[100010]; for(int i = 0; i < n; i++){

PAT 1074 Reversing Linked List[链表][一般]

1074 Reversing Linked List (25)(25 分) Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you mus

PAT1074 Reversing Linked List (25)详细题解

02-1. Reversing Linked List (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6,

pat02-线性结构1. Reversing Linked List (25)

02-线性结构1. Reversing Linked List (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→