POJ 1703 Find them, Catch them(确定元素归属集合的并查集)

Find them, Catch them

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 52925   Accepted: 16209

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

题目意思:

现在又两个犯罪团伙

罪犯编号1到n,现在又两种操作:

1.D x y 告诉你编号x的罪犯和编号y的罪犯属于不同犯罪团伙

2.A x y 问你x和y是不是属于同一个犯罪犯罪团伙,三种情况,是同一个,不是同一个,不确定

分析:

union_set(x, y)同属于第一个团伙

union_set(x+n,y+n)同属于第二个团伙

union_set(x+n, y)表示x属于第二个团伙,y属于第一个团伙

union_set(x, y+n)表示x属于第一个团伙,y属于第二个团伙;

每次告诉你x和y属于不同团伙,有两种情况,x属于1,y属于2

x属于2,y属于1,所以需要这样进行两次合并

确定是否属于相同团伙的话

x与y的根结点相同或者x+n与y+n的根结点相同 都属于相同犯罪团伙

x+n与y根结点相同或者x与y+n的根结点相同,都属于不同犯罪团伙

其他情况就不能确定了

这个思路很巧妙,也比较简单,不用具体确定x属于1还是2

code:

#include<queue>
#include<set>
#include<cstdio>
#include <iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define max_v 100005
int pa[max_v*2];
int rk[max_v*2];
int n,m;
void init()
{
    for(int i=0; i<=2*n; i++)
    {
        pa[i]=i;
        rk[i]=0;
    }
}
int find_set(int x)
{
    if(x!=pa[x])
        pa[x]=find_set(pa[x]);
    return pa[x];
}
void union_set(int x,int y)
{
    x=find_set(x);
    y=find_set(y);
    if(x==y)
        return ;
    if(rk[x]>rk[y])
        pa[y]=x;
    else
    {
        pa[x]=y;
        if(rk[x]==rk[y])
            rk[y]++;
    }
}
int f(int x,int y)
{
    return find_set(x)==find_set(y);
}
int main()
{
    int t;
    scanf("%d",&t);
    int x,y;
    char str[10];
    while(t--)
    {
        scanf("%d %d",&n,&m);
        init();

        for(int i=0; i<m; i++)
        {
            scanf("%s %d %d",str,&x,&y);
            if(str[0]==‘D‘)
            {
                union_set(x+n,y);
                union_set(x,y+n);
            }
            else if(str[0]==‘A‘)
            {
                if(f(x,y)||f(x+n,y+n))
                    printf("In the same gang.\n");
                else if(f(x+n,y)||f(x,y+n))
                    printf("In different gangs.\n");
                else
                    printf("Not sure yet.\n");
            }
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/yinbiao/p/9463647.html

时间: 2024-10-18 04:53:22

POJ 1703 Find them, Catch them(确定元素归属集合的并查集)的相关文章

POJ 2236 Wireless Network ||POJ 1703 Find them, Catch them 并查集

POJ 2236 Wireless Network http://poj.org/problem?id=2236 题目大意: 给你N台损坏的电脑坐标,这些电脑只能与不超过距离d的电脑通信,但如果x和y均能C通信,则x和y可以通信.现在给出若干个操作, O p 代表修复编号为p的电脑 S p q代表询问p和q是不是能通信. 思路: 并查集即可.. 如果修复了一台电脑,则把与它相连距离不超过d的且修复了的放在一个集合里面. #include<cstdio> #include<cstring&

POJ 1703 Find them, Catch them(数据结构-并查集)

Find them, Catch them Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal b

[ACM] POJ 2513 Colored Sticks (Trie树,欧拉通路,并查集)

Colored Sticks Time Limit: 5000MS   Memory Limit: 128000K Total Submissions: 29736   Accepted: 7843 Description You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a st

poj 1703 Find them, Catch them(种类并查集和一种巧妙的方法)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 36176   Accepted: 11090 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago

poj 1703 Find them, Catch them(带权并查集和一种巧妙的方法)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 36176   Accepted: 11090 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago

POJ 1703 Find them, Catch them(带权并查集)

传送门 Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 42463   Accepted: 13065 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang D

POJ 1703 Find them, Catch them (数据结构-并查集)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 31102   Accepted: 9583 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon

POJ 1703 Find them, catch them (并查集)

题目:Find them,Catch them 刚开始以为是最基本的并查集,无限超时. 这个特殊之处,就是可能有多个集合. 比如输入D 1 2  D 3 4 D 5 6...这就至少有3个集合了.并且任意2个集合之间成员的敌我关系不明. 这里每个集合里面的成员关系要记录,他们在一个集合里,只是因为他们关系明确,敌人或者朋友. 千万不要简单的认为成朋友在一个集合,敌人在另外一个集合,分成2个集合.因为题目说只有2个匪帮,很容易进入这个误区. 我们只要记录一个成员和自己父亲的敌我关系和建树就可以了.

poj 1703 Find them, Catch them 【并查集拓展】

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 32514   Accepted: 10036 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago