HDOJ 1007 Quoit Design 最近点对

3年前刚接触ACM的时候做的这一题,交了几十次怎么写都过不了.........

今天无意中又看到了这一题,随手一写终于过了.....

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 33151    Accepted Submission(s): 8709

Problem Description

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.

In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a
configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered
to be 0.

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated
by N = 0.

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output

0.71
0.00
0.75

Author

CHEN, Yue

Source

ZJCPC2004

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const double eps=1e-8;
const int maxn=100100;

int n;

int dcmp(double x)
{
	if(fabs(x)<eps) return 0;
	return (x>0)?1:-1;
}

struct Point
{
	double x,y;
}p[maxn],temp[maxn];

bool cmpxy(Point a,Point b)
{
	if(dcmp(a.x-b.x)!=0)
		return dcmp(a.x-b.x)<0;
	return dcmp(a.y-b.y)<0;
}

bool cmpy(Point a,Point b)
{
	return dcmp(a.y-b.y)<0;
}

inline double square(double x)
{
	return x*x;
}

double dist(Point a,Point b)
{
	return sqrt(square(a.x-b.x)+square(a.y-b.y));
}

double Close_pair(int left,int right)
{
	double d=1e30;
	if(left==right) return d;
	if(left+1==right) return dist(p[left],p[right]);
	int mid=(left+right)/2;
	d=min(Close_pair(left,mid),Close_pair(mid+1,right));
	int k=0;
	for(int i=left;i<=right;i++)
	{
		if(dcmp(square(p[i].x-p[mid].x)-d)<=0)
		{
			temp[k++]=p[i];
		}
	}
	sort(temp,temp+k,cmpy);
	for(int i=0;i<k;i++)
	{
		for(int j=i+1;j<k&&dcmp(square(temp[i].y-temp[j].y)-d)<0;j++)
		{
			d=min(d,dist(temp[i],temp[j]));
		}
	}
	return d;
}

int main()
{
	while(scanf("%d",&n)!=EOF&&n)
	{
		for(int i=0;i<n;i++)
		{
			double x,y;
			scanf("%lf%lf",&x,&y);
			p[i].x=x;p[i].y=y;
		}
		sort(p,p+n,cmpxy);
		printf("%.2lf\n",Close_pair(0,n-1)/2.);
	}
	return 0;
}
时间: 2024-10-29 03:23:06

HDOJ 1007 Quoit Design 最近点对的相关文章

Hdoj 1007 Quoit Design 题解

Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. In the field of Cyberground, the position of each toy is fixed, and the ring is careful

ZOJ 2107 HDU 1007 Quoit Design(最近点对)

最近点对的裸题 利用分治去搞搞即可 代码: #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> using namespace std; const int N = 100005; struct Point { double x, y; void read() { scanf("%lf%lf", &x, &y); } }; b

hdu 1007 Quoit Design 分治求最近点对

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 29344    Accepted Submission(s): 7688 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 Quoit Design (分治)

Quoit Design Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. In the field of Cyberground, the position of each toy is fixed, and the ri

HDU 1007 Quoit Design【计算几何/分治/最近点对】

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 58566    Accepted Submission(s): 15511 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 Quoit Design

Quoit Design Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 130 Accepted Submission(s): 72   Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings a

分治 [HDU 1007] Quoit Design

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33577    Accepted Submission(s): 8800 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat

HDU 1007 Quoit Design(二分+浮点数精度控制)

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 47104    Accepted Submission(s): 12318 Problem Description Have you ever played quoit in a playground? Quoit is a game in which fla

poj 1007 Quoit Design(分治)

Quoit Design Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29694    Accepted Submission(s): 7788 Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat