PAT 甲级 1066 Root of AVL Tree

https://pintia.cn/problem-sets/994805342720868352/problems/994805404939173888

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then Ndistinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

代码:

#include <bits/stdc++.h>
using namespace std;
struct node {
    int val;
    struct node *left, *right;
};
node *rotateLeft(node *root) {
    node *t = root -> right;
    root -> right = t -> left;
    t -> left = root;
    return t;
}

node *rotateRight(node *root) {
    node *t = root -> left;
    root -> left = t -> right;
    t -> right = root;
    return t;
}

node *rotateLeftRight(node *root) {
    root -> left = rotateLeft(root -> left);
    return rotateRight(root);
}

node *rotateRightLeft(node *root) {
    root -> right = rotateRight(root -> right);
    return rotateLeft(root);
}

int getHeight(node *root) {
    if(root == NULL) return 0;
    return max(getHeight(root -> left), getHeight(root -> right)) + 1;
}

node *insert(node *root, int val) {
    if(root == NULL) {
        root = new node();
        root -> val = val;
        root -> left = root -> right = NULL;
    } else if(val < root -> val) {
        root -> left = insert(root -> left, val);
        if(getHeight(root -> left) - getHeight(root -> right) == 2)
            root = val < root -> left -> val ? rotateRight(root) : rotateLeftRight(root);
    } else {
        root -> right = insert(root -> right, val);
        if(getHeight(root -> left) - getHeight(root -> right) == -2)
            root = val > root -> right -> val ? rotateLeft(root) : rotateRightLeft(root);
    }
    return root;
}

int main() {
    int n, val;
    scanf("%d", &n);
    node *root = NULL;
    for(int i = 0; i < n; i ++) {
        scanf("%d", &val);
        root = insert(root, val);
    }
    printf("%d", root -> val);
    return 0;
}

  AVL 树的模板题 第一次写 AVL 树 还不是很会 还有那么多题没写 不会的越来越多?烦

FH

原文地址:https://www.cnblogs.com/zlrrrr/p/10361380.html

时间: 2024-10-08 13:47:13

PAT 甲级 1066 Root of AVL Tree的相关文章

PAT 甲级 1066 Root of AVL Tree (25 分)(快速掌握平衡二叉树的旋转,内含代码和注解)***

1066 Root of AVL Tree (25 分) An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this

pat(A) 1066. Root of AVL Tree

代码: #include<iostream> #include<cstdio> #include<cmath> #include<stdlib.h> #define Max(a,b) ((a)>(b)?(a):(b)) using namespace std; struct Node { int value; Node* l; Node* r; int BF; //左子树高度 - 右子树高度 void init(int v) { value=v; l=

1066. Root of AVL Tree (25)【AVL树】——PAT (Advanced Level) Practise

题目信息 1066. Root of AVL Tree (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more tha

PAT 1066 Root of AVL Tree[AVL树][难]

1066 Root of AVL Tree (25)(25 分) An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore

PTA (Advanced Level)1066 Root of AVL Tree

Root of AVL Tree An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. F

1066. Root of AVL Tree (25)

时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than o

PAT甲级题解-1066. Root of AVL Tree (25)

我嗯,这道题比较讨厌,非常难,需要用到马尔科夫随便链.高斯混合复制模型.神经网络还需要用到本人的模拟退火算法进行优化搜索,为了搜索文章避免陷入局部优化,还得用到一些Tabu Search代码比较多写的有点乱七八糟,有的还点长,都贴到laji的网站如了.布料布衣价格上涨,扣子费用降低.这样导致过程很难算,有难度,但还是有点意思的,建议自省反省考虑下,嗯么. #include <iostream> #include <cstdio> #include <algorithm>

PAT (Advanced Level) 1066. Root of AVL Tree (25)

AVL树的旋转.居然1A了.... 了解旋转方式之后,数据较小可以当做模拟写. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using name

PAT 1066 Root of AVL Tree

#include <cstdio> #include <cstdlib> class Node { public: Node* L; Node* R; int height; int data; Node(int val, Node* l = NULL, Node* r = NULL, int h = 0): data(val), L(l), R(r), height(h) {} }; inline int height(Node* node) { if (node == NULL