甲级1002 A+B for Polynomials (25)

题目描述:

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively.It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

@:
polynomial    多项式
exponents     指数
coefficients  系数

题目要求:

给出俩个多项式的指数和系数,没有给出基数,只要将指数相同的多项式进行系数相加即可。输出时按照指数从高到低的顺序输出。

注意题意,一开始没有看题意直接看的实例,忽略了负数情况相加之后系数可能为零从而不写,所以常用的单词还是得认得。。。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    int i,j,a,n;
    int con=0;
    double s[1200],b;
    int vis[1200];
    memset(s,0,sizeof(s));
    memset(vis,0,sizeof(vis));

    for(i=0;i<2;i++)
    {
        scanf("%d", &n);
        for(j=0;j<n;j++)
        {
            scanf("%d %lf",&a,&b);
            s[a]+=b;
        }
    }

    for(i=0;i<=1000;i++)
        if(s[i]!=0)
        con++;

    printf("%d", con);

    for(i=1000;i>=0;i--)
        if(s[i]!=0)
            printf(" %d %.1f",i,s[i]);

    printf("\n");

    return 0;
}
时间: 2024-10-10 01:00:37

甲级1002 A+B for Polynomials (25)的相关文章

PAT 甲级1002 A+B for Polynomials (25)

1002. A+B for Polynomials (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, an

PAT甲级1002.A+B for Polynomials (25)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000 解题思路: 由于是求两个多项式之和,并且多项式的指数是从大到小进行排列的,相加时有合并和消除的操作 因此选用了较为灵活的链表结构,将输入的第一个多项式使用链表存储起来,将第二个多项式的项依次输入, 对于加数每个项和被加数的每项的指数进行比较,如果大于其指数则插入在其前面,如果小于其指数,则比较 被加数的后一项,如果等于其指数,则将两

1002. A+B for Polynomials (25)

题目: 1002. A+B for Polynomials (25) #include<stdio.h> #define N 1000 int main() { double poly[N+1]={0}; int n,m,i; int exp; double coef; scanf("%d",&n); m=n; for(i=0;i<n;i++) { scanf(" %d %lf",&exp,&coef); poly[exp]

1002. A+B for Polynomials (25)——PAT (Advanced Level) Practise

题目信息: 1002. A+B for Polynomials (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lin

1002 A+B for Polynomials (25)(25 point(s))

problem 1002 A+B for Polynomials (25)(25 point(s)) This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polyno

1002. A+B for Polynomials (25) (数学啊 ZJU_PAT)

题目链接:http://www.patest.cn/contests/pat-a-practise/1002 This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a po

PAT Advanced 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

PAT:1002. A+B for Polynomials (25) 部分错误

#include<stdio.h> #include<stdlib.h> #include<string.h> //[warning]double 输入%lf,输出%f struct arr { int tag; double data; }arr[1005]; int main() { memset(arr,0,sizeof(arr)); int t1,t2,tmp,maxI=0; //maxI记录最多多少项 double tdata; for(int I=0 ; I

PAT (Advanced Level) 1002. A+B for Polynomials (25)

为0的不要输出. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> using namespace std; double a[1500],b[1500]; int k; int main() { for(int i=0;i<=1000;i++) a[i]=b[i]=0; int Max=-1; scanf(&q