(hdu step 4.3.2)Prime Ring Problem(n个数成环,输出两两之和为质数的所有情况)

题目:

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 467 Accepted Submission(s): 297
 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).


Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.


Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

Source

Asia 1996, Shanghai (Mainland China)


Recommend

JGShining

题目分析:

简单题。用DFS来做。需要注意的是第n个数还需要判断一下和1的和是否是一个质数。需要注意的是,和上一道题相比,这一道题是一道一维的DFS题目,而上一道是一道二维的DFS题目。所以这一道题并没有开用於包村地图信息的map[][]。

DFS的规则如下:

1)访问一个邻接的未访问结点,并将其入栈

2)如果不能执行规则1),则出栈一个元素

3)如果不能执行规则1)2),则说明遍历已经完成

代码如下:

/*
 * b.cpp
 *
 *  Created on: 2015年2月24日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

const int maxn = 21;
int value[maxn];//用来存储最后的符合要求的结果队列
bool visited[maxn];//用于标记某一个数是否访问过

int n;

/**
 * 判断某一个数n是否是质数
 */
bool isPrime(int n){
	int i;
	for(i = 2 ; i <= sqrt(n) + 0.5 ; ++i ){//如果一个数是合数,name它必然有一个因子是<sqrt(n)的
		if(n%i == 0){//如果它能整除i
			return false;//说明他不是质数
		}
	}

	return true;//说明他是质数
}

/**
 * 输出符合要求的结果队列
 */
void printValues(){
	int i;
	for(i = 1 ; i < n ; ++i){
		printf("%d ",value[i]);
	}
	printf("%d\n",value[n]);

}

/**
 * 深搜
 * cnt:目前搜索到的步数
 */
void dfs(int cnt){

	//如果已经走完n步,并切蒂n个数和第1个数之和是质数
	if(cnt == (n+1) && isPrime(value[cnt-1] + 1)){
		printValues();//name这种情况是符合要求的情况,输出所有结果
	}

	int i;
	for(i = 2 ; i <= n ; ++i){//遍历每一个数,看他是否合适加入到现在这种情况的结果队列中
		//如果i没有没访问过&&目前结果序列的最后一个数与i的和是一个质数
		if((visited[i] == false) && isPrime(i+value[cnt-1])){
			visited[i] = true;//将i标记为已经访问过
			value[cnt] = i;//将i加入到结果序列中
			dfs(cnt+1);//沿着该序列寻找下一个合适的数
			visited[i] = false;//上面一种情况已经考虑完,将i重新设置成未访问过.用于考虑下一情况
		}
	}
}

int main(){
	int counter = 1;
	while(scanf("%d",&n)!=EOF){
		memset(visited,false,sizeof(visited));
		printf("Case %d:\n",counter);
		value[1] = 1;//序列的第1个数永远是1
		visited[1] = true;
		dfs(2);//从第2步开始搜索

		printf("\n");
		counter++;

	}

	return 0;
}
时间: 2024-10-12 22:48:10

(hdu step 4.3.2)Prime Ring Problem(n个数成环,输出两两之和为质数的所有情况)的相关文章

HDU 1016:Prime Ring Problem

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25156    Accepted Submission(s): 11234 Problem Description A ring is compose of n circles as shown in diagram. Put natural num

HDU 1016 Prime Ring Problem 题解

Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1

HDU 1016 Prime Ring Problem --- 经典DFS

思路:第一个数填1,以后每个数判断该数和前一个数想加是否为素数,是则填,然后标记,近一步递归求解. 然后记得回溯,继续判断下一个和前一个数之和为素数的数. /* HDU 1016 Prime Ring Problem --- 经典DFS */ #include <cstdio> #include <cstring> int n; bool primer[45], visit[25]; //primer打素数表,visit标记是否访问 int a[25]; //数组a存储放置的数 /

【dfs】hdu 1016 Prime Ring Problem

[dfs]hdu 1016 Prime Ring Problem 题目链接 刚开始接触搜索,先来一道基本题目练练手. 注意对树的深度进行dfs dfs过程中注意回退!!! 素数提前打表判断快一些 参考代码 /*Author:Hacker_vision*/ #include<bits/stdc++.h> #define clr(k,v) memset(k,v,sizeof(k)) using namespace std; const int _max=1e3+10;//素数打表 int n,pr

HDU 1016 Prime Ring Problem (素数筛+DFS)

题目链接 题意 : 就是把n个数安排在环上,要求每两个相邻的数之和一定是素数,第一个数一定是1.输出所有可能的排列. 思路 : 先打个素数表.然后循环去搜..... 1 //1016 2 #include <cstdio> 3 #include <cstring> 4 #include <iostream> 5 6 using namespace std ; 7 8 bool vis[21]; 9 int prime[42] ,cs[21]; 10 int n ; 11

hdu 1016 Prime Ring Problem (简单DFS)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25700    Accepted Submission(s): 11453 Problem Description A ring is compose of n circles as shown in diagram. Put natural numb

hdu 1016 Prime Ring Problem (dfs)

一切见注释. #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> using namespace std; bool vis[22]; int n; int ans[22]; int top; bool isprime(int x)//判断素数 { for(int i=2;i<x;i++) if(x%i==0)return false; return

[HDU 1016]--Prime Ring Problem(回溯)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016 Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2

杭电 HDU ACM 1016 Prime Ring Problem

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 31900    Accepted Submission(s): 14108 Problem Description A ring is compose of n circles as shown in diagram. Put natural num