HDU2955Robberies

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11816    Accepted Submission(s): 4397

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only
for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then
follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

Source

问题的关键是把被抓的概率转换成安全的概率

#include<iostream>
#include<cstdio>
#include<cmath>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,c[110],i,j;
        double f,dp[11000]={0},w[110];
        scanf("%lf%d",&f,&n);
        f=1-f;
        for(i=0;i<n;i++)
           {
               scanf("%d%lf",c+i,w+i);
               w[i]=1-w[i];
           }
           dp[0]=1;
        for(i=0;i<n;i++)
        {
            for(j=10000;j>=c[i];j--)
            {
                if(dp[j]<dp[j-c[i]]*w[i])
                    dp[j]=dp[j-c[i]]*w[i];
            }
        }
        for(i=10000;i>=0;i--)
        {
            if(f<dp[i])
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

HDU2955Robberies

时间: 2024-08-01 07:35:36

HDU2955Robberies的相关文章

HDU-2955Robberies

Robberies Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they be

hdu2955---Robberies(概率做01背包)

Problem Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only

HDU2955Robberies(DP)

http://acm.hdu.edu.cn/showproblem.php?pid=2955 题目是说一小偷偷东西,第i个物品的价值是M[i],被抓的概率是p[i],现在要使得在被抓的概率在P以下时的所能偷得的最大价值. 不同于以往的01背包,这里需要将价值作为物品的大小.同时如果偷A被抓的概率是Pa,偷B被抓的概率是Pb那么偷两个物品被抓的概率就是 1-(1-Pa)*(1-Pb) 这时令DP[i][j]代表对于前i个物品偷得的价值为j时的最小的被抓的概率,这时可以得到状态转移方程: DP[i]

hdu2955Robberies 01背包水题

//给出每个银行的钱数和被抓的概率, //问在被抓概率小于p的情况下得到的钱数最多为多少 //直接以钱数为容量,以(1-pi)为为价值01背包就行 #include<cstdio> #include<cstring> #include<iostream> using namespace std ; const int maxn = 110 ; const int maxm = maxn*maxn ; double dp[maxm] ; int main() { int