PAT 1053. Path of Equal Weight (30)

1053. Path of Equal Weight (30)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to Lis defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let‘s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


深度遍历dfs,dfs函数分两部分,第一部分写达到某些条件进行返回,第二部分写遍历下一个节点。

这道题在顺序输出上有两个思路,一个是在children中添加子节点时,进行排序,使得在遍历过程中实现顺序遍历;另一个是将遍历后符合条件的结果放入一个数组中,最后在对数组排序,但是第二种方法,我在PAT上运行程序,有一个case显示段错误,在牛客网上却是正确的,我很诧异,可能是vector数组sort的问题?我不确定。

#include <bits/stdc++.h>

using namespace std;

int N, M, K;

struct Node {
    int weight;
    vector<int> children;
}nodes[102];

bool cmp(int a, int b) {
    return nodes[a].weight > nodes[b].weight;
}

bool cmp2(vector<int> vec1, vector<int>vec2) {
    int len1 = vec1.size();
    int len2 = vec2.size();
    int len = min(len1, len2);
    for(int i = 0; i < len; i++) {
        if(nodes[vec1[i]].weight < nodes[vec2[i]].weight) {
            return false;
        }
        else if(nodes[vec1[i]].weight > nodes[vec2[i]].weight) {
            return true;
        }
    }
    return true;
}

vector<int> nodesVec;
//vector<int> nodesVecs[102];
//int INDEX = 0;

void dfs(int index, int weights) {
    //cout<< "index:"<< index<< endl;
    if(weights > K) {
        return;
    }
    if(nodes[index].children.size() == 0) {
        if(weights == K) {
            //nodesVecs[INDEX] = nodesVec;
            //INDEX++;
            for(int i = 0; i < nodesVec.size(); i++) {
                if(i != 0) cout<< " ";
                cout<< nodes[nodesVec[i]].weight;
            }
            cout<< endl;
        }
        return;
    }
    for(int i = 0; i < nodes[index].children.size(); i++) {
        nodesVec.push_back(nodes[index].children[i]);
        dfs(nodes[index].children[i], weights+nodes[nodes[index].children[i]].weight);
        nodesVec.erase(nodesVec.end()-1);
    }
}

int main()
{
    cin>>N>>M>>K;
    for(int i = 0; i < N; i++) {
        cin>> nodes[i].weight;
    }
    int index, s, c;
    for(int i = 0; i < M; i++) {
        cin>> index>> s;
        for(int j = 0; j < s; j++) {
            cin>> c;
            nodes[index].children.push_back(c);
        }
        sort(nodes[index].children.begin(), nodes[index].children.end(), cmp);
    }
    nodesVec.push_back(0);
    dfs(0, nodes[0].weight);
    /*
    sort(nodesVecs, nodesVecs+INDEX, cmp2);
    for(int i = 0; i < INDEX; i++) {
        for(int j = 0; j < nodesVecs[i].size(); j++) {
            if(j != 0) cout<< " ";
            cout<< nodes[nodesVecs[i][j]].weight;
        }
        cout<< endl;
    }*/
    return 0;
}

原文地址:https://www.cnblogs.com/ACMessi/p/8444493.html

时间: 2024-08-24 16:51:06

PAT 1053. Path of Equal Weight (30)的相关文章

1053. Path of Equal Weight (30)

dfs函数携带vector形参记录搜索路径 时间限制 10 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of

PAT Advanced 1053 Path of Equal Weight (30) [树的遍历]

题目 Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L. Now given any weighted tree,

PAT:1053. Path of Equal Weight (30) AC

#include<stdio.h> #include<vector> #include<queue> #include<algorithm> using namespace std; const int MAX=1010; int n,m; //n个节点,m个非叶子节点 long long int S; //待测权值 long long int weight[MAX]; //每个节点的权值 vector<int> child[MAX]; //存储

PAT (Advanced Level) 1053. Path of Equal Weight (30)

简单DFS #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<string> #include<algorithm> using namespace std; const int maxn=100+10;

PAT甲题题解-1053. Path of Equal Weight (30)-dfs

由于最后输出的路径排序是降序输出,相当于dfs的时候应该先遍历w最大的子节点. 链式前向星的遍历是从最后add的子节点开始,最后添加的应该是w最大的子节点, 因此建树的时候先对child按w从小到大排序,然后再add建边. 水题一个,不多说了. #include <iostream> #include <algorithm> #include <cstdio> #include <string.h> using namespace std; const in

PAT 1053 Path of Equal Weight

#include <cstdio> #include <cstdlib> #include <vector> #include <algorithm> using namespace std; vector<vector<int>* > paths; class Node { public: vector<int> child; int weight; Node(int w = 0) : weight(w){} }; in

1053 Path of Equal Weight (30分)(并查集)

Given a non-empty tree with root R, and with weight W?i?? assigned to each tree node T?i??. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L. Now given any weighted tre

1053 Path of Equal Weight (30分)

1. 题目 2. 思路 定义结构体, 并且使用下标作为序号 struct node{ string weight; vector<int> children; }nodes[101]; 读取数据,并且排序children,方便输出 使用先序遍历,处理数据 3. 注意点 权重的值很大,用字符串处理,要自己写加法和比较函数 4. 代码 #include<cstdio> #include<algorithm> #include<vector> #include&l

PAT Advanced Level 1053 Path of Equal Weight

1053 Path of Equal Weight (30)(30 分) Given a non-empty tree with root R, and with weight W~i~ assigned to each tree node T~i~. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf