POJ 3616 Milking Time 动态规划法题解

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N),
and a corresponding efficiency (1 ≤efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour,
respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that
Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R

* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , andefficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

USACO 2007 November Silver

任务安排类型的动态规划法计算。

思路1:

1 按照任务的结束时间排序

2 填表,使用一维表即可,表的值表示以当前时间点为结束时间,得到的最大效率。那么就得到状态转换方程:arr[i] = max (arr[i], arr[mt[i].st]+mt[i].ef)

其中mt[i].st代表当前任务的起止时间,mt[i].ef代表当前任务的效率。

3 那么当当前计算的时间点不是某任务的结束时间,改如何处理呢?可以直接把之前计算得到的最大效率填上来就可以。

4 还有最重要的处理特殊情况-很容易栽跟斗的地方: 如果两个任务的终止时间是一样的,那么就需要比较这两个任务选择哪个比较有效,故此代码就需要特殊处理,具体看程序。

下面程序思路1的实现函数是:int getMaxEfficiency(int N, int M)

思路2:

1 记录当前的最大效率为arr[i] = mt[i].ef

2 遍历比当前任务i的终止时间更小的任务j = (0, i),如果当前任务的起止适合大于等于j的终止时间,那么这两个任务就可以一起做,故此状态转换方程为:

arr[i] = max(arr[i], arr[j]+mt[i].ef);

3 这样每个arr[i]就代表当前任务必须要选择的时候得到的最大效率,故此最终结果需要比较所有arr的值。

下面程序思路2的实现函数是:int getMaxEffi(int M)

具体选用哪种方法需要根据所给的数据而定,比如本题就应该选择思路2,因为思路2更加省内存,因为其arr可以开得和M一样大小,而思路1的arr必须开得和题目的N一样大小,故此思路2更加省内存。

最终程序如下:

#include <stdio.h>
#include <algorithm>
#include <limits.h>
#include <string.h>
using namespace std;

const int MAX_N = 1000001;
const int MAX_M = 1001;
int arr[MAX_N<<1];
struct Interval
{
	int st, end, ef;
	Interval(int s=0, int e1=0, int e2=0) : st(s), end(e1), ef(e2) {}
};
Interval mt[MAX_M];

inline int cmp(const void *a, const void *b)
{
	Interval *pa = (Interval *)a;
	Interval *pb = (Interval *)b;
	return pa->end - pb->end;
}

int getMaxEfficiency(int N, int M)
{
	memset(arr, 0, sizeof(int) * (N+1));
	if (M)
	{
		int i = mt[0].end;
		arr[i] = mt[0].ef;
	}
	for (int i = 1; i < M; i++)
	{//特殊情况处理:两个end时间完全一样的时候
		int j = mt[i-1].end;//如果是j=mt[i-1].end+1就无法处理特殊情况
		int k = mt[i].end;
		for (; j+1 < k; j++)
		{
			arr[j+1] = arr[j];
		}
		arr[k] = max(arr[k], arr[j]);//arr[k]已经存在
		arr[k] = max(arr[k], arr[mt[i].st]+mt[i].ef);
	}
	return arr[N];
}

int getMaxEffi(int M)
{
	int maxEf = 0;
	for (int i = 0; i < M; i++)
	{
		arr[i] = mt[i].ef;
		for (int j = 0; j < i; j++)
		{
			if (mt[j].end <= mt[i].st)
				arr[i] = max(arr[i], arr[j]+mt[i].ef);
		}
		maxEf = max(maxEf, arr[i]);
	}
	return maxEf;
}

int main()
{
	int N, M, R, maxN;
	while (~scanf("%d %d %d", &N, &M, &R))
	{
		maxN = 0;
		for (int i = 0; i < M; i++)
		{
			scanf("%d %d %d", &mt[i].st, &mt[i].end, &mt[i].ef);
			mt[i].end += R;
			if (mt[i].end > maxN) maxN = mt[i].end;
		}
		qsort(mt, M, sizeof(Interval), cmp);
		printf("%d\n", getMaxEfficiency(maxN, M));
	}
	return 0;
}
时间: 2024-12-29 04:54:58

POJ 3616 Milking Time 动态规划法题解的相关文章

POJ 3616 Milking Time DP题解

典型的给出区间任务和效益值,然后求最大效益值的任务取法. 属于一维DP了. 一维table记录的数据含义:到当前任务的截止时间前的最大效益值是多少. 注意, 这表示当前任务一定要选择,但是最终结果是不一定选择最后一个任务,故此最后需要遍历找到table数组的最大值,当然计算过程中使用一个数记录最终最大值也是可以的. 状态转移方程就是: tbl[i] = MAX({from tbl[0]->tbl[i-1] }+ weight[i] ),即区间0到i-1加上i的当前效益值. #include <

[2016-03-28][POJ][3616][Milking Time]

时间:2016-03-28 17:27:03 星期一 题目编号:[2016-03-28][POJ][3616][Milking Time] #include <algorithm> #include <cstdio> using namespace std; const int maxm = 1000 + 10; struct Roo{ int l,r,v; bool operator < (const Roo & a)const{ return l < a.l

POJ 3616 Milking Time 挤奶问题,带权区间DP

题目链接:POJ 3616 Milking Time Milking Time Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4837   Accepted: 2034 Description Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to sc

POJ 3616 Milking Time(加掩饰的LIS)

传送门: http://poj.org/problem?id=3616 Milking Time Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 13406   Accepted: 5655 Description Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she dec

poj 3616 Milking Time dp+树状数组

题意: 给一堆区间,每个区间有开始时间s,结束时间e,和收益w,现在要找一些区间使收益和最大,且区间之间的间隔最小为r. 分析: 这道题用dp做是简单题,用dp+树状数组做是中等题.dp问题的关键是对状态的定义.有两种方法,一:dp[k]表示按开始时间排序到第k个区间能取得的最大收益.二:dp[t]表示在时间t时能获得的最大收益.定义好状态方程就好写了这不再赘述.有趣的是这个时间复杂度.设一共有M个区间,所有区间的最大时间为L,第一种是M^2的,第二种是M*(logL+logM)的,这题M才10

POJ 3616 Milking Time 简单DP

题目链接:http://poj.org/problem?id=3616 题目大意:M个区间,每个区间一个对应一个效率值-多少升牛奶,区间可能重复,现要求取出来一些区间,要求是区间间隔不能小于R,问所能得到的牛奶量的最大值. 解题思路:决策:当前区间用或者不用.区间个数M≤1000,因此直接双循环递推即可. dp[i]:=选第i个区间情况下前i个区间能获得的牛奶最大值 dp[i] = max(dp[i], dp[j] + a[i].eff) a[j].end + r <= a[i].start 代

POJ 3616 Milking Time(最大递增子序列变形)

题目链接:http://poj.org/problem?id=3616 题目大意:给你时间N,还有M个区间每个区间a[i]都有开始时间.结束时间.生产效率(时间都不超过N),只能在给出的时间段内生产,要求合理安排时间求出最大生产价值. 解题思路:把区间按开始时间排序,于是有状态转移方程:dp[i]=max(dp[i],dp[j]+a[i].val)(前提是a[j].end+r<=a[i].start,i是区间的序号,j是i前面的区间) 相当于最大递增子序列的变形,写法差不多. 代码: 1 #in

POJ 3616 Milking Time (排序+dp)

题目链接:http://poj.org/problem?id=3616 有头牛产奶n小时(n<=1000000),但必须在m个时间段内取奶,给定每个时间段的起始时间和结束时间以及取奶质量 且两次取奶之间须间隔r-1个小时,求最大取奶质量 也就是说r = 2时 3分结束取奶,至少在5分才能取. 按照时间排序,dp[i]表示i时段的最大产奶量 1 //#pragma comment(linker, "/STACK:102400000, 102400000") 2 #include &

POJ 3616 Milking Time 动态规划

http://poj.org/problem?id=3616 题意:一个奶牛在0~N时间段内可被取奶,每次挤奶以后必须休息至少R分钟才能下次继续挤奶.有M次可以挤奶的时间段,每次取奶对应三个值:开始时间.结束时间.效率值,每次挤奶的过程不能中断.求出最大效率值. 解法:首先按照结束时间从小到大排序(按照结束时间排序方便后边的dp):dp[i]表示第i个挤奶时间段后,效率最大值. 转移方程如下: 初始化:dp[i] = data[i].eff #include <iostream> #inclu