UVA - 101 The Blocks Problem(STL,模拟)

The Blocks Problem

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

Background

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program‘‘ a robotic arm to respond to a limited set of commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are nblocks on the table (numbered from 0 to n-1) with block bi adjacent
to block bi+1 for all  as shown in the diagram
below:

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks
    that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after
    returning any blocks that are stacked on top of block a to their initial positions.
  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a,
    onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block aretain their order when moved.
  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a,
    onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.
  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is
an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output

The output should consist of the final state of the blocks world. Each original block position numbered i (  where n is
the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other
block numbers by a space. Don‘t put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:

Miguel Revilla

2000-04-06

自己打了遍紫书中的代码。

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<cstdio>
using namespace std;
const int MAXN = 30;
int n;
vector<int>pile[MAXN];

//找出木块所在的pile和height,以引用的方式返回调用者
void find_block(int x, int &p, int &h)
{
	for (p = 0; p < n; p++)
	for (h = 0; h < pile[p].size(); h++)
	{
		if (pile[p][h] == x) return;
	}
}

//把第p堆高度为h的木块上方的所有木块移回原位
void clear_above(int p, int h)
{
	for (int i = h + 1; i < pile[p].size(); i++)
	{
		int b = pile[p][i];
		pile[b].push_back(b);
	}
	pile[p].resize(h + 1);       //第p堆只应保留下标0到h的元素
}

//将第p堆高度为h及其上方的木块整体移动到p2的堆的顶部
void pile_onto(int p, int h, int p2)
{
	for (int i = h; i < pile[p].size(); i++)
		pile[p2].push_back(pile[p][i]);
	pile[p].resize(h);
}

void print()
{
	for (int i = 0; i < n; i++)
	{
		cout << i << ':';
		for (int j = 0; j < pile[i].size(); j++)
			cout << " " << pile[i][j];
		cout << endl;
	}
}

int main()
{
	cin >> n;
	int a, b;
	string s1, s2;
	for (int i = 0; i < n; i++)
		pile[i].push_back(i);

	while (cin >>s1)
	{
		if (s1 == "quit") break;
		cin >> a >> s2 >> b;
		int pa, ha, pb, hb;
		find_block(a, pa, ha);
		find_block(b, pb, hb);

		if (pa == pb) continue; //非法指令

		if (s2 == "onto") clear_above(pb, hb);  //哇喔...
		if (s1 == "move") clear_above(pa, ha);

		pile_onto(pa, ha, pb);
	}
	print();

}
时间: 2024-12-30 18:39:52

UVA - 101 The Blocks Problem(STL,模拟)的相关文章

uva 101 The Blocks Problem (模拟)

uva 101  The Blocks Problem Background Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm per

UVa 101 - The Blocks Problem STL

题目:给你n个方块,有四种操作: 1.move a onto b,把a和b上面的方块都放回原来位置,然后把a放到b上面: 2.move a over b,把a上面的放回原处,然后把a放在b所在的方块堆的上面: 3.pile a onto b,把b上面的放回原来位置,然后把a和a上面的方块整体放到b上面: 4.pile a over b,把a和a上面的方块整体放到b所在堆的上面. 分析:模拟,数据结构.观察操作,如果是move就是先把a上面的还原,如果是onto就是先把b上面的还原. 然后,就是移

uva 101 The Blocks Problem (基本算法-模拟)

 The Blocks Problem  Background Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed

uva 101 - The Blocks Problem

题目:给你n个方块,有四种操作:            1.move a onto b,把a和b上面的方块都放回原来位置,然后把a放到b上面: 2.move a over b,把a上面的放回原处,然后把a放在b所在的方块堆的上面: 3.pile a onto b,把b上面的放回原来位置,然后把a所在的堆整体放到b上面: 4.pile a over b,吧a所在堆整体放到b所在堆的上面. 分析:模拟,数据结构.观察操作,如果是move就是先把a上面的还原,如果是onto就是先把b上面的还原. 然后

101 - The Blocks Problem

题目来源:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=3&page=show_problem&problem=37   The Blocks Problem  Background Many areas of Computer Science use simple, abstract domains for both analytical and empiric

UVA - 00101 The Blocks Problem(STL,vector)

5.2.2不定长数组vector 1.vector就是一个不定长数组.不仅如此,它把一些常用操作”封装“在vector类型内部.例如,若a是一个vector,可以用a.size()读取它的大小,a.resize()改变大小,a.push_back()向尾部添加元素,a.pop_back()删除最后一个元素,a.clear()清空,a.empty测试是否为空. 2.vector是一个模板类,所以需要用vector<int>a这样的方式来声明一个vector.vector<int>是一

uvaoj 101 - The Blocks Problem(vector应用+技巧)

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=835&page=show_problem&problem=37 木块问题,模拟堆的操作.每个堆的高度不确定,用vector来做很合适(vector动态). 本题模拟四个操作: 1.move a onto b:把a和b上方的木块全部放回原来的堆,然后把a摞在b上面 2.move a over b:把a上方的木块全部放回

poj1208 The Blocks Problem,模拟,vector

题意: 从左到右有n个积木,依次编号0~n-1,要求模拟以下4种操作. 1.move a onto b a和b都是积木的编号,先将a和b上面所有的积木都放回原处,再将a放在b上. 2.move a over b a和b都是积木的编号,先将a上面所有的积木放回原处,再将a放在b上.(b上原有积木不动) 3.pile a onto b a和b都是积木的编号,将a和其上面所有的积极组成的一摞整体移动到b上.在移动前要先将b上面所有的积木都放回原处.移动的一摞积木要保持原来的顺序不变. 4.pile a

POJ 1208 The Blocks Problem

The Blocks Problem Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 5397   Accepted: 2312 Description Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of