POJ2185-Milking Grid(KMP,next数组的应用)

Milking Grid

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 6317   Accepted: 2648

Description

Every morning when they are milked, the Farmer John‘s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding
behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid,
as indicated in the sample input below.

Input

* Line 1: Two space-separated integers: R and C

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow‘s breed. Each of the R input lines has C characters with no space or other intervening character.

Output

* Line 1: The area of the smallest unit from which the grid is formed

Sample Input

2 5
ABABA
ABABA

Sample Output

2

题意:r*c的字符串,问用最小的面积的字符串去覆盖它,求最小的面积

思路:可以分行分列考虑,容易想到当只考虑行的时候,只要把每一行看成一个字符,就可以求出关于行的next数组,然后求出最短的循环串 r-next[r] ,列也是如此,所以最终答案就是 (c-P[c])*(r-F[r]) P,F分别为各自的next数组。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 10000+10;
const int maxm = 80;
char mat[maxn][maxm];
char revmat[maxm][maxn];
int r,c;
int P[maxn],F[maxn];
int gcd(int a,int b) {
    if(b==0) return a;
    else return gcd(b,a%b);
}
void getP() {
    P[1] = P[0] = 0;
    for(int i = 1; i < r; i++) {
        int j = P[i];
        while(j && strcmp(mat[i],mat[j])) j = P[j];
        if(strcmp(mat[i],mat[j])==0) P[i+1] = j+1;
        else P[i+1] = 0;
    }
}
void getF() {
    F[1] = F[0] = 0;
    for(int i = 1; i < c; i++) {
        int j = F[i];
        while(j && strcmp(revmat[i],revmat[j])) j = F[j];
        if(strcmp(revmat[i],revmat[j])==0) F[i+1] = j+1;
        else F[i+1] = 0;
    }
}
void getRev() {
    for(int i = 0; i < c; i++) {
        for(int j = 0; j < r; j++) {
            revmat[i][j] = mat[j][i];
        }
    }
}
void solve() {
    int L = r-P[r],R = c - F[c];
    printf("%d\n",L*R);
}
int main(){

    while(~scanf("%d%d",&r,&c)){
        for(int i = 0; i < r; i++) scanf("%s",mat[i]);
        getP();
        getRev();
        getF();
        solve();
    }
    return 0;
}
时间: 2024-07-29 00:15:16

POJ2185-Milking Grid(KMP,next数组的应用)的相关文章

POJ2185 Milking Grid(KMP)

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book

poj2185 Milking Grid(KMP运用)

题目链接:http://poj.org/problem?id=2185 Milking Grid Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 6249   Accepted: 2616 Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 1

poj2185 Milking Grid (最小覆盖矩阵)

//给定一个由字符组成的矩阵,求出它的面积最小的覆盖矩阵 //可以求出每一行的最小覆盖子串的长度,只要对这些长度求最小公倍数,就可以获得最小覆盖矩阵的宽度. //同理,求出每一列的最小覆盖子串的长度,再求最小公倍数,就可以获得最小覆盖矩阵的高度了. # include <stdio.h> # include <string.h> # include <algorithm> using namespace std; char a[10010][100]; int next

poj 2185 Milking Grid(KMP)

题目链接:poj 2185 Milking Grid 题目大意:给定一个N?M的矩阵,找到一个最小的r?c的矩阵,使得原矩阵可以由若干个小矩阵组成,输出r?c的值. 解题思路:将行和列分别看成字符串,然后hash,对hash后的数组分别求KMP. #include <cstdio> #include <cstring> #include <algorithm> using namespace std; typedef unsigned long long ll; con

POJ 2185 Milking Grid KMP循环节周期

题目来源:id=2185" target="_blank">POJ 2185 Milking Grid 题意:至少要多少大的子矩阵 能够覆盖全图 比如例子 能够用一个AB 组成一个 ABABAB ABABAB 能够多出来 思路:每一行求出周期 总共n个 求这n个周期的最小公倍数 假设大于m 取m 每一列求出周期 总共m个求这个m个周期的最小公倍数 假设大于n取n 答案就是2个最小公倍数的积 #include <cstdio> #include <cst

【kmp算法】poj2185 Milking Grid

先对每行求出所有可能的循环节长度(不需要整除). 然后取在所有行中都出现了的,且最小的长度为宽. 然后将每一行看作字符,对所有行求next数组,将n-next[n](对这些行来说最小的循环节长度)作为长. 最后输出长乘宽即可. #include<cstdio> #include<cstring> using namespace std; bool can[10010][80]; char s[10010][80]; int next[80],n,m,wide,NEXT[10010]

POJ2185 Milking Grid【KMP】

题目链接: http://poj.org/problem?id=2185 题目大意: 有一个N行M列的字符矩阵,这个字符矩阵可以由较小的矩阵重复平铺组成整个矩阵.问: 最小的字符子矩阵的面积为多少. 思路: 对于长度为M的每一行s[i]来说,M-Next[M],M-Next[Next[M]],-都是能通过复制,完 全覆盖字符串的可行串,而M-Next[M]是最小的.遍历每一行,求出对所有s[i]都可行的最 小字符串长度,即每一行M-Next[M]的最小公倍数lcmn.再用类似的方法求出长度为N.

【POJ2185】【KMP + HASH】Milking Grid

Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently wri

POJ 2185 Milking Grid (二维KMP next数组)

Milking Grid Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 6665   Accepted: 2824 Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75

Milking Grid poj2185

Milking Grid POJ - 2185 时限: 3000MS   内存: 65536KB   64位IO格式: %I64d & %I64u 提交 状态 已开启划词翻译 问题描述 Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns.