Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each
line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and
with one line of output for each line in input.
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
#include<iostream>
using namespace std;int main()
{
int N1=0,x=0;
int **arrayN;
cin>>N1;
arrayN=new int*[N1];
for(int i=0;i<N1;i++)
{
cin>>x;
arrayN[i]=new int [x+1];
for(int j=1;j<x+1;j++)
{
cin>>arrayN[i][j];
}
arrayN[i][0]=x;
}int *sum=new int [N1];
for(int i=0;i<N1;i++)
{
sum[i]=0;
}
for(int i=0;i<N1;i++)
{
int k=arrayN[i][0];
for(int j=1;j<k+1;j++)
{
sum[i]+=arrayN[i][j];
}
}
for(int i=0;i<N1;i++)
{
cout<<sum[i]<<endl;
}
return 0;
}
calculate the sum of some integers