hdu 1002大数(Java)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 230395    Accepted Submission(s):
44208

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.


Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


Sample Input

2 1 2 112233445566778899 998877665544332211


Sample Output

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


链接: http://acm.hdu.edu.cn/showproblem.php?pid=1002

题意:就是简单的A+B,就只要注意最后一组数据后没多余的空行就ok了,用c/c++比较麻烦,用java轻而易举就搞定了,so~,c的代码就不贴了。

 1 import java.util.*;
 2  2 import java.math.*;
 3  3 public class Main {
 4  4     public static void main(String[] args) {
 5  5         int T;
 6  6         BigDecimal a,b,c;             //定义两个大数型变量a,b
 7  7         Scanner cin = new Scanner(System.in);    
 8  8         T = cin.nextInt();
 9  9         for (int i=1; i<=T; i++){
10 10             a = cin.nextBigDecimal();
11 11             b = cin.nextBigDecimal();
12 12             //c = a.add(b);        //java的加法和c/c++的不同,四则运算都要写成这种形式
13 13             System.out.println("Case "+i+":");
14 14             System.out.println(a+" + "+b+" = "+(a.add(b)));
15 15             if (i != T)        //最后一组数据后没有多余的空行。
16 16             System.out.println();
17 17         }
18 18
19 19     }
20 20 }

时间: 2024-10-22 15:09:15

hdu 1002大数(Java)的相关文章

HDU 1002 大数A+B

A + B Problem II Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases.

抓起根本(二)(hdu 4554 叛逆的小明 hdu 1002 A + B Problem II,数字的转化(反转),大数的加法......)

数字的反转: 就是将数字倒着存下来而已.(*^__^*) 嘻嘻…… 大致思路:将数字一位一位取出来,存在一个数组里面,然后再将其变成数字,输出. 详见代码. 1 while (a) //将每位数字取出来,取完为止 2 { 3 num1[i]=a%10; //将每一个各位取出存在数组里面,实现了将数字反转 4 i++; //数组的变化 5 a/=10; 6 } 趁热打铁 例题:hdu 4554 叛逆的小明 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid

HDU 1002 A - A + B Problem II (大数问题)

原题代号:HDU 1002 原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002 原题描述: Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an int

HDU 1002 A + B Problem II(两个大数相加)

详细题目点击:http://acm.hdu.edu.cn/showproblem.php?pid=1002 Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. Input The first line of the input contains an integer T(1<=T<=20)

HDU 1250 大数加法

Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6948    Accepted Submission(s): 2285 Problem Description A Fibonacci sequence is calculated by adding the previous two members the

HDU 4927 大数运算

模板很重要 #include <cstdio> #include <cstring> #include <cstdlib> #include <iostream> #include <algorithm> using namespace std; #define MAXN 9999 #define MAXSIZE 10 #define DLEN 4 class BigInt { private: int a[500]; //可以控制大数的位数 i

hdu 1402 大数A*B模板(FFT)

hdu 1402 大数A*B模板(FFT) 题目链接 参考博客 #include <cstdio> #include <cmath> #include <cstring> #include <algorithm> #include <complex> #include <iostream> using namespace std; typedef long long ll; template <class T> void

hdu 1002 Java 大数 加法

http://acm.hdu.edu.cn/showproblem.php?pid=1002 PE   因为最后一个CASE不需要输出空行 import java.math.BigInteger; import java.util.Scanner; public class Main { public static void main(String args[]){ Scanner in = new Scanner(System.in); int ncase; ncase = in.nextIn

HDU Exponentiation 1063 Java大数题解

Exponentiation Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6973    Accepted Submission(s): 1975 Problem Description Problems involving the computation of exact values of very large magnitude