hdu1702 ACboy needs your help again!

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11427    Accepted Submission(s): 5750

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

Sample Output

1

2

2

1

1

2

None

2

3

//hdu1702
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<stack>
using namespace std;
int main()
{
  int n,m,k;
  char s[5],ss[5];
  cin>>n;
  while(n--)
  {
    cin>>m;
    cin>>s;
    if(s[2]==‘F‘)//队列
    {
      queue<int>mm;
      for(int i=0;i<m;i++)
      {
        cin>>ss;
        if(ss[0]==‘I‘)
          {
            cin>>k;
            mm.push(k);
          }
        else
        {
          if(mm.empty())
            cout<<"None"<<endl;
          else
            {
              cout<<mm.front()<<endl;
              mm.pop();
            }
        }
      }

    }
    else//栈
    {
      stack<int>mmm;
      for(int i=0;i<m;i++)
      {
        cin>>ss;
        if(ss[0]==‘I‘)
          {
            cin>>k;
            mmm.push(k);
          }
        else
        {
          if(mmm.empty())
            cout<<"None"<<endl;
          else
            {
              cout<<mmm.top()<<endl;
              mmm.pop();
            }
        }
      }
    }
  }
  return 0;
}

原文地址:https://www.cnblogs.com/-citywall123/p/9500755.html

时间: 2024-08-30 06:48:24

hdu1702 ACboy needs your help again!的相关文章

算法学习——STL和基本数据结构

第一次接触算法,只是照着自己的方法学习的,总结写的可能不是会很好,但我会努力改进. #STL容器包括顺序式容器和关联式容器. 顺序式容器: ·vector:动态数组,从末尾能快速插入与删除,直接访问任何元素. ·list:双链表,从任何地方快速插入与删除. ·deque:双向队列,从前面或后面快速插入与删除,直接访问任何元素. ·queue:队列,先进先出 ·priority_queue:优先队列,最高优先级元素总是第一个出列. ·stack:栈,先进后出. 关联式容器: ·set:集合,快速查

hdu1702(ACboy needs your help again!) 在杭电又遇坑了

点击打开链接 结题感悟: 其实吧,这题并不是很难,就是一个栈和队列的公共题,也就是按指定的方式(栈或队列)存取数据,但是为什么我自己写的栈和队列就是不能再杭电ac(一直wa啊),而用java包中的栈和队列就秒过了,问题尚未找出原因,值得思考啊.不过可以趁此学学这两个类(尽量还是自己动手写的好啊) 栈:java.util 类 Stack<E> Stack 类表示后进先出(LIFO)的对象堆栈.它通过五个操作对类 Vector 进行了扩展 ,允许将向量视为堆栈.它提供了通常的push 和 pop

ACboy needs your help again!--hdu1702

ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4429    Accepted Submission(s): 2260 Problem Description ACboy was kidnapped!! he miss his mother very much and is ve

HDUOJ P1702 ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 8599    Accepted Submission(s): 4306 Problem Description ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image

(hdu step 8.1.1)ACboy needs your help again!(STL中栈和队列的基本使用)

题目: ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 73 Accepted Submission(s): 57   Problem Description ACboy was kidnapped!! he miss his mother very much and is very

HDU 1702 ACboy needs your help again!(附加优先队列)

ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the ma

hdu 1702 ACboy needs your help again!

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1702 题目大意:按照所给要求,输出相应的数.“FIFO”指代先进先出,即队列的概念,“FILO”指代先进后出,即栈的表现形式~这里定义两个函数即可,一个队列,一个栈的调用! 1 #include <iostream> 2 #include <cstdio> 3 #include <queue> 4 #include <stack> 5 #include <

hdu1561--H - ACboy needs your help(树形dp)

H - ACboy needs your help Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from diffe

HDOJ 1702 ACboy needs your help again!

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1702 ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3512    Accepted Submission(s): 1797 Problem Description ACboy w