1003 Emergency(25 分)C语言版本(提问求解答)

1003 Emergency(25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N?1), M - the number of roads, C?1?? and C?2?? - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c?1??, c?2?? and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C?1?? to C?2??.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C?1?? and C?2??, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 21 2 1 5 30 1 10 2 20 3 11 2 12 4 1 3 4 1 

Sample Output:

2 4 

这篇我是根据其他前辈写的自己编写的,提交的时候现实只有一个正确,其余错误,希望大家帮我找一下我的错误。感谢感谢??
#include<stdio.h>
#include<math.h>
#include <stdbool.h>
#define inf 9999999
int main(){
  int n,m,c1,c2,i,j;
  int num[510],weight[510],dis[510],w[510];//num路径条数 dis最短路径长 w最终队伍数目总和
  int e[510][510];
  bool visit[510];            //标记访问
  scanf("%d%d%d%d",&n,&m,&c1,&c2);
  for(i=0;i<n;i++)
    scanf("%d",&weight[i]);   //每个顶点的数量
  for(i=0;i<n;i++){
    for(j=0;j<n;j++){
      e[i][j]=inf;            //重置矩阵e顶点
    }
    dis[i]=inf;               //重置边
  }
  int a,b,c;
  for(i=0;i<m;i++){
    scanf("%d%d%d",&a,&b,&c);
    e[a][b]=e[b][a]=c;        //输入边
  }
  dis[c1]=0;
  w[c1]=weight[c1];
  num[c1]=1;
  for(i=0;i<n;i++){
    int u=-1,minn=inf;
    for(j=0;j<n;j++){
      if(visit[j]==false&&dis[j]<minn){
        u=j;minn=dis[j];
      }
    }
    if(u==-1) break;
    visit[u]=true;
    for(int v=0;v<n;v++){
      if(visit[v]==false&&e[u][v]!=inf){
        if(dis[v]+e[u][v]<dis[v]){
          dis[v]=e[u][v]+dis[v];
          num[v]=num[u];
          w[v]=w[u]+weight[v];
        }
        else if(dis[v]+e[u][v]==dis[v]){
          num[v]=num[u]+num[v];
          if(w[u]+weight[v]>w[v]){
            w[v]=w[u]+weight[v];
          }
        }
      }
    }
  }
  printf("%d %d",num[c2],w[c2]);
  return 0;
}

原文地址:https://www.cnblogs.com/neojoker/p/9573242.html

时间: 2024-08-30 01:18:34

1003 Emergency(25 分)C语言版本(提问求解答)的相关文章

【PAT甲级】1003 Emergency (25分)

1003 Emergency (25分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

PAT 1003 Emergency (25)(25 分)

1003 Emergency (25)(25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road betwe

1003. Emergency (25)——PAT (Advanced Level) Practise

题目信息: 1003. Emergency (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads.

PAT 1003. Emergency (25)

1003. Emergency (25) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

PAT 甲级 1003. Emergency (25)

1003. Emergency (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount

1003. Emergency (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in e

PAT:1003. Emergency (25) AC

#include<stdio.h> #include<string.h> #include<algorithm> using namespace std; const int MAXV=510; const int INF=0x3fffffff; int n,m,c1,c2; bool vis[MAXV]; int G[MAXV][MAXV]; //城市间距离 int weight[MAXV]; //每个城市的救援人数 int d[MAXV]; //最短距离 int w

PAT (Advanced Level) 1003. Emergency (25)

最短路+dfs 先找出可能在最短路上的边,这些边会构成一个DAG,然后在这个DAG上dfs一次就可以得到两个答案了. 也可以对DAG进行拓扑排序,然后DP求解. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<queue> #include<vector> using nam

A1003 Emergency (25分)

一.技术总结 这是一道考查Djiktra算法的题目,主要是求解最短路径的前提下,求每个城市点权的最大值,同时最短路径的条数. 只需要在Djikstra算法的基本架构下,添加一些条件即可,点权是添加一个数组weight存储每个点的权值,然后再创建数组w,用于存储.初始化是,除了起点s,w[s]=weight[s],其余都初始化为0,使用memset(w, 0, sizeof(w)),进行初始化. 而对于最短路径的条数,设置数组num,然后初始化,num[s] = 1,其余都是初始化为0,memse