Problem A: Artificial Intelligence?

Description

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don‘t state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There‘s an electrical current of I=5A through the bulb. Which
power is generated in the bulb?".

However, half of the pupils just don‘t pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn‘t always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.

Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept ‘=‘ RealNumber [Prefix] Unit

Concept ::= ‘P‘ | ‘U‘ | ‘I‘

Prefix ::= ‘m‘ | ‘k‘ | ‘M‘

Unit ::= ‘W‘ | ‘V‘ | ‘A‘

Additional assertions:

The equal sign (`=‘) will never occur in an other context than within a data field.

There is no whitespace (tabs,blanks) inside a data field.

Either P and U, P and I, or U and I will be given.

Output

For each test case, print three lines:

a line saying ``Problem #k" where k is the number of the test case

a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output

a blank line

Sample Input

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

HINT

#include<stdio.h>
#include<string.h>
int main()
{
	int n,t,i,k=1,x;
	double P,U,I,b;
	char a[1000];
	scanf("%d",&n);
	getchar();
	x=n;
	while(n--)
	{
		P=0;
		U=0;
		I=0;
		gets(a);
		t=strlen(a);

		for(i=0;i<t;i++)
		{
			b=1;
			if(a[i]=='U'&&a[i+1]=='=')
			{
				i=i+2;
				while(a[i]>='0'&&a[i]<='9')
				{
					U=U*10+a[i]-'0';
					i++;
				}
				if(a[i]=='.')
				{
					i++;
					while(a[i]>='0'&&a[i]<='9')
					{
						b=b*0.1;
						U=U+b*(a[i]-'0');
						i++;
					}
				}
				if(a[i]=='m')
				{
					U=U/1000;
					i++;
				}
				else if(a[i]=='k')
				{
					U=U*1000;
					i++;
				}
				else if(a[i]=='M')
				{
					U=U*1000000;
					i++;
				}
			}
			else if(a[i]=='P'&&a[i+1]=='=')
			{
				i=i+2;
				while(a[i]>='0'&&a[i]<='9')
				{
					P=P*10+a[i]-'0';
					i++;
				}
				if(a[i]=='.')
				{
					i++;
					while(a[i]>='0'&&a[i]<='9')
					{
						b=b*0.1;
						P=P+b*(a[i]-'0');
						i++;
					}
				}
				if(a[i]=='m')
				{
					P=P/1000;
					i++;
				}
				else if(a[i]=='k')
				{
					P=P*1000;
					i++;
				}
				else if(a[i]=='M')
				{
					P=P*1000000;
					i++;
				}

			}
			else if(a[i]=='I'&&a[i+1]=='=')
			{
				i=i+2;
				while(a[i]>='0'&&a[i]<='9')
				{
					I=I*10+a[i]-'0';
					i++;
				}
				if(a[i]=='.')
				{
					i++;
					while(a[i]>='0'&&a[i]<='9')
					{
						b=b*0.1;
						I=I+b*(a[i]-'0');
						i++;
					}
				}
				if(a[i]=='m')
				{
					I=I/1000;
					i++;
				}
				else if(a[i]=='k')
				{
					I=I*1000;
					i++;
				}
				else if(a[i]=='M')
				{
					I=I*1000000;
					i++;
				}
			}
		}
		printf("Problem #%d\n",k);
		if(P>0&&I>0)
			printf("U=%.2lfV\n",P/I);
		else if(P>0&&U>0)
			printf("I=%.2lfA\n",P/U);
		else if(U>0&&I>0)
			printf("P=%.2lfW\n",U*I);
		if(k!=x)
			printf("\n");
		k++;
	}
	return 0;
}
时间: 2024-08-10 17:17:04

Problem A: Artificial Intelligence?的相关文章

(转) Artificial intelligence, revealed

Artificial intelligence, revealed Yann LeCunJoaquin Qui?onero Candela It's 8:00 am on a Tuesday morning. You've awoken, scanned the headlines on your phone, responded to an online post, ordered a holiday sweater for your mom, locked up the house, and

POJ 2256 Artificial Intelligence?【字符串处理】

题目链接:http://poj.org/problem?id=2256 Artificial Intelligence? Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 1323   Accepted: 643 Description Physics teachers in high school often think that problems given as text are more demanding than

UVa 537 - Artificial Intelligence?

题目:再一句话里面有P,I,U中的2个已知量,求第三个未知量.(P=I*U) 分析:字符串.利用'='定位已知量,然后将'='后面的的数字和单位分别读入处理. 说明:注意单位有m,k,M的前缀,以及小数点的处理:每组输出后面有一个空行. #include <iostream> #include <cstdlib> #include <cstring> #include <cstdio> using namespace std; char Satz[1000]

UVA之537 - Artificial Intelligence?

 Artificial Intelligence?  Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first! So they don't state a problem like ``U=

UVA Artificial Intelligence?(模拟)

Artificial Intelligence? Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Description  Artificial Intelligence?  Physics teachers in high school often think that problems given as text are more demanding than pure

ARTIFICIAL INTELLIGENCE SEARCH

ARTIFICIAL INTELLIGENCE SEARCHASSIGNMENTThis is the assignment for the sub-module Artificial Intelligence Search ofthe module Software Methodologies. The hand-out date is Monday 14thOctober 2019 and it is to be completed and handed in via DUO by 2p.m

Artificial intelligence(AI)

http://blog.jobbole.com/96676/#artificial-intelligence 人工智能(Artificial Intelligence) AIMLBot(Program#):使用 C# 编写的一个小型.快速.兼容标准.易于定制的聊天机器人,基于 AIML (人工智能标记语言 Artificial Intelligence Markup Language). SIML :智能综合智能标记语言(Synthetic Intelligence Markup Languag

Artificial Intelligence Research Methodologies 人工智能研究方法

Computer Science An Overview _J. Glenn Brookshear _11th Edition To appreciate the field of artificial intelligence, it is helpful to understand that it is being pursued along two paths. One is the engineering track in which researchers are trying to

Artificial Intelligence

//**************************************BEST-FS ALRORITHM IN ARTIFICAL INTELLIGENCE************************************** // Created by Clivia_zhou . 2014.7.29 #include <iostream> using namespace std; //define functions //Some function has'n finshie