JDOJ-1833: Network of Schools 校园网

1833: Network of Schools 校园网

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 155  Solved: 63
[Submit][Status][Web Board]

Description

一些学校连入一个电脑网络。那些学校已订立了协议:每个学校都会给其它的一些学校分发软件(称作“接受学校”)。注意如果 B 在 A 学校的分发列表中,那么 A 不必也在 B 学校的列表中。

你要写一个程序计算,根据协议,为了让网络中所有的学校都用上新软件,必须接受新软件副本的最少学校数目(子任务 A)。更进一步,我们想要确定通过给任意一个学校发送新软件,这个软件就会分发到网络中的所有学校。为了完成这个任务,我们可能必须扩展接收学校列表,使其加入新成员。计算最少需要增加几个扩展,使得不论我们给哪个学校发送新软件,它都会到达其余所有的学校(子任务 B)。一个扩展就是在一个学校的接收学校列表中引入一个新成员。

Input

输入文件的第一行包括一个整数 N:网络中的学校数目(2 <= N <= 100)。学校用前 N 个正整数标识。接下来 N 行中每行都表示一个接收学校列表(分发列表)。第 i+1 行包括学校 i 的接收学校的标识符。每个列表用 0 结束。空列表只用一个 0 表示。

Output

你的程序应该在输出文件中输出两行。第一行应该包括一个正整数:子任务 A 的解。第二行应该包括子任务 B 的解。

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2

Source

USACO

总结:tarjan + 缩点

#include<bits/stdc++.h>

using namespace std;
const int maxn = 100005;

int dfn[maxn], low[maxn], n, tot = 0, tim;
bool vis[maxn]; stack<int> s; int c[maxn], r[maxn];
int head[maxn], cnt = 1, num, color[maxn];

struct Node{
    int v, nxt;
} G[maxn];
void insert(int u, int v) {
    G[cnt] = (Node) {v, head[u]}; head[u] = cnt++;
}

void tarjan(int x) {
    vis[x] = true;
    s.push(x);
    low[x] = dfn[x] = ++tim;
    for (int i = head[x]; i; i = G[i].nxt) {
        int v = G[i].v;
        if(!dfn[v]) {
            tarjan(v);
            low[x] = min(low[x], low[v]);
        } else if(vis[v]) low[x] = min(low[x], dfn[v]);
    } if(dfn[x] == low[x]) {
        tot++;
        while(1) {
            int now = s.top();
            s.pop(); vis[now] = false;
            color[now] = tot;
            if(now == x) break;
        }
    }
}

int main() {
    scanf("%d", &n);
    for (int i = 1; i <= n; ++i) {
        for(; ;) {
            int a; scanf("%d", &a);
            if(a == 0) break; insert(i, a);
        }
    }
    for (int i = 1; i <= n; ++i) if(!dfn[i]) tarjan(i);
    int ans1 = 0, ans2 = 0;
    for (int u = 1; u <= n; ++u) {
        for (int i = head[u]; i; i = G[i].nxt) {
            int v = G[i].v;
            if(color[u] != color[v]) {
                c[color[u]]++;
                r[color[v]]++;
            }
        }
    }
    for (int i = 1; i <= tot; ++i) {
        if(!c[i]) ans1++;
        if(!r[i]) ans2++;
    }
    printf("%d\n", ans2);
    if(tot == 1) printf("0\n");
    else printf("%d\n", max(ans1, ans2));

    return 0;
}

原文地址:https://www.cnblogs.com/oi-forever/p/8910077.html

时间: 2024-10-11 16:10:16

JDOJ-1833: Network of Schools 校园网的相关文章

P2746 [USACO5.3]校园网Network of Schools// POJ1236: Network of Schools

P2746 [USACO5.3]校园网Network of Schools// POJ1236: Network of Schools 题目描述 一些学校连入一个电脑网络.那些学校已订立了协议:每个学校都会给其它的一些学校分发软件(称作“接受学校”).注意即使 B 在 A 学校的分发列表中, A 也不一定在 B 学校的列表中. 你要写一个程序计算,根据协议,为了让网络中所有的学校都用上新软件,必须接受新软件副本的最少学校数目(子任务 A).更进一步,我们想要确定通过给任意一个学校发送新软件,这个

【luogu2746】 [USACO5.3]校园网Network of Schools [tarjan 缩点]

P2746 [USACO5.3]校园网Network of Schools 任务a:找有多少个入度为0的点 任务b:找出出度为0的个数和入度为0点个数中的较大数 在一个出度为0和另一入度为0的点间连一条边 就可以同时解决两个点 故找出其中较大数 要注意最终缩为一个强连通时要特判 1 #include<bits/stdc++.h> 2 using namespace std; 3 #define ll long long 4 const int N=100+5; 5 int n,in[N],ou

POJ 1236——Network of Schools——————【加边形成强连通图】

Network of Schools Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1236 Description A number of schools are connected to a computer network. Agreements have been developed among those schools: e

Network of Schools(强连通分量+缩点) (问添加几个点最少点是所有点连接+添加最少边使图强连通)

Network of Schools Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13801   Accepted: 5505 Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a li

poj 1236 Network of Schools(tarjan+缩点)

Network of Schools Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that

【连通图|强连通分量+缩点】POJ-1236 Network of Schools

Network of Schools Time Limit: 1000MS Memory Limit: 10000K Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes softwa

POJ 1236 Network of Schools(强连通分量)

POJ 1236 Network of Schools 链接:http://poj.org/problem?id=1236 题意:有一些学校连接到一个计算机网络.这些学校之间达成了一个协议:每个学校维护着一个学校列表,它向学校列表中的学校发布软件.注意,如果学校B 在学校A 的列表中,则A 不一定在B 的列表中. 任务A:计算为使得每个学校都能通过网络收到软件,你至少需要准备多少份软件拷贝. 任务B:考虑一个更长远的任务,想确保给任意一个学校发放一个新的软件拷贝,该软件拷贝能发布到网络中的每个学

[IOI1996] USACO Section 5.3 Network of Schools(强连通分量)

nocow上的题解很好. http://www.nocow.cn/index.php/USACO/schlnet 如何求强连通分量呢?对于此题,可以直接先用floyd,然后再判断. ---------------------------------------------------------------------------------- #include<cstdio> #include<iostream> #include<algorithm> #includ

POJ 1236 Network of Schools(强联通缩点)

Network of Schools Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that