1147. Heaps (30)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line "Max Heap" if it is a max heap, or "Min Heap" for a min heap, or "Not Heap" if it is not a heap at all. Then in the next line print the tree‘s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

判断最堆只需要判断从头到尾是否是一致的双亲大于(小于)左右儿子。代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>
#define Max 1005
using namespace std;
int n,m,h[Max],flag;
bool check(bool tag)
{
    for(int i = 1;i * 2 <= n;i ++)
    {
        if(h[i] != h[i * 2] && h[i] > h[i * 2] == tag)return 0;
        if(i * 2 + 1 <= n && h[i] != h[i * 2 + 1] && h[i] > h[i * 2 + 1] == tag)return 0;
    }
    return 1;
}
void post_order(int t)
{
    if(t * 2 <= n)post_order(t * 2);
    if(t * 2 + 1 <= n)post_order(t * 2 + 1);
    if(flag ++)printf(" %d",h[t]);
    else printf("%d",h[t]);
}
int main()
{
    scanf("%d%d",&m,&n);
    while(m --)
    {
        for(int i = 1;i <= n;i ++)
        {
            scanf("%d",&h[i]);
        }
        if(check(false))puts("Max Heap");
        else if(check(true))puts("Min Heap");
        else puts("Not Heap");
        flag = 0;
        post_order(1);
        puts("");
    }
}

原文地址:https://www.cnblogs.com/8023spz/p/8933021.html

时间: 2024-08-02 02:37:42

1147. Heaps (30)的相关文章

PAT Advanced 1147 Heaps (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min h

PAT甲级——1147 Heaps【30】

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min h

PAT 1147 Heaps

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min h

A题目

1 1001 A+B Format(20) 2 1002 A+B for Polynomials(25) 3 1003 Emergency(25) 4 1004 Counting Leaves(30) 5 1005 Spell It Right(20) 6 1006 Sign In and Sign Out(25) 7 1007 Maximum Subsequence Sum(25) 8 1008 Elevator(20) 9 1009 Product of Polynomials(25) 10

日志文件ci

08/30/14 11:19:33,422 INFO =============CDN BaseLib is starting......!================ pid = 6050 [src/main.cpp:537] 08/30/14 11:19:33,422 TRACE Enter InitThreadPool() [src/main.cpp:378] 08/30/14 11:19:33,422 TRACE Exit InitThreadPool() [src/main.cpp

SQLSERVER聚集索引与非聚集索引的再次研究(上)

原文:SQLSERVER聚集索引与非聚集索引的再次研究(上) SQLSERVER聚集索引与非聚集索引的再次研究(上) 上篇主要说聚集索引 下篇的地址:SQLSERVER聚集索引与非聚集索引的再次研究(下) 由于本人还是SQLSERVER菜鸟一枚,加上一些实验的逻辑严谨性, 单写<SQLSERVER聚集索引与非聚集索引的再次研究(上)>就用了12个小时,两篇文章加起来最起码写了20个小时, 本人非常非常用心的努力完成这两篇文章,希望各位看官给点意见o(∩_∩)o 为了搞清楚索引内部工作原理和结构

PAT甲级目录

树 备注 1004 Counting Leaves   1020 Tree Traversals   1043 Is It a Binary Search Tree  判断BST,BST的性质 1053 Path of Equal Weight   1064 Complete Binary Search Tree  完全二叉树的顺序存储,BST的性质 1066 Root of AVL Tree  构建AVL树,模板题,需理解记忆 1079 Total Sales of Supply Chain

DPDK rte_malloc

参考文献:dpdk中的librte_malloc库 <深入浅出DPDK> 一.   librte_malloc 库 dpdk中的librte_malloc库提供了能够分配任意大小内存的API. 该库的目标是提供类似malloc的函数从hugepage中分配内存,以及帮助应用程序移植.通常情况下,这种类型的分配不应该在数据平面处理,因为其比基于内存池的分配更慢,并且在分配和释放时会使用锁. 1.1 Cookies 如果在配置文件中打开CONFIG_RTE_MALLOC_DEBUG, 分配的内存会

百度,宫颈癌和房和附件是房价将阿斯顿发

http://www.ebay.com/cln/vnqus-aoi2rh42/ebay/157776573019/2015.01.30 http://www.ebay.com/cln/vnqus-aoi2rh42/ebay/157776590019/2015.01.30 http://www.ebay.com/cln/vnqus-aoi2rh42/ebay/157776608019/2015.01.30 http://www.ebay.com/cln/vnqus-aoi2rh42/ebay/15