解题报告 之 POJ3686 The Windy's

解题报告 之 POJ3686 The Windy‘s

Description

The Windy‘s is a world famous toy factory that owns M top-class workshop to make toys. This year the manager receives N orders for toys. The manager knows that every order will take different amount of hours in different workshops. More
precisely, the i-th order will take Zij hours if the toys are making in the j-th workshop. Moreover, each order‘s work must be wholly completed in the same workshop. And a workshop can not switch to another order until
it has finished the previous one. The switch does not cost any time.

The manager wants to minimize the average of the finishing time of the N orders. Can you help him?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N and M (1 ≤ N,M ≤ 50).

The next N lines each contain M integers, describing the matrix Zij (1 ≤ Zij ≤ 100,000) There is a blank line before each test case.

Output

For each test case output the answer on a single line. The result should be rounded to six decimal places.

Sample Input

3

3 4
100 100 100 1
99 99 99 1
98 98 98 1

3 4
1 100 100 100
99 1 99 99
98 98 1 98

3 4
1 100 100 100
1 99 99 99
98 1 98 98

Sample Output

2.000000
1.000000
1.333333

题目大意:有n个玩具要生产,有m个工厂,每个工厂同时只能加工一个玩具,给出每个工厂生产不同玩具所需的时间,问每个玩具生产平均需要花的时间最少为多少?

分析:这个题比较抽象,不是很好想明白。首先很简单可以得到的结论是:如果只有一个工厂,那么它一定是先生产时间少的玩具,再生产时间多的玩具(想想为啥?)。那么最终这个工厂花费的时间就是
T = Z1+(Z1+Z2)+(Z1+Z2+Z3)+……+(Z1+Z2+Z3……+Zn) 。 化简得到:

T = N*Z1+(N-1)*Z2+(N-2)*Z3+……+Zn。        **

注意这个公式要从抽象的层面去看待,不要试图寻找其中的含义不然会很绕。

然后我们的大问题就转化为,将n种玩具分配给m家工厂,每家工厂都按照上述的最佳策略去生产分配到的玩具。即我们现在需要考虑的是,如何分配这n种玩具?首先很明显枚举肯定超,就不说了。那么我们怎么想呢,这里借助了最小费用流的想法。先考虑简单的情形:如果问题是每个厂家仅分配一个玩具,那么直接上最小费用流跑即可。这里变成了多个厂家,我们根据**公式,假设一个厂家分配到了一些玩具,假设为K个玩具好了,那么它就按照上面的公式运算即可。那某个厂家到底分配到了几个玩具,又是哪几个呢?这里我们交给最小费用流去试验,而没有一种确定的方法。

具体操作是,超级源点连接没一个玩具节点,负载为1,费用为0。然后将每个厂家分成n个节点,厂家j的第k个节点表示**公式中的系数k(k=1,2,3……N)应的是哪个玩具
i,当然费用对应的增长k*cost[j][i]。当然对于每一个厂家,不一定1~n都有玩具,这交给最小费用流去解决。然后每个厂家的所有节点都连接到超级汇点。最后跑最小费用流min_cost_flow(n)即可自动规划出一条最优方案。

Q:如果某玩具选择了厂家k较大的一条路但该厂家k小的路却没用怎么办?

A:不会出现这种情况,因为是最小费用流,当然会优选k小的路。

Q:如果多个玩具同时选了厂家j的系数k节点不是就重复了么?

A:不会,建图的时候厂家j的系数k节点连到des负载为1,所以不会重复。

上代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<deque>
using namespace std;

const int MAXN = 3010;
const int MAXM = 1100000;
const int INF = 0x3f3f3f3f;

struct Edge
{
	int from, to, cap, next, cost;
};

Edge edge[MAXM];
int prevv[MAXN];
int preve[MAXN];
int dist[MAXN];
int head[MAXN];
int h[MAXN];   //标号数组
int cost[MAXN][MAXN];
int src, des, cnt;

void addedge( int from, int to, int cap, int cost )
{
	edge[cnt].from = from;
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].cost = cost;
	edge[cnt].next = head[from];
	head[from] = cnt++;

	swap( from, to );

	edge[cnt].from = from;
	edge[cnt].to = to;
	edge[cnt].cap = 0;
	edge[cnt].cost = -cost;
	edge[cnt].next = head[from];
	head[from] = cnt++;
}

int SPFA( )
{
	deque<int> dq;
	bool inqueue[MAXN];
	memset( dist, INF, sizeof dist );
	memset( inqueue, 0, sizeof inqueue );
	dq.push_back( src );
	inqueue[src] = 1;
	dist[src] = 0;
	while(!dq.empty( ))
	{
		int u = dq.front( );
		dq.pop_front( );

		inqueue[u] = 0;

		for(int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].to;
			if(edge[i].cap > 0 && dist[u] + edge[i].cost + h[u] - h[v]< dist[v])
			{
				dist[v] = dist[u] + edge[i].cost + h[u] - h[v];
				prevv[v] = u;
				preve[v] = i;
				if(!inqueue[v])
				{
					if(!dq.empty( ) && dist[v] <= dist[dq.front( )])
					{
						dq.push_front( v );
					}
					else
						dq.push_back( v );
				}
			}

		}

	}
	return 0;
}

int min_cost_flow( int f )
{
	memset( h, 0, sizeof h );
	int cost = 0;
	while(f > 0)
	{
		SPFA( );
		if(dist[des] == INF)
		{
			return -1;
		}
		for(int u = 1; u < MAXN; u++)
			h[u] += dist[u];

		int d = f;
		for(int i = des; i != src; i = prevv[i])
		{
			d = min( d, edge[preve[i]].cap );
		}

		f -= d;
		cost += d*h[des];
		for(int i = des; i != src; i = prevv[i])
		{
			edge[preve[i]].cap -= d;
			edge[preve[i] ^ 1].cap += d;
		}
	}
	return cost;
}

int main( )
{
	int n, m;
	int kase;
	cin >> kase;
	src = 0;
	des = 3005;
	while(kase--)
	{
		cin >> n >> m;
		memset( head, -1, sizeof head );
		cnt = 0;
		for(int i = 1; i <= n; i++)
		{
			for(int j = 1; j <= m; j++)
			{
				cin >> cost[i][j];
			}
		}

		for(int i = 1; i <= n; i++)
		{
			addedge( src, i, 1, 0 );
		}

		for(int j = 1; j <= m; j++)
		{
			for(int k = 1; k <= n; k++)
			{
				addedge( j * 50 + k, des, 1, 0 );
				for(int i = 1; i <= n; i++)
				{
					addedge( i, j * 50 + k, 1, k*cost[i][j] );
				}
			}
		}

		printf( "%.6lf\n", min_cost_flow( n ) / (double)n );
	}
	return 0;
}

~ 代码狗祝你劳动节快乐 ~

解题报告 之 POJ3686 The Windy's

时间: 2025-01-06 21:29:24

解题报告 之 POJ3686 The Windy's的相关文章

解题报告 之 POJ3057 Evacuation

解题报告 之 POJ3057 Evacuation Description Fires can be disastrous, especially when a fire breaks out in a room that is completely filled with people. Rooms usually have a couple of exits and emergency exits, but with everyone rushing out at the same time

hdu 1541 Stars 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541 题目意思:有 N 颗星星,每颗星星都有各自的等级.给出每颗星星的坐标(x, y),它的等级由所有比它低层(或者同层)的或者在它左手边的星星数决定.计算出每个等级(0 ~ n-1)的星星各有多少颗. 我只能说,题目换了一下就不会变通了,泪~~~~ 星星的分布是不是很像树状数组呢~~~没错,就是树状数组题来滴! 按照题目输入,当前星星与后面的星星没有关系.所以只要把 x 之前的横坐标加起来就可以了

【百度之星2014~初赛(第二轮)解题报告】Chess

声明 笔者最近意外的发现 笔者的个人网站http://tiankonguse.com/ 的很多文章被其它网站转载,但是转载时未声明文章来源或参考自 http://tiankonguse.com/ 网站,因此,笔者添加此条声明. 郑重声明:这篇记录<[百度之星2014~初赛(第二轮)解题报告]Chess>转载自 http://tiankonguse.com/ 的这条记录:http://tiankonguse.com/record/record.php?id=667 前言 最近要毕业了,有半年没做

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告 勘误1:第6题第4个 if最后一个条件粗心写错了,答案应为1580. 条件应为abs(a[3]-a[7])!=1,宝宝心理苦啊.!感谢zzh童鞋的提醒. 勘误2:第7题在推断连通的时候条件写错了,后两个if条件中是应该是<=12 落了一个等于号.正确答案应为116. 1.煤球数目 有一堆煤球.堆成三角棱锥形.详细: 第一层放1个, 第二层3个(排列成三角形), 第三层6个(排列成三角形), 第四层10个(排列成三角形). -. 假设一共

[noip2011]铺地毯(carpet)解题报告

最近在写noip2011的题,备战noip,先给自己加个油! 下面是noip2011的试题和自己的解题报告,希望对大家有帮助,题目1如下 1.铺地毯(carpet.cpp/c/pas) [问题描述]为了准备一个独特的颁奖典礼,组织者在会场的一片矩形区域(可看做是平面直角坐标系的第一象限)铺上一些矩形地毯.一共有n 张地毯,编号从1 到n.现在将这些地毯按照编号从小到大的顺序平行于坐标轴先后铺设,后铺的地毯覆盖在前面已经铺好的地毯之上.地毯铺设完成后,组织者想知道覆盖地面某个点的最上面的那张地毯的

ACdream 1203 - KIDx&#39;s Triangle(解题报告)

KIDx's Triangle Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others) Submit Statistic Next Problem Problem Description One day, KIDx solved a math problem for middle students in seconds! And than he created this problem. N

解题报告 之 CodeForces 91B Queue

解题报告 之 CodeForces 91B Queue Description There are n walruses standing in a queue in an airport. They are numbered starting from the queue's tail: the 1-st walrus stands at the end of the queue and the n-th walrus stands at the beginning of the queue.

解题报告 之 POJ1226 Substrings

解题报告 之 POJ1226 Substrings Description You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings. Input The first li

解题报告 之 UVA563 Crimewave

解题报告 之 UVA563 Crimewave Description Nieuw Knollendam is a very modern town. This becomes clear already when looking at the layout of its map, which is just a rectangular grid of streets and avenues. Being an important trade centre, Nieuw Knollendam a